mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/qt4 to 4.8.5-6
This commit is contained in:
parent
2cd43062ba
commit
288473957f
2 changed files with 46 additions and 3 deletions
|
@ -10,7 +10,7 @@
|
|||
|
||||
pkgname=qt4
|
||||
pkgver=4.8.5
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -38,7 +38,7 @@ source=("http://download.qt-project.org/official_releases/qt/4.8/${pkgver}/${_pk
|
|||
'qtconfig-qt4.desktop' 'assistant-qt4.desktop' 'designer-qt4.desktop'
|
||||
'linguist-qt4.desktop' 'qdbusviewer-qt4.desktop'
|
||||
'improve-cups-support.patch'
|
||||
'qtbug-31579.patch' 'qtbug-32534.patch')
|
||||
'qtbug-31579.patch' 'qtbug-32534.patch' 'qtbug-32908.patch')
|
||||
md5sums=('1864987bdbb2f58f8ae8b350dfdbe133'
|
||||
'a16638f4781e56e7887ff8212a322ecc'
|
||||
'8a28b3f52dbeb685d4b69440b520a3e1'
|
||||
|
@ -47,7 +47,8 @@ md5sums=('1864987bdbb2f58f8ae8b350dfdbe133'
|
|||
'b859c5673e5098c39f72b2252947049e'
|
||||
'c439c7731c25387352d8453ca7574971'
|
||||
'6ed8d26a8e4a9bba1f6c08fb99cc8357'
|
||||
'bb0e0fa6ba953fa590d81ac612374e11')
|
||||
'bb0e0fa6ba953fa590d81ac612374e11'
|
||||
'db343dcae522bc90d802ad1e83b7f5dd')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -59,6 +60,8 @@ prepare() {
|
|||
patch -p1 -i "${srcdir}"/qtbug-31579.patch
|
||||
# (FS#36394) (QTBUG#32534)
|
||||
patch -p1 -i "${srcdir}"/qtbug-32534.patch
|
||||
# (FS#36947) (QTBUG#32908)
|
||||
patch -p1 -i "${srcdir}"/qtbug-32908.patch
|
||||
|
||||
export CXXFLAGS="$CXXFLAGS -fno-strict-volatile-bitfields"
|
||||
|
||||
|
|
40
extra/qt4/qtbug-32908.patch
Normal file
40
extra/qt4/qtbug-32908.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
From 0c03af0d4d928bdbb32b09eedb1dba3ce59e5278 Mon Sep 17 00:00:00 2001
|
||||
From: Gatis Paeglis <gatis.paeglis@digia.com>
|
||||
Date: Sat, 31 Aug 2013 21:22:47 +0200
|
||||
Subject: [PATCH] Revert "QTBUG-15319: fix shortcuts with secondary Xkb layout."
|
||||
|
||||
The change which attempted to fix QTBUG-15319 broke keyboard
|
||||
shortcuts for non latin keyboard layouts.
|
||||
|
||||
This patch reverts QTBUG-15319 (f45cdeda8) since it caused a
|
||||
regression.
|
||||
|
||||
Task-number: QTBUG-32908
|
||||
|
||||
Change-Id: I47d7984fa7986d5218d1f3ff1fc36d2ec67c9ba7
|
||||
Reviewed-by: David Faure <david.faure@kdab.com>
|
||||
---
|
||||
src/gui/kernel/qkeymapper_x11.cpp | 5 +----
|
||||
1 files changed, 1 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/gui/kernel/qkeymapper_x11.cpp b/src/gui/kernel/qkeymapper_x11.cpp
|
||||
index 005ff3f..7daa41d 100644
|
||||
--- a/src/gui/kernel/qkeymapper_x11.cpp
|
||||
+++ b/src/gui/kernel/qkeymapper_x11.cpp
|
||||
@@ -282,12 +282,9 @@ QList<int> QKeyMapperPrivate::possibleKeysXKB(QKeyEvent *event)
|
||||
|
||||
// first, translate key only using lock modifiers (there are no Qt equivalents for these, so we must
|
||||
// always use them when determining the baseKeySym)
|
||||
- // Note: the Xkb group to be used for the conversion keycode->keysym has to be given to
|
||||
- // XkbLookupKeySym(). This information is contained in the bits 8 to 15 of xmodifiers.
|
||||
- // See https://bugreports.qt-project.org/browse/QTBUG-15319 .
|
||||
KeySym baseKeySym;
|
||||
uint consumedModifiers;
|
||||
- if (!XkbLookupKeySym(X11->display, xkeycode, (xmodifiers & (0xff00 | LockMask | qt_num_lock_mask)),
|
||||
+ if (!XkbLookupKeySym(X11->display, xkeycode, (xmodifiers & (LockMask | qt_num_lock_mask)),
|
||||
&consumedModifiers, &baseKeySym))
|
||||
return QList<int>();
|
||||
|
||||
--
|
||||
1.7.1
|
||||
|
Loading…
Reference in a new issue