mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added extra/js185
This commit is contained in:
parent
8e65fab4a2
commit
288fd54323
2 changed files with 80 additions and 0 deletions
47
extra/js185/PKGBUILD
Normal file
47
extra/js185/PKGBUILD
Normal file
|
@ -0,0 +1,47 @@
|
|||
# $Id: PKGBUILD 183425 2013-04-21 22:11:08Z heftig $
|
||||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix mozilla stupidity
|
||||
|
||||
pkgname=js185
|
||||
pkgver=1.0.0
|
||||
pkgrel=2
|
||||
pkgdesc="JavaScript interpreter and libraries (legacy)"
|
||||
arch=(i686 x86_64)
|
||||
url="https://developer.mozilla.org/En/SpiderMonkey/1.8.5"
|
||||
license=(MPL)
|
||||
depends=(nspr gcc-libs)
|
||||
makedepends=(python2 zip)
|
||||
options=(!staticlibs)
|
||||
source=(http://ftp.mozilla.org/pub/mozilla.org/js/$pkgname-$pkgver.tar.gz
|
||||
ihatemozilla.patch)
|
||||
md5sums=('a4574365938222adca0a6bd33329cb32'
|
||||
'9add35f52965e4643b9235307d0d6cc5')
|
||||
|
||||
build() {
|
||||
cd js-1.8.5/js/src
|
||||
|
||||
# _FORTIFY_SOURCE causes configure error
|
||||
unset CPPFLAGS
|
||||
|
||||
patch -p3 -i "$srcdir/ihatemozilla.patch"
|
||||
|
||||
./configure --prefix=/usr --with-system-nspr \
|
||||
--enable-threadsafe
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd js-1.8.5/js/src
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm755 shell/js "$pkgdir/usr/bin/js"
|
||||
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -x {} +
|
||||
|
||||
# Bad symlinks (absolute, including DESTDIR!)
|
||||
cd "$pkgdir/usr/lib"
|
||||
ln -sf libmozjs185.so.1.0.0 libmozjs185.so.1.0
|
||||
ln -sf libmozjs185.so.1.0 libmozjs185.so
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
33
extra/js185/ihatemozilla.patch
Normal file
33
extra/js185/ihatemozilla.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
diff -urN js-1.8.5.orig/js/src/configure js-1.8.5/js/src/configure
|
||||
--- js-1.8.5.orig/js/src/configure 2011-03-31 13:08:36.000000000 -0600
|
||||
+++ js-1.8.5/js/src/configure 2011-11-29 18:13:45.000000000 -0700
|
||||
@@ -13322,13 +13322,9 @@
|
||||
case "$target_cpu" in
|
||||
arm*)
|
||||
if test "$GNU_CC"; then
|
||||
- cat >> confdefs.h <<\EOF
|
||||
-#define MOZ_ARM_ARCH 1
|
||||
-EOF
|
||||
-
|
||||
- CFLAGS="$CFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
|
||||
- CXXFLAGS="$CXXFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
|
||||
- ASFLAGS="$ASFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
+ ASFLAGS="$ASFLAGS"
|
||||
else
|
||||
{ echo "configure: error: --with-cpu-arch=armv7 is not supported for non-GNU toolchains" 1>&2; exit 1; }
|
||||
fi
|
||||
@@ -13341,9 +13337,9 @@
|
||||
case "$target_cpu" in
|
||||
arm*)
|
||||
if test "$GNU_CC"; then
|
||||
- CFLAGS="$CFLAGS -march=armv5te -mthumb-interwork -msoft-float"
|
||||
- CXXFLAGS="$CXXFLAGS -march=armv5te -mthumb-interwork -msoft-float"
|
||||
- ASFLAGS="$ASFLAGS -march=armv5te -mthumb-interwork -msoft-float"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
+ ASFLAGS="$ASFLAGS"
|
||||
fi
|
||||
;;
|
||||
esac
|
Loading…
Reference in a new issue