mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/python2 to 2.7.16-1
This commit is contained in:
parent
a249729a12
commit
28ae6cb094
2 changed files with 5 additions and 69 deletions
|
@ -7,8 +7,8 @@
|
||||||
# - configure with --without-lto
|
# - configure with --without-lto
|
||||||
|
|
||||||
pkgname=python2
|
pkgname=python2
|
||||||
pkgver=2.7.15
|
pkgver=2.7.16
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
_pybasever=2.7
|
_pybasever=2.7
|
||||||
pkgdesc="A high-level scripting language"
|
pkgdesc="A high-level scripting language"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
|
@ -21,11 +21,9 @@ optdepends=('tk: for IDLE'
|
||||||
'python2-setuptools'
|
'python2-setuptools'
|
||||||
'python2-pip')
|
'python2-pip')
|
||||||
conflicts=('python<3')
|
conflicts=('python<3')
|
||||||
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
|
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc})
|
||||||
descr_ref.patch)
|
sha512sums=('16e814e8dcffc707b595ca2919bd2fa3db0d15794c63d977364652c4a5b92e90e72b8c9e1cc83b5020398bd90a1b397dbdd7cb931c49f1aa4af6ef95414b43e0'
|
||||||
sha512sums=('27ea43eb45fc68f3d2469d5f07636e10801dee11635a430ec8ec922ed790bb426b072da94df885e4dfa1ea8b7a24f2f56dd92f9b0f51e162330f161216bd6de6'
|
'SKIP')
|
||||||
'SKIP'
|
|
||||||
'2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d')
|
|
||||||
validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
|
validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -56,10 +54,6 @@ prepare() {
|
||||||
|
|
||||||
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
|
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
|
||||||
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
|
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
|
||||||
|
|
||||||
# FS#48761
|
|
||||||
# http://bugs.python.org/issue25750
|
|
||||||
patch -Np1 -i ../descr_ref.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,58 +0,0 @@
|
||||||
When calling tp_descr_get(self, obj, type), make sure that we own a reference to "self"
|
|
||||||
|
|
||||||
diff -ru Python-2.7.9/Objects/typeobject.c Python-2.7.9-fixed//Objects/typeobject.c
|
|
||||||
--- Python-2.7.9/Objects/typeobject.c 2014-12-10 16:59:57.000000000 +0100
|
|
||||||
+++ Python-2.7.9-fixed//Objects/typeobject.c 2015-11-27 20:39:58.276156800 +0100
|
|
||||||
@@ -2542,6 +2542,7 @@
|
|
||||||
PyTypeObject *metatype = Py_TYPE(type);
|
|
||||||
PyObject *meta_attribute, *attribute;
|
|
||||||
descrgetfunc meta_get;
|
|
||||||
+ PyObject* res;
|
|
||||||
|
|
||||||
if (!PyString_Check(name)) {
|
|
||||||
PyErr_Format(PyExc_TypeError,
|
|
||||||
@@ -2563,6 +2564,7 @@
|
|
||||||
meta_attribute = _PyType_Lookup(metatype, name);
|
|
||||||
|
|
||||||
if (meta_attribute != NULL) {
|
|
||||||
+ Py_INCREF(meta_attribute);
|
|
||||||
meta_get = Py_TYPE(meta_attribute)->tp_descr_get;
|
|
||||||
|
|
||||||
if (meta_get != NULL && PyDescr_IsData(meta_attribute)) {
|
|
||||||
@@ -2570,10 +2572,11 @@
|
|
||||||
* writes. Assume the attribute is not overridden in
|
|
||||||
* type's tp_dict (and bases): call the descriptor now.
|
|
||||||
*/
|
|
||||||
- return meta_get(meta_attribute, (PyObject *)type,
|
|
||||||
+ res = meta_get(meta_attribute, (PyObject *)type,
|
|
||||||
(PyObject *)metatype);
|
|
||||||
+ Py_DECREF(meta_attribute);
|
|
||||||
+ return res;
|
|
||||||
}
|
|
||||||
- Py_INCREF(meta_attribute);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* No data descriptor found on metatype. Look in tp_dict of this
|
|
||||||
@@ -2581,6 +2584,7 @@
|
|
||||||
attribute = _PyType_Lookup(type, name);
|
|
||||||
if (attribute != NULL) {
|
|
||||||
/* Implement descriptor functionality, if any */
|
|
||||||
+ Py_INCREF(attribute);
|
|
||||||
descrgetfunc local_get = Py_TYPE(attribute)->tp_descr_get;
|
|
||||||
|
|
||||||
Py_XDECREF(meta_attribute);
|
|
||||||
@@ -2588,11 +2592,12 @@
|
|
||||||
if (local_get != NULL) {
|
|
||||||
/* NULL 2nd argument indicates the descriptor was
|
|
||||||
* found on the target object itself (or a base) */
|
|
||||||
- return local_get(attribute, (PyObject *)NULL,
|
|
||||||
+ res = local_get(attribute, (PyObject *)NULL,
|
|
||||||
(PyObject *)type);
|
|
||||||
+ Py_DECREF(attribute);
|
|
||||||
+ return res;
|
|
||||||
}
|
|
||||||
|
|
||||||
- Py_INCREF(attribute);
|
|
||||||
return attribute;
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in a new issue