mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/libreoffice-fresh to 7.2.1-2
This commit is contained in:
parent
86a5c3d9e0
commit
28e3fb9518
2 changed files with 45 additions and 1 deletions
|
@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
|
|||
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
|
||||
_LOver=7.2.1.2
|
||||
pkgver=7.2.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -70,6 +70,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
skia-freetype2.11.patch
|
||||
pld-skia-patches.patch
|
||||
kf5_fix.patch
|
||||
soffice-template.desktop.in
|
||||
libreoffice-fresh.sh libreoffice-fresh.csh)
|
||||
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -121,6 +122,7 @@ sha256sums=('7a16b46fb397e72fce2d06b786025f321da12ccc39c9976510674ff9119b0a4d'
|
|||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'1f9506cff0c3f3638de6d1ff76f679c301f0e9aa2ab735b26274c42f16345e8e'
|
||||
'55710ab0200784c69d49c38b9be6b447502c818ca828efc825355038c8980eea'
|
||||
'89fb019756c1db7fa382d8ed325b36d1d02e525ccee77c59fb15abe2b61f1770'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
|
||||
'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
|
||||
|
@ -148,6 +150,9 @@ prepare() {
|
|||
cp "${srcdir}"/skia-freetype2.11.patch external/skia
|
||||
patch -Np1 -i "${srcdir}"/pld-skia-patches.patch
|
||||
|
||||
# https://bugs.documentfoundation.org/show_bug.cgi?id=144037
|
||||
patch -Np1 -i "${srcdir}"/kf5_fix.patch
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
case "$i" in
|
||||
|
|
39
extra/libreoffice-fresh/kf5_fix.patch
Normal file
39
extra/libreoffice-fresh/kf5_fix.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
From 7c1f4284562e905372b5c14b6017f1eb438f54b5 Mon Sep 17 00:00:00 2001
|
||||
From: Jan-Marek Glogowski <glogow@fbihome.de>
|
||||
Date: Thu, 26 Aug 2021 14:23:29 +0200
|
||||
Subject: tdf#144037 Qt5 just close popup with mouse outside
|
||||
|
||||
How hard could it be to close a popup window when losing focus or
|
||||
clicking outside of it (AKA tdf#143114 problem 3)? At least with
|
||||
Qt it feels like solving an NP problem...
|
||||
|
||||
So don't always force-close the popup window if clicked anywhere
|
||||
on it. Seems to be consistent with gen and gtk3.
|
||||
|
||||
Change-Id: Ia1c231c0b51a55bec2c587feffcf14bb4b4cee55
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/121093
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
|
||||
(cherry picked from commit a1a83b6b3b4459de353e0cdc8cdf402370c0a5c4)
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/121064
|
||||
Reviewed-by: Adolfo Jayme Barrientos <fitojb@ubuntu.com>
|
||||
---
|
||||
vcl/qt5/Qt5Widget.cxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/vcl/qt5/Qt5Widget.cxx b/vcl/qt5/Qt5Widget.cxx
|
||||
index 864701340ad3..64ad4f7539c4 100644
|
||||
--- a/vcl/qt5/Qt5Widget.cxx
|
||||
+++ b/vcl/qt5/Qt5Widget.cxx
|
||||
@@ -182,7 +182,7 @@ void Qt5Widget::mousePressEvent(QMouseEvent* pEvent)
|
||||
{
|
||||
handleMousePressEvent(m_rFrame, pEvent);
|
||||
if (m_rFrame.isPopup()
|
||||
- || !geometry().translated(geometry().topLeft() * -1).contains(pEvent->pos()))
|
||||
+ && !geometry().translated(geometry().topLeft() * -1).contains(pEvent->pos()))
|
||||
closePopup();
|
||||
}
|
||||
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
Loading…
Reference in a new issue