Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs

This commit is contained in:
Mike Brown 2012-05-04 12:59:36 -04:00
commit 29051ccf23
13 changed files with 498 additions and 33 deletions

16
README
View file

@ -16,3 +16,19 @@ packages that are not available in either upstream or AUR.
These packages are meant to be built on Arch Linux ARM, found at
http://archlinuxarm.org
Layout:
core, extra, community: These folders contain packages only found in the
upstream repositories by the same name. Exceptions are packages such as our
kernels or other packages we feel belong within the scope of these repos.
aur: Contains packages that come from only from the AUR.
alarm: Contains packages that are our own, or changed significantly enough
from upstream or AUR to no longer qualify as being in those respective
locations here.
New packages should be placed in the correct locations, with the packages base
folder name reflecting the 'pkgname' for single-package PKGBUILDs, or 'pkgbase'
for multiple-package PKGBUILDs. In the case of non-alarm packages, naming should
exactly match the base folder or package name as used upstream or in the AUR,
respectively. This will ensure correct package->version matching in the build
system update routines.

View file

@ -3,20 +3,25 @@
plugrel=1
pkgname=pianobar
pkgver=2012.01.10
pkgver=2012.04.24
pkgrel=2
pkgdesc="console-based frontend for Pandora (official version)"
url="http://6xq.net/0017"
arch=('i686' 'x86_64')
license=('MIT')
depends=('libao' 'faad2' 'libmad' 'gnutls')
source=(http://6xq.net/media/00/16/pianobar-$pkgver.tar.bz2)
source=(http://6xq.net/media/00/16/pianobar-$pkgver.tar.bz2
protocol-fix.patch)
sha256sums=('1286005b14ef58ea5b7baece054e772761e6351fdeceadd3a69e0a7c8b9bf28e'
'39f30666783d28ccb0bdfe985738bb06c9545e6f0f42e3eba905da2d202de2f7')
_builddir="$pkgname-$pkgver"
build() {
cd "$_builddir"
# temporary fix from https://gist.github.com/2500616/654f1869da5698696ce60cb8a7fe3cae0f4dfd25
patch -p 1 -i ../protocol-fix.patch
make
}
@ -26,5 +31,3 @@ package() {
make DESTDIR=$pkgdir PREFIX=/usr install
install -vDm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
md5sums=('448c57d65c71158674e8b30a8cfa217e')

View file

@ -0,0 +1,58 @@
diff --git a/src/libpiano/piano.c b/src/libpiano/piano.c
index 342e4ec..b70477e 100644
--- a/src/libpiano/piano.c
+++ b/src/libpiano/piano.c
@@ -42,7 +42,7 @@ THE SOFTWARE.
#include "crypt.h"
#include "config.h"
-#define PIANO_PROTOCOL_VERSION "33"
+#define PIANO_PROTOCOL_VERSION "34"
#define PIANO_RPC_HOST "www.pandora.com"
#define PIANO_RPC_PORT "80"
#define PIANO_RPC_PATH "/radio/xmlrpc/v" PIANO_PROTOCOL_VERSION "?"
@@ -272,6 +272,7 @@ PianoReturn_t PianoRequest (PianoHandle_t *ph, PianoRequest_t *req,
"<?xml version=\"1.0\"?><methodCall>"
"<methodName>listener.authenticateListener</methodName>"
"<params><param><value><int>%lu</int></value></param>"
+ "<param><value><string></string></value></param>"
/* user */
"<param><value><string>%s</string></value></param>"
/* password */
diff --git a/src/main.c b/src/main.c
index 43f3ffc..9a637cf 100644
--- a/src/main.c
+++ b/src/main.c
@@ -77,10 +77,31 @@ static bool BarMainLoginUser (BarApp_t *app) {
WaitressReturn_t wRet;
PianoRequestDataLogin_t reqData;
bool ret;
+ WaitressHandle_t waithSync;
+ char *syncTime;
+ unsigned long int syncTimeInt;
+
+ /* skip sync step by fetching time from somewhere else */
+ WaitressInit (&waithSync);
+ WaitressSetUrl (&waithSync, "http://ridetheclown.com/s2/synctime.php");
+ if (app->settings.proxy != NULL && strlen (app->settings.proxy) > 0) {
+ WaitressSetProxy (&waithSync, app->settings.proxy);
+ }
+ wRet = WaitressFetchBuf (&waithSync, &syncTime);
+ WaitressFree (&waithSync);
+ if (wRet != WAITRESS_RET_OK) {
+ BarUiMsg (&app->settings, MSG_ERR, "Unable to sync: %s\n",
+ WaitressErrorToStr (wRet));
+ return false;
+ }
+
+ syncTimeInt = strtoul (syncTime, NULL, 0);
+ app->ph.timeOffset = time (NULL) - syncTimeInt;
+ free (syncTime);
reqData.user = app->settings.username;
reqData.password = app->settings.password;
- reqData.step = 0;
+ reqData.step = 1;
BarUiMsg (&app->settings, MSG_INFO, "Login... ");
ret = BarUiPianoCall (app, PIANO_REQUEST_LOGIN, &reqData, &pRet, &wRet);

112
extra/digikam/PKGBUILD Normal file
View file

@ -0,0 +1,112 @@
# $Id: PKGBUILD 158119 2012-05-03 02:26:57Z foutrelis $
# Maintainer: Ronald van Haren <ronald@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix qreal so it builds on ARM
plugrel=1
pkgbase=digikam
pkgname=('digikam' 'kipi-plugins' 'libkface' 'libkgeomap' 'libkvkontakte' 'libmediawiki')
pkgver=2.5.0
pkgrel=6
pkgdesc="Digital photo management application for KDE"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.digikam.org/"
makedepends=('kdepimlibs' 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane' 'liblqr'
'kdeedu-marble' 'opencv' 'boost' 'libgpod' 'qjson' 'hugin'
'cmake' 'automoc4' 'doxygen')
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
"boost148.patch" "libkipi140.patch" "digikam-2.5.0-gcc-4.7.0.patch" "qreal-float.patch")
sha1sums=('6cadb838669d1bdcbd6abb677889f7d68d696383'
'93853084905b21309c46ce7d585021e76283d429'
'8a8f624fd0ca768a9dcd706405eb6e4944892d87'
'5058831a4f1209468d0249c03f0e243f176f995a'
'236a7e1436d2ca05205c6dffcfa881be2cc6e91b')
build() {
cd "${srcdir}"
pushd ${pkgname}-${pkgver}/core
patch -Np0 -i ${srcdir}/boost148.patch
patch -Np1 -i ${srcdir}/libkipi140.patch
cd ..
patch -Np1 -i ${srcdir}/qreal-float.patch
popd
patch -Np0 -i ${srcdir}/digikam-2.5.0-gcc-4.7.0.patch
mkdir build
cd build
# Use internal lensfun (FS#21816)
cmake ../${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DLENSFUN_LIBRARY="" \
-DLENSFUN_INCLUDE_DIR=""
make
}
package_digikam() {
pkgdesc="Digital photo management application for KDE"
depends=('kdebase-runtime' 'kdepimlibs' 'libgphoto2' 'opencv' 'liblqr'
'libkipi' 'libkexiv2' 'libkdcraw' 'libkface' 'libkgeomap')
optdepends=('kipi-plugins: for more extras and plugins')
install=digikam.install
cd "${srcdir}"/build/core
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/doc
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/po
make DESTDIR="${pkgdir}" install
}
package_libkface() {
pkgdesc="A Qt/C++ wrapper around LibFace library to perform face recognition and detection over pictures"
depends=('kdelibs' 'opencv')
cd "${srcdir}"/build/extra/libkface
make DESTDIR="${pkgdir}" install
}
package_libkgeomap() {
pkgdesc="A wrapper around world map components for browsing and arranging photos on a map"
depends=('kdelibs' 'kdeedu-marble' 'libkexiv2')
cd "${srcdir}"/build/extra/libkgeomap
make DESTDIR="${pkgdir}" install
}
package_libkvkontakte() {
pkgdesc="KDE C++ library for asynchronous interaction with vkontakte.rusocial network"
depends=('kdelibs' 'qjson')
cd "${srcdir}"/build/extra/libkvkontakte
make DESTDIR="${pkgdir}" install
}
package_libmediawiki() {
pkgdesc="A KDE C++ interface for MediaWiki based web service as wikipedia.org"
depends=('kdelibs')
cd "${srcdir}"/build/extra/libmediawiki
make DESTDIR="${pkgdir}" install
}
package_kipi-plugins() {
pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
depends=('kdebase-runtime' 'kdepimlibs' 'libkdcraw' 'libkipi' 'libksane'
'opencv' 'qjson' 'libkvkontakte' 'libkexiv2')
optdepends=('libkgeomap'
'libmediawiki'
'libgpod'
'hugin')
install=kipi-plugins.install
cd "${srcdir}"/build/extra/kipi-plugins
make DESTDIR="${pkgdir}" install
}

View file

@ -0,0 +1,65 @@
diff -u libs/database/imagehistory/imagehistorygraph_boost.h ../../digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h
--- libs/database/imagehistory/imagehistorygraph_boost.h 2012-01-05 08:32:19.837388059 -0500
+++ ../../digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h 2012-01-05 09:17:27.798341897 -0500
@@ -1198,7 +1198,7 @@
{
boost::dag_shortest_paths(graph, v,
// we provide a constant weight of 1
- weight_map(boost::ref_property_map<edge_t,int>(weight)).
+ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
// Store distance and predecessors in QMaps, wrapped to serve as property maps
distance_map(VertexIntMapAdaptor(distances)).
predecessor_map(VertexVertexMapAdaptor(predecessors))
@@ -1218,7 +1218,7 @@
{
boost::dag_shortest_paths(graph, v,
// we provide a constant weight of 1
- weight_map(boost::ref_property_map<edge_t,int>(weight)).
+ weight_map(boost::ref_property_map<typename boost::graph_traits<GraphType>::edge_descriptor,int>(weight)).
// Invert the default compare method: With greater, we get the longest path
distance_compare(std::greater<int>()).
// will be returned if a node is unreachable
@@ -1384,14 +1384,15 @@
template <class GraphType, typename VertexLessThan>
class lessThanMapEdgeToTarget
{
+ typedef typename boost::graph_traits<GraphType>::edge_descriptor edge_descriptor;
public:
lessThanMapEdgeToTarget(const GraphType& g, VertexLessThan vertexLessThan)
: g(g), vertexLessThan(vertexLessThan) {}
const GraphType& g;
VertexLessThan vertexLessThan;
- bool operator()(const Edge& a, const Edge& b)
+ bool operator()(const edge_descriptor& a, const edge_descriptor& b)
{
- return vertexLessThan(boost::target(a.toEdge(), g), boost::target(b.toEdge(), g));
+ return vertexLessThan(boost::target(a, g), boost::target(b, g));
}
};
@@ -1402,20 +1403,21 @@
{
typedef std::pair<Vertex, QList<Edge> > VertexInfo;
- QList<Edge> outEdges;
+ typedef typename boost::graph_traits<IncidenceGraph>::edge_descriptor edge_descriptor;
+ QList<edge_descriptor> outEdges;
std::vector<VertexInfo> stack;
boost::put(color, u, boost::gray_color);
vis.discover_vertex(u, g);
- outEdges = toEdgeList(boost::out_edges(u, g));
+ outEdges = toList<edge_descriptor>(boost::out_edges(u, g));
// Sort edges. The lessThan we have takes vertices, so we use a lessThan which
// maps the given edges to their targets, and calls our vertex lessThan.
qSort(outEdges.begin(), outEdges.end(), lessThanMapEdgeToTarget<IncidenceGraph, LessThan>(g, lessThan));
- foreach(const Edge& e, outEdges)
+ foreach(const edge_descriptor& e, outEdges)
{
- Vertex v = boost::target(e.toEdge(), g);
+ Vertex v = boost::target(e, g);
vis.examine_edge(e, g);
boost::default_color_type v_color = boost::get(color, v);
if (v_color == boost::white_color)

View file

@ -0,0 +1,63 @@
--- digikam-2.5.0/core/digikam/album/albummanager.h 2012-01-03 02:32:41.000000000 +0200
+++ digikam-2.5.0/core/digikam/album/albummanager.h 2012-01-05 03:18:16.291639995 +0200
@@ -831,7 +831,7 @@
{
foreach(T* t, list)
{
- append(AlbumPointer<T>(t));
+ this->append(AlbumPointer<T>(t));
}
return *this;
}
--- digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h 2012-01-03 02:32:26.000000000 +0200
+++ digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h 2012-01-05 03:01:56.965609602 +0200
@@ -1362,7 +1362,7 @@
template <typename VertexType, typename GraphType>
void discover_vertex(VertexType u, const GraphType&) const
{
- record(u);
+ this->record(u);
}
};
@@ -1373,7 +1373,7 @@
template <typename VertexType, typename GraphType>
void discover_vertex(VertexType u, const GraphType&) const
{
- record(u);
+ this->record(u);
}
};
--- digikam-2.5.0/core/utilities/cameragui/devices/gpcamera.cpp 2012-01-03 02:32:04.000000000 +0200
+++ digikam-2.5.0/core/utilities/cameragui/devices/gpcamera.cpp 2012-01-05 01:22:34.009352997 +0200
@@ -30,6 +30,7 @@
extern "C"
{
#include <utime.h>
+#include <unistd.h>
}
// C++ includes
--- digikam-2.5.0/extra/kipi-plugins/htmlexport/wizard.cpp 2012-01-03 02:31:42.000000000 +0200
+++ digikam-2.5.0/extra/kipi-plugins/htmlexport/wizard.cpp 2012-01-05 02:35:01.061054821 +0200
@@ -78,7 +78,7 @@
public:
WizardPage(KAssistantDialog* dialog, const QString& title)
: QWidget(dialog) {
- setupUi(this);
+ this->setupUi(this);
layout()->setMargin(0);
mPage = dialog->addPage(this, title);
}
--- digikam-2.5.0/extra/kipi-plugins/printimages/wizard/wizard.cpp 2012-01-03 02:31:34.000000000 +0200
+++ digikam-2.5.0/extra/kipi-plugins/printimages/wizard/wizard.cpp 2012-01-05 02:17:15.249914790 +0200
@@ -88,7 +88,7 @@
WizardPage ( KAssistantDialog* dialog, const QString& title )
: QWidget ( dialog )
{
- setupUi ( this );
+ this->setupUi ( this );
layout()->setMargin ( 0 );
mPage = dialog->addPage ( this, title );
}

View file

@ -0,0 +1,12 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,12 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,63 @@
diff --git a/utilities/setup/setupplugins.cpp b/utilities/setup/setupplugins.cpp
index 0f4030a..b8efb35 100644
--- a/utilities/setup/setupplugins.cpp
+++ b/utilities/setup/setupplugins.cpp
@@ -6,8 +6,8 @@
* Date : 2004-01-02
* Description : setup Kipi plugins tab.
*
- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
*
* This program is free software; you can redistribute it
* and/or modify it under the terms of the GNU General
@@ -100,6 +100,11 @@ SetupPlugins::SetupPlugins(QWidget* parent)
panel->setLayout(mainLayout);
+#if KIPI_VERSION < 0x010400
+ d->checkAllBtn->setVisible(false);
+ d->clearBtn->setVisible(false);
+#endif
+
initPlugins();
// --------------------------------------------------------
@@ -158,14 +163,18 @@ void SetupPlugins::applyPlugins()
void SetupPlugins::slotCheckAll()
{
QApplication::setOverrideCursor(Qt::WaitCursor);
+#if KIPI_VERSION >= 0x010400
d->kipiConfig->slotCheckAll();
+#endif
QApplication::restoreOverrideCursor();
}
void SetupPlugins::slotClear()
{
QApplication::setOverrideCursor(Qt::WaitCursor);
+#if KIPI_VERSION >= 0x010400
d->kipiConfig->slotClear();
+#endif
QApplication::restoreOverrideCursor();
}
diff --git a/utilities/setup/setupplugins.h b/utilities/setup/setupplugins.h
index 271a569..114e0fa 100644
--- a/utilities/setup/setupplugins.h
+++ b/utilities/setup/setupplugins.h
@@ -6,8 +6,8 @@
* Date : 2004-01-02
* Description : setup Kipi plugins tab.
*
- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
+ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
+ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
*
* This program is free software; you can redistribute it
* and/or modify it under the terms of the GNU General

View file

@ -0,0 +1,78 @@
Index: digikam-2.5.0/extra/kipi-plugins/photolayoutseditor/widgets/canvas/CropWidgetItem.cpp
===================================================================
--- digikam-2.5.0.orig/extra/kipi-plugins/photolayoutseditor/widgets/canvas/CropWidgetItem.cpp 2012-01-03 00:31:44.000000000 +0000
+++ digikam-2.5.0/extra/kipi-plugins/photolayoutseditor/widgets/canvas/CropWidgetItem.cpp 2012-03-15 16:02:31.000000000 +0000
@@ -340,8 +340,8 @@
QPointF dif = event->scenePos() - event->lastScenePos();
temp.translate(dif);
- temp.translate( qMin(maxRect.right()-temp.right(),0.0), qMin(maxRect.bottom()-temp.bottom(),0.0) );
- temp.translate( qMax(maxRect.left()-temp.left(),0.0), qMax(maxRect.top()-temp.top(),0.0) );
+ temp.translate( qMin(maxRect.right()-temp.right(),qreal(0.0)), qMin(maxRect.bottom()-temp.bottom(),qreal(0.0)) );
+ temp.translate( qMax(maxRect.left()-temp.left(),qreal(0.0)), qMax(maxRect.top()-temp.top(),qreal(0.0)) );
}
// Size change
else
Index: digikam-2.5.0/core/libs/widgets/graphicsview/regionframeitem.cpp
===================================================================
--- digikam-2.5.0.orig/core/libs/widgets/graphicsview/regionframeitem.cpp 2012-01-03 00:32:18.000000000 +0000
+++ digikam-2.5.0/core/libs/widgets/graphicsview/regionframeitem.cpp 2012-03-15 16:02:31.000000000 +0000
@@ -639,8 +639,8 @@
{
const QSizeF maxSize = parentDImgItem()->boundingRect().size();
const QPointF point = mapToParent(event->pos());
- qreal posX = qBound(0., point.x(), maxSize.width());
- qreal posY = qBound(0., point.y(), maxSize.height());
+ qreal posX = qBound(qreal(0.0), point.x(), maxSize.width());
+ qreal posY = qBound(qreal(0.0), point.y(), maxSize.height());
QRectF r = rect();
// Adjust edge
Index: digikam-2.5.0/core/libs/database/searchxml.cpp
===================================================================
--- digikam-2.5.0.orig/core/libs/database/searchxml.cpp 2012-01-03 00:32:25.000000000 +0000
+++ digikam-2.5.0/core/libs/database/searchxml.cpp 2012-03-15 16:02:31.000000000 +0000
@@ -645,7 +645,7 @@
}
}
-void SearchXmlWriter::writeValue(const QList<double>& valueList, int precision)
+void SearchXmlWriter::writeValue(const QList<qreal>& valueList, int precision)
{
QString listitem("listitem");
foreach(double i, valueList)
Index: digikam-2.5.0/core/libs/database/searchxml.h
===================================================================
--- digikam-2.5.0.orig/core/libs/database/searchxml.h 2012-01-03 00:32:26.000000000 +0000
+++ digikam-2.5.0/core/libs/database/searchxml.h 2012-03-15 16:02:31.000000000 +0000
@@ -231,7 +231,7 @@
void writeValue(const QDateTime& dateTime);
void writeValue(const QList<int>& valueList);
void writeValue(const QList<qlonglong>& valueList);
- void writeValue(const QList<double>& valueList, int precision = 8);
+ void writeValue(const QList<qreal>& valueList, int precision = 8);
void writeValue(const QStringList& valueList);
void writeValue(const QList<QDateTime>& valueList);
Index: digikam-2.5.0/core/utilities/searchwindow/searchfields.cpp
===================================================================
--- digikam-2.5.0.orig/core/utilities/searchwindow/searchfields.cpp 2012-01-03 00:32:02.000000000 +0000
+++ digikam-2.5.0/core/utilities/searchwindow/searchfields.cpp 2012-03-15 19:49:39.000000000 +0000
@@ -1209,7 +1209,7 @@
if (m_reciprocal)
{
- writer.writeValue(QList<double>() << m_secondBox->fractionMagicValue() << m_firstBox->fractionMagicValue());
+ writer.writeValue(QList<qreal>() << m_secondBox->fractionMagicValue() << m_firstBox->fractionMagicValue());
}
else
{
@@ -1505,7 +1505,7 @@
if (m_firstBox->value() != m_secondBox->value())
{
writer.writeField(m_name, SearchXml::Interval);
- writer.writeValue(QList<double>()
+ writer.writeValue(QList<qreal>()
<< (m_firstBox->value() * m_factor) << (m_secondBox->value() * m_factor));
writer.finishField();
}

View file

@ -9,7 +9,7 @@ plugrel=1
pkgbase=kdebindings-python
pkgname=('kdebindings-python'
'kdebindings-python2')
pkgver=4.8.2
pkgver=4.8.3
pkgrel=1
url='http://kde.org/'
arch=('i686' 'x86_64')
@ -18,7 +18,7 @@ groups=('kdebindings')
makedepends=('cmake' 'automoc4' 'boost' 'kdepim-runtime' 'python2-pyqt' 'qscintilla')
source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.xz"
"pykde4-4.4.4-arm-sip.patch")
sha1sums=('7d1a41e00794dba160ce8e2a3f750c9a4298ef15'
sha1sums=('e88ef838b492802f401b0242205e87149c19d032'
'20d37a8b127eebffc4556352168786036969ee78')
build() {

View file

@ -11,9 +11,8 @@ plugrel=1
pkgbase=opencv
pkgname=('opencv' 'opencv-docs' 'opencv-samples')
_realname=OpenCV
pkgver=2.3.1_a
_realver=2.3.1
pkgrel=4
pkgver=2.4.0
pkgrel=1
pkgdesc="Open Source Computer Vision Library"
arch=('i686' 'x86_64')
license=('BSD')
@ -26,10 +25,8 @@ optdepends=('opencv-docs'
'eigen2'
'python2-numpy: Python 2.x interface')
options=('!libtool')
source=("http://downloads.sourceforge.net/opencvlibrary/$_realname-${_realver}a.tar.bz2"
"alarm.patch")
md5sums=('82e4b6bfa349777233eea09b075e931e'
'941d6076ebdb4af729626ba3730e2f76')
source=("http://downloads.sourceforge.net/opencvlibrary/$_realname-${pkgver}.tar.bz2")
md5sums=('1fcda4ed3d0655f033ac30be8bad4882')
_cmakeopts=('-D CMAKE_BUILD_TYPE=Release'
'-D CMAKE_INSTALL_PREFIX=/usr'
@ -56,26 +53,24 @@ _cmakeopts=('-D CMAKE_BUILD_TYPE=Release'
'-D USE_FAST_MATH=ON')
build() {
cd "$srcdir/$_realname-$_realver"
cd "$srcdir/$_realname-$pkgver"
# x64, i.e "Athlon64" and upwards, can use SSE3
[ $CARCH = x86_64 ] && \
_cmakeopts=${_cmakeopts[@]/ENABLE_SSE3=OFF/ENABLE_SSE3=ON}
patch -p1 -i ${srcdir}/alarm.patch
cmake ${_cmakeopts[@]} .
make
}
package_opencv() {
cd "$srcdir/$_realname-$_realver"
cd "$srcdir/$_realname-$pkgver"
make DESTDIR="$pkgdir" install
# install license file
install -Dm644 "$srcdir/$_realname-$_realver/doc/license.txt" \
install -Dm644 "$srcdir/$_realname-$pkgver/doc/license.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$pkgdir/usr/share"
@ -106,7 +101,7 @@ package_opencv-docs() {
cp -r opencv-doc "$pkgdir/usr/share/doc/opencv"
# install license file
install -Dm644 "$srcdir/$_realname-$_realver/doc/license.txt" \
install -Dm644 "$srcdir/$_realname-$pkgver/doc/license.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
@ -121,7 +116,7 @@ package_opencv-samples() {
mkdir -p "$pkgdir/usr/share/opencv"
cp -r opencv-samples "$pkgdir/usr/share/opencv/samples"
install -Dm644 "$srcdir/$_realname-$_realver/doc/license.txt" \
install -Dm644 "$srcdir/$_realname-$pkgver/doc/license.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

View file

@ -1,12 +0,0 @@
diff -urN a/modules/flann/include/opencv2/flann/dist.h b/modules/flann/include/opencv2/flann/dist.h
--- a/modules/flann/include/opencv2/flann/dist.h 2011-09-12 12:42:27.000000000 -0600
+++ b/modules/flann/include/opencv2/flann/dist.h 2011-11-05 23:29:38.518023435 -0600
@@ -60,7 +60,7 @@
inline double abs<double>(double x) { return fabs(x); }
template<>
-inline long double abs<long double>(long double x) { return fabsl(x); }
+inline long double abs<long double>(long double x) { return fabs(x); }
template<typename T>