mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/pipewire to 0.3.4-1.1
This commit is contained in:
parent
cdbb7eaad1
commit
2911804f29
3 changed files with 35 additions and 5 deletions
|
@ -1,7 +1,7 @@
|
|||
From 83d5286fec3ed5828d468c2b4ff2a961a54a054e Mon Sep 17 00:00:00 2001
|
||||
From 2528f437b43a3611c7174b3b31af014337b4d3e0 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 11 Mar 2020 07:28:28 -0600
|
||||
Subject: [PATCH] atomic
|
||||
Subject: [PATCH 1/2] atomic
|
||||
|
||||
---
|
||||
pipewire-jack/src/meson.build | 23 ++++++++++++++++++++++-
|
||||
|
|
26
extra/pipewire/0002-disable-neon.patch
Normal file
26
extra/pipewire/0002-disable-neon.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From ead322cc7a7c401f2d10f2585ec021ed7365aa73 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 1 May 2020 20:17:39 -0600
|
||||
Subject: [PATCH 2/2] disable neon
|
||||
|
||||
---
|
||||
meson.build | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 74142587..e7844cd0 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -100,9 +100,6 @@ have_neon = false
|
||||
if host_machine.cpu_family() == 'aarch64'
|
||||
neon_args = []
|
||||
have_neon = true
|
||||
-elif cc.has_argument('-mfpu=neon')
|
||||
- neon_args = ['-mfpu=neon']
|
||||
- have_neon = true
|
||||
endif
|
||||
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -4,11 +4,12 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend on valgrind
|
||||
# - patch to check for and link with libatomic
|
||||
# - patch to disable neon on !aarch64
|
||||
|
||||
pkgbase=pipewire
|
||||
pkgname=(pipewire pipewire-docs pipewire-jack pipewire-pulse)
|
||||
pkgver=0.3.4
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc="Server and user space API to deal with multimedia pipelines"
|
||||
url="https://pipewire.org"
|
||||
license=(LGPL2.1)
|
||||
|
@ -18,9 +19,11 @@ makedepends=(git meson doxygen graphviz xmltoman jack2 libpulse
|
|||
dbus libsndfile bluez-libs vulkan-headers)
|
||||
_commit=33398d7de83fad1c67c691e0712e3e0108c5e966 # tags/0.3.4
|
||||
source=("git+https://github.com/PipeWire/pipewire#commit=$_commit"
|
||||
0001-atomic.patch)
|
||||
0001-atomic.patch
|
||||
0002-disable-neon.patch)
|
||||
sha256sums=('SKIP'
|
||||
'3ae386bc7ad38177e7f1729668a5d035535dc4f234b97a5f60ab774316a3a82c')
|
||||
'012c545b4f17b7b4f08ff4994dfe01b1ba125be9f71563a0e2a094e0fb72cec5'
|
||||
'6e465e8413f4c20b2015f4168ca4e9fd07b1186c405b613657f95796fd3fd473')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgbase
|
||||
|
@ -30,6 +33,7 @@ pkgver() {
|
|||
prepare() {
|
||||
cd $pkgbase
|
||||
patch -p1 -i ../0001-atomic.patch
|
||||
patch -p1 -i ../0002-disable-neon.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue