mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/chromium to 76.0.3809.87-1
This commit is contained in:
parent
0d9262d709
commit
291e7c61ae
7 changed files with 9 additions and 245 deletions
|
@ -13,9 +13,10 @@
|
|||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=75.0.3770.142
|
||||
pkgver=76.0.3809.87
|
||||
pkgrel=1
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
|
@ -33,23 +34,13 @@ optdepends=('kdialog: needed for file dialogs in KDE'
|
|||
install=chromium.install
|
||||
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
|
||||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium-system-icu.patch
|
||||
chromium-non-const-deltas.patch
|
||||
libstdc-do-not-assume-unique_ptr-has-ostream-operator.patch
|
||||
disallow-partial-swaps-for-linux-based-on-gl_version.patch
|
||||
chromium-fix-window-flash-for-some-WMs.patch
|
||||
chromium-widevine.patch
|
||||
chromium-skia-harmony.patch
|
||||
0001-crashpad-include-limits.patch)
|
||||
sha256sums=('510e6ca7ccc218b401b375c13656f6aecab196b03142026dc3602b9d1804a5ac'
|
||||
sha256sums=('215ca6acee7b4fd3c95fe796260af4dc5454dbba3b701aa43afeb98a06dc4194'
|
||||
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
|
||||
'e2d284311f49c529ea45083438a768db390bde52949995534034d2a814beab89'
|
||||
'09c5f16b726ef7031d74807b534fbbfa49a7276ee2a239b70602de2704fa197c'
|
||||
'e309dfd9d790f32cb1d23103726ac25e405b6ae6757a1c957a8395667d753908'
|
||||
'1e4686de75c019f38a3ed947463e429a777d5387fd29310deef2108c58617b07'
|
||||
'183d8cc712f0bcf1afcb01ce90c4c104a4c8d8070a06f94974a28b007d9e2ce4'
|
||||
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
|
||||
'5887f78b55c4ecbbcba5930f3f0bb7bc0117c2a41c2f761805fcf7f46f1ca2b3'
|
||||
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1'
|
||||
'df99f49ad58b70c9a3e1827d7e80b62e4363419334ed83373cf55b79c17b6f10')
|
||||
|
||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||
|
@ -110,27 +101,12 @@ prepare() {
|
|||
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
|
||||
third_party/libxml/chromium/libxml_utils.cc
|
||||
|
||||
# https://chromium-review.googlesource.com/1584292
|
||||
patch -Np1 -i ../libstdc-do-not-assume-unique_ptr-has-ostream-operator.patch
|
||||
|
||||
# https://crbug.com/973216
|
||||
patch -Np1 -i ../disallow-partial-swaps-for-linux-based-on-gl_version.patch
|
||||
|
||||
# https://crbug.com/956061
|
||||
patch -Np1 -i ../chromium-fix-window-flash-for-some-WMs.patch
|
||||
|
||||
# Load Widevine CDM if available
|
||||
patch -Np1 -i ../chromium-widevine.patch
|
||||
|
||||
# https://crbug.com/skia/6663#c10
|
||||
patch -Np0 -i ../chromium-skia-harmony.patch
|
||||
|
||||
# https://bugs.gentoo.org/661880#c21
|
||||
patch -Np1 -i ../chromium-system-icu.patch
|
||||
|
||||
# https://bugs.gentoo.org/686982#c5
|
||||
patch -Np1 -i ../chromium-non-const-deltas.patch
|
||||
|
||||
# Force script incompatible with Python 3 to use /usr/bin/python2
|
||||
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
|
||||
|
||||
|
@ -205,11 +181,6 @@ build() {
|
|||
|
||||
if check_option strip y; then
|
||||
_flags+=('symbol_level=0')
|
||||
|
||||
# Mimic exclude_unwind_tables=true
|
||||
CFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
|
||||
CXXFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
|
||||
CPPFLAGS+=' -DNO_UNWIND_TABLES'
|
||||
fi
|
||||
|
||||
gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
|
||||
|
|
|
@ -1,98 +0,0 @@
|
|||
From 90e226ba50c98b5e60f74f9dce998b17117f9051 Mon Sep 17 00:00:00 2001
|
||||
From: Peng Huang <penghuang@chromium.org>
|
||||
Date: Tue, 7 May 2019 13:16:21 +0000
|
||||
Subject: [PATCH] Fix window flash for some WMs
|
||||
|
||||
Bug: 956061
|
||||
Change-Id: I0d8d196395e70006a8fdc770f1e4a5ba6f93dd57
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1597388
|
||||
Commit-Queue: Peng Huang <penghuang@chromium.org>
|
||||
Reviewed-by: Antoine Labour <piman@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#657215}
|
||||
---
|
||||
ui/gl/BUILD.gn | 5 ++++-
|
||||
ui/gl/gl_surface_glx.cc | 41 ++++++++++++++++++++++++++++-------------
|
||||
2 files changed, 32 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/ui/gl/BUILD.gn b/ui/gl/BUILD.gn
|
||||
index 50df0e4085..1753dd480b 100644
|
||||
--- a/ui/gl/BUILD.gn
|
||||
+++ b/ui/gl/BUILD.gn
|
||||
@@ -274,7 +274,10 @@ jumbo_component("gl") {
|
||||
"//build/config/linux:xext",
|
||||
]
|
||||
|
||||
- deps += [ "//ui/gfx/x" ]
|
||||
+ deps += [
|
||||
+ "//ui/base/x",
|
||||
+ "//ui/gfx/x",
|
||||
+ ]
|
||||
}
|
||||
if (is_win) {
|
||||
sources += [
|
||||
diff --git a/ui/gl/gl_surface_glx.cc b/ui/gl/gl_surface_glx.cc
|
||||
index f4c13bed18..777bf767cb 100644
|
||||
--- a/ui/gl/gl_surface_glx.cc
|
||||
+++ b/ui/gl/gl_surface_glx.cc
|
||||
@@ -21,6 +21,7 @@
|
||||
#include "base/time/time.h"
|
||||
#include "base/trace_event/trace_event.h"
|
||||
#include "build/build_config.h"
|
||||
+#include "ui/base/x/x11_util.h"
|
||||
#include "ui/events/platform/platform_event_source.h"
|
||||
#include "ui/gfx/x/x11.h"
|
||||
#include "ui/gfx/x/x11_connection.h"
|
||||
@@ -431,7 +432,9 @@ bool GLSurfaceGLX::InitializeOneOff() {
|
||||
}
|
||||
|
||||
const XVisualInfo& visual_info =
|
||||
- gl::GLVisualPickerGLX::GetInstance()->rgba_visual();
|
||||
+ ui::IsCompositingManagerPresent()
|
||||
+ ? gl::GLVisualPickerGLX::GetInstance()->rgba_visual()
|
||||
+ : gl::GLVisualPickerGLX::GetInstance()->system_visual();
|
||||
g_visual = visual_info.visual;
|
||||
g_depth = visual_info.depth;
|
||||
g_colormap =
|
||||
@@ -581,18 +584,30 @@ bool NativeViewGLSurfaceGLX::Initialize(GLSurfaceFormat format) {
|
||||
}
|
||||
size_ = gfx::Size(attributes.width, attributes.height);
|
||||
|
||||
- XSetWindowAttributes swa;
|
||||
- memset(&swa, 0, sizeof(swa));
|
||||
- swa.background_pixmap = 0;
|
||||
- swa.bit_gravity = NorthWestGravity;
|
||||
- swa.colormap = g_colormap;
|
||||
- swa.background_pixel = 0;
|
||||
- swa.border_pixel = 0;
|
||||
- window_ = XCreateWindow(
|
||||
- gfx::GetXDisplay(), parent_window_, 0 /* x */, 0 /* y */, size_.width(),
|
||||
- size_.height(), 0 /* border_width */, g_depth, InputOutput, g_visual,
|
||||
- CWBackPixmap | CWBitGravity | CWColormap | CWBackPixel | CWBorderPixel,
|
||||
- &swa);
|
||||
+ XSetWindowAttributes swa = {
|
||||
+ .background_pixmap = 0,
|
||||
+ .bit_gravity = NorthWestGravity,
|
||||
+ .colormap = g_colormap,
|
||||
+ .background_pixel = 0, // ARGB(0,0,0,0) for compositing WM
|
||||
+ .border_pixel = 0,
|
||||
+ };
|
||||
+ auto value_mask = CWBackPixmap | CWBitGravity | CWColormap | CWBorderPixel;
|
||||
+ if (ui::IsCompositingManagerPresent() &&
|
||||
+ XVisualIDFromVisual(attributes.visual) == XVisualIDFromVisual(g_visual)) {
|
||||
+ // When parent and child are using the same visual, the back buffer will be
|
||||
+ // shared between parent and child. If WM compositing is enabled, we set
|
||||
+ // child's background pixel to ARGB(0,0,0,0), so ARGB(0,0,0,0) will be
|
||||
+ // filled to the shared buffer, when the child window is mapped. It can
|
||||
+ // avoid an annoying flash when the child window is mapped below.
|
||||
+ // If WM compositing is disabled, we don't set the background pixel, so
|
||||
+ // nothing will be draw when the child window is mapped.
|
||||
+ value_mask |= CWBackPixel;
|
||||
+ }
|
||||
+
|
||||
+ window_ =
|
||||
+ XCreateWindow(gfx::GetXDisplay(), parent_window_, 0 /* x */, 0 /* y */,
|
||||
+ size_.width(), size_.height(), 0 /* border_width */,
|
||||
+ g_depth, InputOutput, g_visual, value_mask, &swa);
|
||||
if (!window_) {
|
||||
LOG(ERROR) << "XCreateWindow failed";
|
||||
return false;
|
|
@ -1,21 +0,0 @@
|
|||
Bug: https://bugs.gentoo.org/686982
|
||||
|
||||
TabStripModelChange has a defaulted default constructor and a const data member
|
||||
without a user-defined default constructor. This leads to a bug:
|
||||
|
||||
error: defaulting this default constructor would delete it after
|
||||
its first declaration
|
||||
|
||||
We declare the data member as non-const instead.
|
||||
|
||||
--- a/chrome/browser/ui/tabs/tab_strip_model_observer.h
|
||||
+++ b/chrome/browser/ui/tabs/tab_strip_model_observer.h
|
||||
@@ -103,7 +103,7 @@ class TabStripModelChange {
|
||||
|
||||
private:
|
||||
const Type type_ = kSelectionOnly;
|
||||
- const std::vector<Delta> deltas_;
|
||||
+ std::vector<Delta> deltas_;
|
||||
|
||||
DISALLOW_COPY_AND_ASSIGN(TabStripModelChange);
|
||||
};
|
|
@ -1,12 +1,13 @@
|
|||
--- third_party/skia/src/ports/SkFontHost_FreeType.cpp.orig 2019-01-20 10:54:56.415239030 +0000
|
||||
+++ third_party/skia/src/ports/SkFontHost_FreeType.cpp 2019-01-20 10:55:05.695307733 +0000
|
||||
@@ -121,8 +121,8 @@ public:
|
||||
--- third_party/skia/src/ports/SkFontHost_FreeType.cpp.orig 2019-07-19 11:08:34.770972665 +0000
|
||||
+++ third_party/skia/src/ports/SkFontHost_FreeType.cpp 2019-07-19 11:08:44.274442065 +0000
|
||||
@@ -128,9 +128,9 @@ public:
|
||||
: fGetVarDesignCoordinates(nullptr)
|
||||
, fGetVarAxisFlags(nullptr)
|
||||
, fLibrary(nullptr)
|
||||
- , fIsLCDSupported(false)
|
||||
- , fLCDExtra(0)
|
||||
+ , fIsLCDSupported(true)
|
||||
, fLightHintingIsYOnly(false)
|
||||
- , fLCDExtra(0)
|
||||
+ , fLCDExtra(2)
|
||||
{
|
||||
if (FT_New_Library(&gFTMemory, &fLibrary)) {
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff --git a/third_party/blink/renderer/platform/text/character_property_data.h b/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
index 28fb6a9..bb4dbd7 100644
|
||||
--- a/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
+++ b/third_party/blink/renderer/platform/text/character_property_data.h
|
||||
@@ -244,10 +244,12 @@ static const UChar32 kIsHangulRanges[] = {
|
||||
0xD7B0, 0xD7FF,
|
||||
// Halfwidth Hangul Jamo
|
||||
// https://www.unicode.org/charts/nameslist/c_FF00.html
|
||||
- 0xFFA0, 0xFFDC,
|
||||
+ 0xFFA0, 0xFFDB,
|
||||
};
|
||||
|
||||
-static const UChar32 kIsHangulArray[] = {};
|
||||
+static const UChar32 kIsHangulArray[] = {
|
||||
+ 0xFFDC,
|
||||
+};
|
||||
|
||||
#if !defined(USING_SYSTEM_ICU)
|
||||
// Freezed trie tree, see character_property_data_generator.cc.
|
|
@ -1,34 +0,0 @@
|
|||
From e6a0cdf0b7045e7f9029cce287bcc539052ef79a Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Backer <backer@chromium.org>
|
||||
Date: Mon, 17 Jun 2019 16:46:37 +0000
|
||||
Subject: [PATCH] Disallow partial swaps for linux based on gl_version_string
|
||||
|
||||
This was missed in https://chromium-review.googlesource.com/c/chromium/src/+/1601182
|
||||
|
||||
Bug: 973216,941670,957541,948640
|
||||
Change-Id: I3d2002c38fe09d87c9a3db951dfc2ab112319caf
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1662528
|
||||
Reviewed-by: Peng Huang <penghuang@chromium.org>
|
||||
Commit-Queue: Peng Huang <penghuang@chromium.org>
|
||||
Commit-Queue: Jonathan Backer <backer@chromium.org>
|
||||
Auto-Submit: Jonathan Backer <backer@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#669701}
|
||||
---
|
||||
gpu/config/gpu_driver_bug_list.json | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/gpu/config/gpu_driver_bug_list.json b/gpu/config/gpu_driver_bug_list.json
|
||||
index 591a0642e8..e4a123ccd0 100644
|
||||
--- a/gpu/config/gpu_driver_bug_list.json
|
||||
+++ b/gpu/config/gpu_driver_bug_list.json
|
||||
@@ -1865,10 +1865,6 @@
|
||||
},
|
||||
"gl_type": "gl",
|
||||
"gl_version_string": ".*Mesa.*",
|
||||
- "direct_rendering_version": {
|
||||
- "op" : "<",
|
||||
- "value": "2.3"
|
||||
- },
|
||||
"features": [
|
||||
"disable_post_sub_buffers_for_onscreen_surfaces"
|
||||
]
|
|
@ -1,36 +0,0 @@
|
|||
From aeed4d1f15ce84a17ea0bc219e258dc4982b2368 Mon Sep 17 00:00:00 2001
|
||||
From: Jose Dapena Paz <jose.dapena@lge.com>
|
||||
Date: Fri, 26 Apr 2019 20:07:05 +0000
|
||||
Subject: [PATCH] libstdc++: do not assume unique_ptr has ostream operator
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
CompositorFrameReportingController is using DCHECK_NE to compare
|
||||
several unique_ptr. This is valid in libc++, but on libstdc++ unique_ptr
|
||||
does not have an ostream operator.
|
||||
|
||||
Change-Id: I9f23ef17f02b9e107694ba493f6f8f3caf5cac4d
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1584292
|
||||
Reviewed-by: Sunny Sachanandani <sunnyps@chromium.org>
|
||||
Commit-Queue: José Dapena Paz <jose.dapena@lge.com>
|
||||
Cr-Commit-Position: refs/heads/master@{#654570}
|
||||
---
|
||||
cc/scheduler/compositor_frame_reporting_controller.cc | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/cc/scheduler/compositor_frame_reporting_controller.cc b/cc/scheduler/compositor_frame_reporting_controller.cc
|
||||
index f1587ed158..1b17021fd2 100644
|
||||
--- a/cc/scheduler/compositor_frame_reporting_controller.cc
|
||||
+++ b/cc/scheduler/compositor_frame_reporting_controller.cc
|
||||
@@ -31,8 +31,8 @@ void CompositorFrameReportingController::WillBeginImplFrame() {
|
||||
|
||||
void CompositorFrameReportingController::WillBeginMainFrame() {
|
||||
DCHECK(reporters_[PipelineStage::kBeginImplFrame]);
|
||||
- DCHECK_NE(reporters_[PipelineStage::kBeginMainFrame],
|
||||
- reporters_[PipelineStage::kBeginImplFrame]);
|
||||
+ DCHECK(reporters_[PipelineStage::kBeginMainFrame] !=
|
||||
+ reporters_[PipelineStage::kBeginImplFrame]);
|
||||
reporters_[PipelineStage::kBeginImplFrame]->StartStage(
|
||||
"SendBeginMainFrameToCommit");
|
||||
AdvanceReporterStage(PipelineStage::kBeginImplFrame,
|
Loading…
Reference in a new issue