diff --git a/community/gitlab/10589.patch b/community/gitlab/10589.patch
deleted file mode 100644
index 435b24929..000000000
--- a/community/gitlab/10589.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From e46f67a5123433f132da28770e4027542062fc81 Mon Sep 17 00:00:00 2001
-From: Jacob Vosmaer <jacob@gitlab.com>
-Date: Mon, 10 Apr 2017 13:24:14 +0200
-Subject: [PATCH] Use gRPC 1.2.2
-
-Fixes LoadError after local compilation.
-
-https://github.com/grpc/grpc/issues/9998
----
- Gemfile.lock | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Gemfile.lock b/Gemfile.lock
-index d7e3f73..965c888 100644
---- a/Gemfile.lock
-+++ b/Gemfile.lock
-@@ -330,7 +330,7 @@ GEM
-     grape-entity (0.6.0)
-       activesupport
-       multi_json (>= 1.3.2)
--    grpc (1.1.2)
-+    grpc (1.2.2)
-       google-protobuf (~> 3.1)
-       googleauth (~> 0.5.1)
-     haml (4.0.7)
--- 
-2.10.2
-
diff --git a/community/gitlab/PKGBUILD b/community/gitlab/PKGBUILD
index 91be5c7c8..91145fbef 100644
--- a/community/gitlab/PKGBUILD
+++ b/community/gitlab/PKGBUILD
@@ -11,7 +11,7 @@
 #  - disable webpack build
 
 pkgname=gitlab
-pkgver=9.1.4
+pkgver=9.2.0
 pkgrel=1
 pkgdesc="Project management and code hosting application"
 arch=('i686' 'x86_64')
@@ -43,10 +43,9 @@ source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/gitlab-org/gitlab-ce/reposi
         apache2.2-ssl.conf.example
         nginx.conf.example
         nginx-ssl.conf.example
-        lighttpd.conf.example
-        10589.patch)
+        lighttpd.conf.example)
 install='gitlab.install'
-sha512sums=('05a05121a190a223079997b4d5e1c7d064e43507947b5599dde59c0bf85a6d26a4d8092b96fef21117f88819f5dc297e1c621562a5936f8f5d374db7ee5c2718'
+sha512sums=('d0ba1e8792493c0d552dcf6dc75673e7116626b221622aa37f651054618715cf08fe230330cef4251d1af7ac7310b7b74234d03394530fe8730cebfb0c9cea96'
             '56cce150645ef74fa42a6100c8bc7689c4012579e1f3ba237c06c367b121246b39e968044615fa21c4757bc8e9d06f37f8ac8d39aa8b808c758e716857553f66'
             '8678b2f0632a830e42a8a62b59ffe66b629b7d96034ff167e2a93fdbb3c7617db0c7529990b73c7a12a78a900ec833e48c691ebbac6cd8257e53de060da16a37'
             '79cfb8ee740ab30f970c3113659b8349128abeae5e32cc81bb905f89a6db9941b7778040a094b884262daf020f66a1aee49a12d34fbb94efce6ade946bb4625b'
@@ -61,8 +60,7 @@ sha512sums=('05a05121a190a223079997b4d5e1c7d064e43507947b5599dde59c0bf85a6d26a4d
             '248d47b44fa5ed65e2a940f2b60d0482c481b3a438357ca510848221370367ffbc0d83ce046d688bebbbc75d4e321b140f6a5ce1a9d7ec0b034fafcf92dee107'
             '53a9d6d6f87874b29e48a8fb2e207094ebc1a80af478562ec4b591926d59e135a3166c20966704aa948ca7063ba63c1ec4ac290a343832fa18025ec3d85081ba'
             '6d3006da591acefcc534c6e3f1da8e812d0b3b21fc416bfaa8678b8e2d922be6b17d1c92b0d7164de3b8ad864139253707107ca082f78e823d23f3b65fcb5914'
-            'c78b6f46abcf603d8db6e38cf50868e14145928422ddfe17c88e2f006b5b910dddf456ec5d6d724b250994530643963809688a98f7e12ebd5b5dabf7f96f0e06'
-            '364408ad2cc7fd866c1f78a336fead0876c6af694cc45744a7dda680d40ad12bc2c35f18b54f4043af3f144a43a64ced5155e61210a88f814918152f041e1bb6')
+            'c78b6f46abcf603d8db6e38cf50868e14145928422ddfe17c88e2f006b5b910dddf456ec5d6d724b250994530643963809688a98f7e12ebd5b5dabf7f96f0e06')
 
 _datadir="/usr/share/webapps/${pkgname}"
 _etcdir="/etc/webapps/${pkgname}"
@@ -73,11 +71,6 @@ _srcdir="gitlab-ce-v${pkgver}"
 prepare() {
   cd "${srcdir}/${_srcdir}"*
 
-  # https://gitlab.com/gitlab-org/gitlab-ce/merge_requests/10589
-  # https://gitlab.com/gitlab-org/gitlab-ce/issues/29562
-  # https://gitlab.com/gitlab-org/gitlab-ce/issues/30124
-  patch -Np1 < "${srcdir}"/10589.patch
-
   export SKIP_STORAGE_VALIDATION='true'
 
   # Patching config files: