extra/gstreamer to 1.22.1-1

This commit is contained in:
Kevin Mihelich 2023-03-09 18:39:08 +00:00
parent 47ae2245ca
commit 2961250fb3
5 changed files with 70 additions and 72 deletions

View file

@ -11,7 +11,7 @@ Subject: [PATCH] HACK: meson: Disable broken tests
4 files changed, 4 deletions(-)
diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
index f97b65bfcbc4..c70d6a035355 100644
index 6b768600932a..be99474e97ba 100644
--- a/subprojects/gst-editing-services/meson.build
+++ b/subprojects/gst-editing-services/meson.build
@@ -270,7 +270,6 @@ subdir('ges')
@ -23,10 +23,10 @@ index f97b65bfcbc4..c70d6a035355 100644
subdir('examples')
endif
diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
index d3d472fe0fdb..c1825e49f64d 100644
index 6f5747a4c8d4..2113fca44cf6 100644
--- a/subprojects/gst-python/meson.build
+++ b/subprojects/gst-python/meson.build
@@ -106,5 +106,4 @@ if not get_option('plugin').disabled()
@@ -107,5 +107,4 @@ if not get_option('plugin').disabled()
endif
endif
if not get_option('tests').disabled()
@ -45,7 +45,7 @@ index 229af32f8117..b9372c125d77 100644
'gst/sessionpool',
'gst/stream',
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
index 9cd3fcf19cb7..4f8e6d27f9a3 100644
index aa2dce6c2e9c..84b61fd6a014 100644
--- a/subprojects/gstreamer-vaapi/meson.build
+++ b/subprojects/gstreamer-vaapi/meson.build
@@ -219,7 +219,6 @@ plugins = []

View file

@ -1,34 +1,23 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Antonio Rojas <arojas@archlinux.org>
Date: Sat, 7 Jan 2023 16:18:03 +0100
Subject: [PATCH] Support zxing-c++ 2.0
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Fri, 3 Mar 2023 16:46:35 +0000
Subject: [PATCH] zxing: update to 2.0.0 tag
format is a C++ string in 2.0
---
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 9 +++++++++
1 file changed, 9 insertions(+)
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 4 ++--
subprojects/gst-plugins-bad/ext/zxing/meson.build | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
index 7836dbbcf18e..a8a0f7b49aa4 100644
index 7836dbbcf18e..a7a24168383f 100644
--- a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
+++ b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
@@ -62,6 +62,7 @@
#include "ReadBarcode.h"
#include "TextUtfEncoding.h"
+#include "ZXVersion.h"
using namespace ZXing;
@@ -369,32 +370,40 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
@@ -369,32 +369,32 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
if (result.isValid ()) {
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
result.text ().c_str (),
+#if ZXING_VERSION_MAJOR >= 2
- ToString (result.format ()));
+ ToString (result.format ()).c_str ());
+#else
ToString (result.format ()));
+#endif
} else {
goto out;
}
@ -53,11 +42,21 @@ index 7836dbbcf18e..a8a0f7b49aa4 100644
"timestamp", G_TYPE_UINT64, timestamp,
"stream-time", G_TYPE_UINT64, stream_time,
"running-time", G_TYPE_UINT64, running_time,
+#if ZXING_VERSION_MAJOR >= 2
- "type", G_TYPE_STRING, ToString (result.format ()),
+ "type", G_TYPE_STRING, ToString (result.format ()).c_str (),
+#else
"type", G_TYPE_STRING, ToString (result.format ()),
+#endif
"symbol", G_TYPE_STRING,
result.text ().c_str (), NULL);
diff --git a/subprojects/gst-plugins-bad/ext/zxing/meson.build b/subprojects/gst-plugins-bad/ext/zxing/meson.build
index 2dbad9ab1eea..89e1f6592e7a 100644
--- a/subprojects/gst-plugins-bad/ext/zxing/meson.build
+++ b/subprojects/gst-plugins-bad/ext/zxing/meson.build
@@ -2,7 +2,7 @@ zxing_sources = [
'gstzxing.cpp',
'gstzxingplugin.c',
]
-zxing_dep = dependency('zxing', version : '>= 1.4.0', required : get_option('zxing'))
+zxing_dep = dependency('zxing', version : '>= 2.0.0', required : get_option('zxing'))
if zxing_dep.found()
gstzxing = library('gstzxing',
zxing_sources,

View file

@ -0,0 +1,24 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Fri, 3 Mar 2023 18:40:22 +0000
Subject: [PATCH] imagesequencesrc: Properly set default location
Noticed this because the generic_states test kept segfaulting at random.
GLibC 2.37 can crash when NULL is supplied as a format string.
---
.../gst-plugins-good/gst/multifile/gstimagesequencesrc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/subprojects/gst-plugins-good/gst/multifile/gstimagesequencesrc.c b/subprojects/gst-plugins-good/gst/multifile/gstimagesequencesrc.c
index 8581e73e3a94..3d59ec74a7c9 100644
--- a/subprojects/gst-plugins-good/gst/multifile/gstimagesequencesrc.c
+++ b/subprojects/gst-plugins-good/gst/multifile/gstimagesequencesrc.c
@@ -356,7 +356,7 @@ gst_image_sequence_src_init (GstImageSequenceSrc * self)
self->start_index = DEFAULT_START_INDEX;
self->index = 0;
self->stop_index = DEFAULT_STOP_INDEX;
- self->path = NULL;
+ self->path = g_strdup (DEFAULT_LOCATION);
self->caps = NULL;
self->n_frames = 0;
self->fps_n = 30;

View file

@ -1,25 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Tue, 24 Jan 2023 02:52:49 +0000
Subject: [PATCH] vaapi: Skip plugin pc file for shared plugins
Following similar logic in the other subprojects.
---
subprojects/gstreamer-vaapi/meson.build | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
index 4f8e6d27f9a3..5f8b5159dee2 100644
--- a/subprojects/gstreamer-vaapi/meson.build
+++ b/subprojects/gstreamer-vaapi/meson.build
@@ -240,6 +240,10 @@ meson.add_dist_script('scripts/gen-changelog.py', meson.project_name(), '1.20.0'
pkgconfig = import('pkgconfig')
plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
+if get_option('default_library') == 'shared'
+ # If we don't build static plugins there is no need to generate pc files
+ plugins_pkgconfig_install_dir = disabler()
+endif
plugin_names = []
gst_plugins = []

View file

@ -31,8 +31,8 @@ pkgname=(
gst-python
gstreamer-docs
)
pkgver=1.22.0
pkgrel=4
pkgver=1.22.1
pkgrel=1
pkgdesc="Multimedia graph framework"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@ -58,11 +58,11 @@ makedepends=(
# gst-plugins-bad
opencv vulkan-icd-loader vulkan-headers vulkan-validation-layers shaderc
libltc bluez-libs libavtp libbs2b bzip2 chromaprint libdca faac faad2
libfdk-aac fluidsynth libgme libkate liblrdf ladspa libde265 lilv lv2
libmicrodns mjpegtools libmpcdec neon openal libdvdnav rtmpdump sbc soundtouch
spandsp libsrtp zvbi libnice webrtc-audio-processing wildmidi
zxing-cpp zbar libxml2 gsm libopenmpt wpewebkit libldac libfreeaptx qrencode
json-glib libva libxkbcommon-x11
libfdk-aac fluidsynth libgme libkate liblrdf ladspa libde265 lilv libmodplug
lv2 libmicrodns mjpegtools libmpcdec neon openal libdvdnav rtmpdump sbc
soundtouch spandsp libsrtp zvbi libnice webrtc-audio-processing
wildmidi zxing-cpp zbar libxml2 gsm libopenmpt wpewebkit libldac libfreeaptx
qrencode json-glib libva libxkbcommon-x11
# gst-plugins-ugly
a52dec opencore-amr libcdio libdvdread libmpeg2 libsidplay x264
@ -81,15 +81,15 @@ source=(
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git?signed#tag=$pkgver"
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-$pkgver.tar.xz"{,.asc}
0001-HACK-meson-Disable-broken-tests.patch
0002-Support-zxing-c-2.0.patch
0003-vaapi-Skip-plugin-pc-file-for-shared-plugins.patch
0002-zxing-update-to-2.0.0-tag.patch
0003-imagesequencesrc-Properly-set-default-location.patch
)
b2sums=('SKIP'
'78152f7dccbefa6a8bb2c844b4ef4e1eab97c6e54a017bbe896fe3afb646942449a87387c66499f454e968b63f00a8040c9360ca7248c6dd7819228cf22fd94f'
'9f8e55732a60aebc8f0f50ba41ef06a739c80290f552f19c80ce71206e1094aadec5dcc57c908a277b33770f505b8f6b6e0e196abc8237778a3d4880bcd6d89a'
'SKIP'
'a90340cd3285882fb8416aae8bce44e3354e43790b947c93c749bc6dce8fa74c900ae933eb24ec872b319dffe16d42eaef6f6d41ddeccd61ea093b2b46e89e3b'
'88af02805ab7a0a6f79fd1fbf56206b6325f1bbeef9415d8bead83331dc04bddf28f4731bc1ab60b37fc7bd1473547838f4de930d9179e842b6190aee7e068a4'
'621ed5ad8051fa513c8ebd987b5a856bf4468f7d0150673783b4010b5c87b0a5ec7f62e402bbea1de493c5d029f3c3f1897cf9289e2168c430632e12ff80c423')
'7fa36829d5ebfb7b673a0fc36b8606d7e8e23975158e59406e9e31c2d82a6c774221b21ae6a49ef234f109e3a352ca04bf50d15f0e66b30667dd5df8cb80bc48'
'9934ab83fb55e2c8b48ede8d1d018d3757725dc869bb9fe20bd66982d04ca164f41a07968c83105be96e4262fd05d9917ed365cd7eb360259174ee9ba6d8f1ad'
'fd5bfeaf5a08f225bfb81df1beac55c3d7332aa4ffb1ba0a3e662dccea6b5ca43eecee92578c54d2fc1e3aa2edc73eb09a02e9c0a8ac3ad2002995a6a0396fa2')
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
prepare() {
@ -99,10 +99,10 @@ prepare() {
git apply -3 ../0001-HACK-meson-Disable-broken-tests.patch
# Fix build with zxing-cpp 2.0
git apply -3 ../0002-Support-zxing-c-2.0.patch
git apply -3 ../0002-zxing-update-to-2.0.0-tag.patch
# Fix install
git apply -3 ../0003-vaapi-Skip-plugin-pc-file-for-shared-plugins.patch
# Fix crash
git apply -3 ../0003-imagesequencesrc-Properly-set-default-location.patch
}
build() {
@ -166,8 +166,8 @@ build() {
}
check() (
mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
export XDG_RUNTIME_DIR
export XDG_RUNTIME_DIR="$PWD/runtime-dir"
mkdir -p -m 700 "$XDG_RUNTIME_DIR"
# Flaky due to timeouts
xvfb-run -s '-nolisten local' \
@ -225,7 +225,7 @@ package_gst-plugins-bad-libs() {
depends=(
"gst-plugins-base-libs=$pkgver"
orc libdrm libx11 libgudev libusb libxkbcommon-x11 libva libnice
vulkan-icd-loader wayland
vulkan-icd-loader wayland wayland-protocols
)
cd root; local files=(