mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/mesa to 23.3.1-1
This commit is contained in:
parent
09790ea0ee
commit
2966bbb8f7
3 changed files with 12 additions and 94 deletions
|
@ -1,11 +1,11 @@
|
|||
pkgbase = mesa
|
||||
pkgdesc = An open-source implementation of the OpenGL specification
|
||||
pkgver = 23.2.1
|
||||
pkgrel = 2
|
||||
pkgver = 23.3.1
|
||||
pkgrel = 1
|
||||
epoch = 1
|
||||
url = https://www.mesa3d.org/
|
||||
arch = x86_64
|
||||
license = custom
|
||||
license = MIT AND BSD-3-Clause AND SGI-B-2.0
|
||||
makedepends = clang
|
||||
makedepends = expat
|
||||
makedepends = libdrm
|
||||
|
@ -44,9 +44,8 @@ pkgbase = mesa
|
|||
makedepends = valgrind
|
||||
makedepends = directx-headers
|
||||
makedepends = libomxil-bellagio
|
||||
source = https://mesa.freedesktop.org/archive/mesa-23.2.1.tar.xz
|
||||
source = https://mesa.freedesktop.org/archive/mesa-23.2.1.tar.xz.sig
|
||||
source = 0001-radeonsi-prefix-function-with-si_-to-prevent-name-co.patch
|
||||
source = https://mesa.freedesktop.org/archive/mesa-23.3.1.tar.xz
|
||||
source = https://mesa.freedesktop.org/archive/mesa-23.3.1.tar.xz.sig
|
||||
source = LICENSE
|
||||
validpgpkeys = 8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D
|
||||
validpgpkeys = 946D09B5E4C9845E63075FF1D961C596A7203456
|
||||
|
@ -54,13 +53,11 @@ pkgbase = mesa
|
|||
validpgpkeys = A5CC9FEC93F2F837CB044912336909B6B25FADFA
|
||||
validpgpkeys = 71C4B75620BC75708B4BDB254C95FAAB3EB073EC
|
||||
validpgpkeys = 57551DE15B968F6341C248F68D8E31AFC32428A6
|
||||
sha256sums = 64de0616fc2d801f929ab1ac2a4f16b3e2783c4309a724c8a259b20df8bbc1cc
|
||||
sha256sums = 6e48126d70fdb3f20ffeb246ca0c2e41ffdc835f0663a03d4526b8bf5db41de6
|
||||
sha256sums = SKIP
|
||||
sha256sums = fcd21477e5c6122dc74f72457364448b171f7843b7a671e1f9df9c61bd888898
|
||||
sha256sums = 7052ba73bb07ea78873a2431ee4e828f4e72bda7d176d07f770fa48373dec537
|
||||
b2sums = 51e44c2e9b7dfe17cf4cb7252e169109d03a006caa8ec34036fb594c0c44e9278d0088170894c1a9debdea911f746470e1d256576e0635cae5c3e670ab49161b
|
||||
b2sums = 73696281868e5eba6493cc34786a6c30eaf256bed2495444be9a1a5ebf1a0d4b8f00bcc3fb91ce9de3ac8ff23663e41cab17b8fe42b1048366c8e9b95aefa905
|
||||
b2sums = SKIP
|
||||
b2sums = b5f2ee167103d53bc0d5ada123d9c3a1e394b5c0b992401da2d4cf69da30710f7d5b6b9264634e02a1e9856798780c1dc3faed01058274599290cb82c15dd193
|
||||
b2sums = 1ecf007b82260710a7bf5048f47dd5d600c168824c02c595af654632326536a6527fbe0738670ee7b921dd85a70425108e0f471ba85a8e1ca47d294ad74b4adb
|
||||
|
||||
pkgname = vulkan-mesa-layers
|
||||
|
|
|
@ -1,72 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: WinLinux1028 <reimu@hakurei.win>
|
||||
Date: Tue, 11 Jul 2023 18:16:01 +0900
|
||||
Subject: [PATCH] radeonsi: prefix function with si_ to prevent name collision
|
||||
|
||||
Fixed a build error caused by multiple gfx11_init_query symbols when building with iris and radeonsi specified in gallium-drivers.
|
||||
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/9238
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/24045>
|
||||
---
|
||||
src/gallium/drivers/radeonsi/gfx11_query.c | 4 ++--
|
||||
src/gallium/drivers/radeonsi/si_pipe.c | 4 ++--
|
||||
src/gallium/drivers/radeonsi/si_pipe.h | 4 ++--
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/radeonsi/gfx11_query.c b/src/gallium/drivers/radeonsi/gfx11_query.c
|
||||
index bfcd8e251105..2a331cc3bda2 100644
|
||||
--- a/src/gallium/drivers/radeonsi/gfx11_query.c
|
||||
+++ b/src/gallium/drivers/radeonsi/gfx11_query.c
|
||||
@@ -422,13 +422,13 @@ struct pipe_query *gfx11_sh_query_create(struct si_screen *screen, enum pipe_que
|
||||
return (struct pipe_query *)query;
|
||||
}
|
||||
|
||||
-void gfx11_init_query(struct si_context *sctx)
|
||||
+void si_gfx11_init_query(struct si_context *sctx)
|
||||
{
|
||||
list_inithead(&sctx->shader_query_buffers);
|
||||
sctx->atoms.s.shader_query.emit = emit_shader_query;
|
||||
}
|
||||
|
||||
-void gfx11_destroy_query(struct si_context *sctx)
|
||||
+void si_gfx11_destroy_query(struct si_context *sctx)
|
||||
{
|
||||
if (!sctx->shader_query_buffers.next)
|
||||
return;
|
||||
diff --git a/src/gallium/drivers/radeonsi/si_pipe.c b/src/gallium/drivers/radeonsi/si_pipe.c
|
||||
index 91da22b5746c..f11cd2256b95 100644
|
||||
--- a/src/gallium/drivers/radeonsi/si_pipe.c
|
||||
+++ b/src/gallium/drivers/radeonsi/si_pipe.c
|
||||
@@ -192,7 +192,7 @@ static void si_destroy_context(struct pipe_context *context)
|
||||
si_release_all_descriptors(sctx);
|
||||
|
||||
if (sctx->gfx_level >= GFX10 && sctx->has_graphics)
|
||||
- gfx11_destroy_query(sctx);
|
||||
+ si_gfx11_destroy_query(sctx);
|
||||
|
||||
if (sctx->sqtt) {
|
||||
struct si_screen *sscreen = sctx->screen;
|
||||
@@ -637,7 +637,7 @@ static struct pipe_context *si_create_context(struct pipe_screen *screen, unsign
|
||||
/* Initialize graphics-only context functions. */
|
||||
if (sctx->has_graphics) {
|
||||
if (sctx->gfx_level >= GFX10)
|
||||
- gfx11_init_query(sctx);
|
||||
+ si_gfx11_init_query(sctx);
|
||||
si_init_msaa_functions(sctx);
|
||||
si_init_shader_functions(sctx);
|
||||
si_init_state_functions(sctx);
|
||||
diff --git a/src/gallium/drivers/radeonsi/si_pipe.h b/src/gallium/drivers/radeonsi/si_pipe.h
|
||||
index 55f1d1788f1a..389716854f9a 100644
|
||||
--- a/src/gallium/drivers/radeonsi/si_pipe.h
|
||||
+++ b/src/gallium/drivers/radeonsi/si_pipe.h
|
||||
@@ -1616,8 +1616,8 @@ void *si_create_query_result_cs(struct si_context *sctx);
|
||||
void *gfx11_create_sh_query_result_cs(struct si_context *sctx);
|
||||
|
||||
/* gfx11_query.c */
|
||||
-void gfx11_init_query(struct si_context *sctx);
|
||||
-void gfx11_destroy_query(struct si_context *sctx);
|
||||
+void si_gfx11_init_query(struct si_context *sctx);
|
||||
+void si_gfx11_destroy_query(struct si_context *sctx);
|
||||
|
||||
/* si_test_image_copy_region.c */
|
||||
void si_test_image_copy_region(struct si_screen *sscreen);
|
|
@ -25,13 +25,13 @@ pkgname=(
|
|||
'mesa-vdpau'
|
||||
'mesa'
|
||||
)
|
||||
pkgver=23.2.1
|
||||
pkgrel=2
|
||||
pkgver=23.3.1
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
url="https://www.mesa3d.org/"
|
||||
arch=('x86_64')
|
||||
license=('custom')
|
||||
license=('MIT AND BSD-3-Clause AND SGI-B-2.0')
|
||||
makedepends=(
|
||||
'clang'
|
||||
'expat'
|
||||
|
@ -82,16 +82,13 @@ makedepends=(
|
|||
)
|
||||
source=(
|
||||
https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
0001-radeonsi-prefix-function-with-si_-to-prevent-name-co.patch
|
||||
LICENSE
|
||||
)
|
||||
sha256sums=('64de0616fc2d801f929ab1ac2a4f16b3e2783c4309a724c8a259b20df8bbc1cc'
|
||||
sha256sums=('6e48126d70fdb3f20ffeb246ca0c2e41ffdc835f0663a03d4526b8bf5db41de6'
|
||||
'SKIP'
|
||||
'fcd21477e5c6122dc74f72457364448b171f7843b7a671e1f9df9c61bd888898'
|
||||
'7052ba73bb07ea78873a2431ee4e828f4e72bda7d176d07f770fa48373dec537')
|
||||
b2sums=('51e44c2e9b7dfe17cf4cb7252e169109d03a006caa8ec34036fb594c0c44e9278d0088170894c1a9debdea911f746470e1d256576e0635cae5c3e670ab49161b'
|
||||
b2sums=('73696281868e5eba6493cc34786a6c30eaf256bed2495444be9a1a5ebf1a0d4b8f00bcc3fb91ce9de3ac8ff23663e41cab17b8fe42b1048366c8e9b95aefa905'
|
||||
'SKIP'
|
||||
'b5f2ee167103d53bc0d5ada123d9c3a1e394b5c0b992401da2d4cf69da30710f7d5b6b9264634e02a1e9856798780c1dc3faed01058274599290cb82c15dd193'
|
||||
'1ecf007b82260710a7bf5048f47dd5d600c168824c02c595af654632326536a6527fbe0738670ee7b921dd85a70425108e0f471ba85a8e1ca47d294ad74b4adb')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
|
@ -103,10 +100,6 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
|
|||
prepare() {
|
||||
cd mesa-$pkgver
|
||||
|
||||
# https://bugs.archlinux.org/task/79831
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/issues/9889#note_2113953
|
||||
patch -Np1 -i ../0001-radeonsi-prefix-function-with-si_-to-prevent-name-co.patch
|
||||
|
||||
# Include package release in version string so Chromium invalidates
|
||||
# its GPU cache; otherwise it can cause pages to render incorrectly.
|
||||
# https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/2020604
|
||||
|
|
Loading…
Reference in a new issue