mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/meson to 0.64.0-1
This commit is contained in:
parent
bbf8133187
commit
296bf0a647
3 changed files with 21 additions and 7 deletions
|
@ -5,8 +5,9 @@ Subject: [PATCH] Skip broken tests
|
|||
|
||||
---
|
||||
test cases/linuxlike/13 cmake dependency/meson.build | 2 ++
|
||||
unittests/allplatformstests.py | 2 +-
|
||||
unittests/linuxliketests.py | 2 ++
|
||||
2 files changed, 4 insertions(+)
|
||||
3 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test cases/linuxlike/13 cmake dependency/meson.build b/test cases/linuxlike/13 cmake dependency/meson.build
|
||||
index 193ad184b637..e94ba68ac30f 100644
|
||||
|
@ -21,11 +22,24 @@ index 193ad184b637..e94ba68ac30f 100644
|
|||
# Zlib is probably on all dev machines.
|
||||
|
||||
dep = dependency('ZLIB', version : '>=1.2', method : 'cmake')
|
||||
diff --git a/unittests/allplatformstests.py b/unittests/allplatformstests.py
|
||||
index 1ecbf18e3477..c567bb794138 100644
|
||||
--- a/unittests/allplatformstests.py
|
||||
+++ b/unittests/allplatformstests.py
|
||||
@@ -4352,7 +4352,7 @@ class AllPlatformTests(BasePlatformTests):
|
||||
self.init(testdir, extra_args=['--werror'], override_envvars={'RUSTC': 'clippy-driver'})
|
||||
with self.assertRaises(subprocess.CalledProcessError) as cm:
|
||||
self.build()
|
||||
- self.assertIn('error: use of a blacklisted/placeholder name `foo`', cm.exception.stdout)
|
||||
+ self.assertIn('error: use of a disallowed/placeholder name `foo`', cm.exception.stdout)
|
||||
|
||||
@skip_if_not_language('rust')
|
||||
def test_rust_rlib_linkage(self) -> None:
|
||||
diff --git a/unittests/linuxliketests.py b/unittests/linuxliketests.py
|
||||
index 6c4012d1a056..59ed1a750b94 100644
|
||||
index 8dd9cfc4e1f3..47bd4be1477d 100644
|
||||
--- a/unittests/linuxliketests.py
|
||||
+++ b/unittests/linuxliketests.py
|
||||
@@ -357,6 +357,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
@@ -359,6 +359,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
|
@ -33,7 +47,7 @@ index 6c4012d1a056..59ed1a750b94 100644
|
|||
|
||||
testdir = os.path.join(self.framework_test_dir, '7 gnome')
|
||||
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|
||||
@@ -1012,6 +1013,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
@@ -1014,6 +1015,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.63.3
|
||||
pkgver=0.64.0
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
|
@ -22,9 +22,9 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
||||
0001-Skip-broken-tests.patch
|
||||
arch-meson)
|
||||
sha512sums=('6855b2bfe05d592419bfeaf4346c3d1079319f14de995109c09a7e5e9770cef829f66d659553337b3e54ca0dd6c497bccd4abef720f299173077b664d905864b'
|
||||
sha512sums=('0656515e983d98350081dc7cd726bff4a83ed1e24d414c022ea804317f2ff86052b53bbbc36e00847541f2cbe19ebe4c87bb35a174bf6321864363512a4cf6b0'
|
||||
'SKIP'
|
||||
'fea6b37d7c07e7f591978d2f495e759d2f6b82126eff7835f823c24848d5a7c32356fe175eefeb2bcba0edb68109d8080de5e128a5317808128dc1ba5c15e92d'
|
||||
'521d662c9bbf8c4618f5f3d5f37ad206d61e222b5e29a6bb0df72ad4da3e4e2d14f60b6ea5fefeba501a06729b257cfe7450cb35946bf0cd7589558529591a4a'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
|
|
0
extra/meson/arch-meson
Normal file → Executable file
0
extra/meson/arch-meson
Normal file → Executable file
Loading…
Reference in a new issue