community/libopenshot-audio to 0.2.2-1

This commit is contained in:
Kevin Mihelich 2021-09-15 21:51:03 +00:00
parent f7797b71d0
commit 2978361097
2 changed files with 8 additions and 28 deletions

View file

@ -4,33 +4,27 @@
# Contributor: Jonathan Thomas <jonathan@openshot.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to link v5/v6 with libatomic
# - explicitly link v5/v6 with libatomic
pkgname=libopenshot-audio
pkgver=0.2.0
pkgver=0.2.2
pkgrel=1
pkgdesc="A high-quality audio editing and playback library used by libopenshot."
arch=('x86_64')
url="https://openshot.org/"
license=('GPL3')
depends=('gcc-libs' 'glibc' 'zlib')
makedepends=('alsa-lib' 'cmake' 'doxygen' 'freetype2' 'libx11')
makedepends=('alsa-lib' 'cmake' 'doxygen' 'freetype2' 'libx11' 'python')
provides=('libopenshot-audio.so')
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/libopenshot-audio/archive/v$pkgver.tar.gz"
atomic.patch)
sha512sums=('c014a619f32283a8482e0df9224785610a9563073fbd98378367f28f713afa1dc9873d212a40352d3c96040004344f16084e5fe30e4cf64c57309f96e66068c1'
'5b527fc2406342bff8d29a2736226ce214dbf6ecf90a0e90e424ff68edf535d5eefcbe720201af3876c2c0b86eda1c8749c52984d3996d471d80ecabafad39e9')
prepare() {
cd "${pkgname}-${pkgver}"
if [[ $CARCH == "armv6h" || $CARCH == "arm" ]]; then
patch -p1 -i ../atomic.patch
fi
}
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
sha512sums=('9960c6225dd9b843d18134e851761bf12861220a2c63970055bc73d554725e56abd6d35339f7490b672faaf0699f58e3701ff8a966ab07af3264325a9d0dc472')
b2sums=('fcf242bdd678d2e79e2775f3aff7507520a4e8b9ddc7696e1506beca0c1f8e0687d66dfa35a31748e2e622def6e1c22c160e9424c1c27527854ebcafc24413ca')
build() {
cd "${pkgname}-${pkgver}"
[[ $CARCH == "armv6h" || $CARCH == "arm" ]] && echo "target_link_libraries(openshot-audio PUBLIC atomic)" >> CMakeLists.txt
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev \
-B build \
-S .
make VERBOSE=1 -C build

View file

@ -1,14 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a80f95..1bf02ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,7 +202,8 @@ target_link_libraries(openshot-audio PUBLIC ZLIB::ZLIB)
target_link_libraries(openshot-audio PUBLIC
${CMAKE_DL_LIBS}
- ${JUCE_PLATFORM_SPECIFIC_LIBRARIES} )
+ ${JUCE_PLATFORM_SPECIFIC_LIBRARIES}
+ atomic)
# PROCESS SUB-DIRECTORIES
add_subdirectory(src)