mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed core/linux-kirkwood
This commit is contained in:
parent
4423a0dfe8
commit
2979d95351
6 changed files with 0 additions and 15204 deletions
|
@ -1,25 +0,0 @@
|
||||||
From 311bb4a115f653ff9f3202873303483007906c8f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Sun, 31 Aug 2014 08:45:13 -0600
|
|
||||||
Subject: [PATCH] disable mv643xx_eth TSO
|
|
||||||
|
|
||||||
---
|
|
||||||
drivers/net/ethernet/marvell/mv643xx_eth.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/net/ethernet/marvell/mv643xx_eth.c b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
|
||||||
index b151a94..e04af62 100644
|
|
||||||
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
|
|
||||||
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
|
||||||
@@ -3110,7 +3110,7 @@ static int mv643xx_eth_probe(struct platform_device *pdev)
|
|
||||||
dev->watchdog_timeo = 2 * HZ;
|
|
||||||
dev->base_addr = 0;
|
|
||||||
|
|
||||||
- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
|
|
||||||
+ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
|
|
||||||
dev->vlan_features = dev->features;
|
|
||||||
|
|
||||||
dev->features |= NETIF_F_RXCSUM;
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
|
@ -1,313 +0,0 @@
|
||||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# Maintainer: Oleg Rakhmanov <oleg@archlinuxarm.org>
|
|
||||||
|
|
||||||
buildarch=2
|
|
||||||
|
|
||||||
pkgbase=linux-kirkwood
|
|
||||||
_kernelname=${pkgbase#linux}
|
|
||||||
_desc="Marvell Kirkwood"
|
|
||||||
pkgver=4.4.271
|
|
||||||
srcver=${pkgver%.0}
|
|
||||||
pkgrel=1
|
|
||||||
bfqver=v7r11
|
|
||||||
bfqkern=4.4
|
|
||||||
|
|
||||||
### AUFS branch name
|
|
||||||
aufsbranch="aufs${pkgver:0:3}"
|
|
||||||
# aufsbranch="aufs4.x-rcN"
|
|
||||||
|
|
||||||
arch=('arm')
|
|
||||||
url="http://www.kernel.org/"
|
|
||||||
license=('GPL2')
|
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'kmod' 'inetutils' 'bc' 'git')
|
|
||||||
options=('!strip')
|
|
||||||
|
|
||||||
source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
|
||||||
'archlinuxarm.patch'
|
|
||||||
'config'
|
|
||||||
'mach-types::http://www.arm.linux.org.uk/developer/machines/download.php'
|
|
||||||
'0001-disable-mv643xx_eth-TSO.patch'
|
|
||||||
"git+https://github.com/sfjro/aufs4-standalone.git#branch=${aufsbranch}"
|
|
||||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${bfqkern}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.0.patch"
|
|
||||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${bfqkern}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${bfqkern}.0.patch"
|
|
||||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${bfqkern}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for.patch"
|
|
||||||
'linux.preset')
|
|
||||||
md5sums=('584eb1b7c84316e8b27ca693b6672ced'
|
|
||||||
'3d14399c6859415d6ccc87f9a975a112'
|
|
||||||
'17d32adf31f1b709bb2cef32845d4d0a'
|
|
||||||
'5aeefba6796ed9be43b8e408b3cbe299'
|
|
||||||
'09d44b9f07abfaeaf4f688ee52034786'
|
|
||||||
'SKIP'
|
|
||||||
'c1d7fcfe88edb658375089c0a9cc1811'
|
|
||||||
'953133d5e387de2ad79ac0ae5c27cb6b'
|
|
||||||
'f0387e673975e9f2a5e05136948edece'
|
|
||||||
'6d8c200779cbdef582e9e435ed86ca31')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${srcdir}/linux-${srcver}"
|
|
||||||
|
|
||||||
msg2 "Copying aufs patches into the kernel source tree"
|
|
||||||
cp -ru "${srcdir}/aufs4-standalone/"{Documentation,fs} "${srcdir}/linux-${srcver}/"
|
|
||||||
cp -ru "${srcdir}/aufs4-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/linux-${srcver}/include/"{linux/,uapi/linux/}
|
|
||||||
|
|
||||||
msg2 "Applying aufs patches"
|
|
||||||
patch -Np1 -i ../aufs4-standalone/aufs4-kbuild.patch
|
|
||||||
patch -Np1 -i ../aufs4-standalone/aufs4-base.patch
|
|
||||||
patch -Np1 -i ../aufs4-standalone/aufs4-mmap.patch
|
|
||||||
patch -Np1 -i ../aufs4-standalone/aufs4-standalone.patch
|
|
||||||
|
|
||||||
msg2 "Disable buggy TCP segmentation offload implementation"
|
|
||||||
msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
|
|
||||||
patch -Np1 -i ${srcdir}/0001-disable-mv643xx_eth-TSO.patch
|
|
||||||
|
|
||||||
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers, mach-types"
|
|
||||||
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
|
|
||||||
cp "${srcdir}/mach-types" arch/arm/tools
|
|
||||||
|
|
||||||
msg2 "Add BFQ patches"
|
|
||||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.0.patch"
|
|
||||||
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${bfqkern}.0.patch"
|
|
||||||
patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for.patch"
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
|
||||||
|
|
||||||
# add pkgrel to extraversion
|
|
||||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
|
||||||
|
|
||||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
|
||||||
sed -i '2iexit 0' scripts/depmod.sh
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "${srcdir}/linux-${srcver}"
|
|
||||||
|
|
||||||
# get kernel version
|
|
||||||
make prepare
|
|
||||||
|
|
||||||
# load configuration
|
|
||||||
# Configure the kernel. Replace the line below with one of your choice.
|
|
||||||
#make menuconfig # CLI menu for configuration
|
|
||||||
#make nconfig # new CLI menu for configuration
|
|
||||||
#make xconfig # X-based configuration
|
|
||||||
#make oldconfig # using old config from previous kernel version
|
|
||||||
# ... or manually edit .config
|
|
||||||
|
|
||||||
# Copy back our configuration (use with new kernel version)
|
|
||||||
#cp ./.config ../${pkgbase}.config
|
|
||||||
|
|
||||||
####################
|
|
||||||
# stop here
|
|
||||||
# this is useful to configure the kernel
|
|
||||||
#msg "Stopping build"
|
|
||||||
#return 1
|
|
||||||
####################
|
|
||||||
|
|
||||||
#yes "" | make config
|
|
||||||
|
|
||||||
msg "Building!"
|
|
||||||
make ${MAKEFLAGS} uImage modules
|
|
||||||
}
|
|
||||||
|
|
||||||
_package() {
|
|
||||||
pkgdesc="The Linux Kernel and modules - ${_desc}"
|
|
||||||
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
|
|
||||||
optdepends=('crda: to set the correct wireless channels of your country')
|
|
||||||
provides=('kernel26' 'linux=${pkgver}' 'aufs_friendly')
|
|
||||||
conflicts=('linux-kirkwood-dt' 'linux' 'linux-olinuxino')
|
|
||||||
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
|
|
||||||
install=${pkgname}.install
|
|
||||||
|
|
||||||
cd "${srcdir}/linux-${srcver}"
|
|
||||||
|
|
||||||
KARCH=arm
|
|
||||||
|
|
||||||
# get kernel version
|
|
||||||
_kernver="$(make kernelrelease)"
|
|
||||||
#_basekernel=${_kernver%%-*}
|
|
||||||
#_basekernel=${_basekernel%.*}
|
|
||||||
_basekernel=${pkgver}
|
|
||||||
|
|
||||||
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
|
|
||||||
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
|
||||||
cp arch/$KARCH/boot/uImage "${pkgdir}/boot/uImage"
|
|
||||||
|
|
||||||
# set correct depmod command for install
|
|
||||||
sed \
|
|
||||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
|
||||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
|
||||||
-i "${startdir}/${pkgname}.install"
|
|
||||||
|
|
||||||
# install mkinitcpio preset file for kernel
|
|
||||||
install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
|
|
||||||
sed \
|
|
||||||
-e "1s|'linux.*'|'${pkgbase}'|" \
|
|
||||||
-e "s|ALL_kver=.*|ALL_kver=\"${_kernver}\"|" \
|
|
||||||
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
|
|
||||||
|
|
||||||
# remove build and source links
|
|
||||||
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
|
||||||
# remove the firmware
|
|
||||||
rm -rf "${pkgdir}/lib/firmware"
|
|
||||||
# gzip -9 all modules to save 100MB of space
|
|
||||||
find "${pkgdir}" -name '*.ko' |xargs -P 2 -n 1 gzip -9
|
|
||||||
# make room for external modules
|
|
||||||
ln -s "../extramodules-${_basekernel}-${_kernelname:-ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
|
||||||
# add real version for building modules and running depmod from post_install/upgrade
|
|
||||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
|
||||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
|
||||||
|
|
||||||
cd "${srcdir}/linux-${srcver}"
|
|
||||||
|
|
||||||
# Now we call depmod...
|
|
||||||
depmod -b "$pkgdir" -F System.map "$_kernver"
|
|
||||||
|
|
||||||
# move module tree /lib -> /usr/lib
|
|
||||||
mkdir -p "${pkgdir}/usr"
|
|
||||||
mv "$pkgdir/lib" "$pkgdir/usr"
|
|
||||||
}
|
|
||||||
|
|
||||||
_package-headers() {
|
|
||||||
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
|
||||||
provides=('linux-headers=${pkgver}')
|
|
||||||
conflicts=('linux-headers-kirkwood-dt' 'linux-headers' 'linux-headers-olinuxino')
|
|
||||||
replaces=('linux-headers-kirkwood')
|
|
||||||
|
|
||||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
|
||||||
|
|
||||||
cd "${pkgdir}/usr/lib/modules/${_kernver}"
|
|
||||||
ln -sf ../../../src/linux-${_kernver} build
|
|
||||||
|
|
||||||
cd "${srcdir}/linux-${srcver}"
|
|
||||||
install -D -m644 Makefile \
|
|
||||||
"${pkgdir}/usr/src/linux-${_kernver}/Makefile"
|
|
||||||
install -D -m644 kernel/Makefile \
|
|
||||||
"${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile"
|
|
||||||
install -D -m644 .config \
|
|
||||||
"${pkgdir}/usr/src/linux-${_kernver}/.config"
|
|
||||||
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include"
|
|
||||||
|
|
||||||
for i in acpi asm-generic config crypto drm generated linux math-emu \
|
|
||||||
media net pcmcia scsi sound trace uapi video xen; do
|
|
||||||
cp -a include/${i} "${pkgdir}/usr/src/linux-${_kernver}/include/"
|
|
||||||
done
|
|
||||||
|
|
||||||
# copy arch includes for external modules
|
|
||||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
|
||||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
|
||||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood
|
|
||||||
cp -a arch/$KARCH/mach-kirkwood/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-kirkwood/
|
|
||||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/plat-orion
|
|
||||||
cp -a arch/$KARCH/plat-orion/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/plat-orion/
|
|
||||||
|
|
||||||
# copy files necessary for later builds, like nvidia and vmware
|
|
||||||
cp Module.symvers "${pkgdir}/usr/src/linux-${_kernver}"
|
|
||||||
cp -a scripts "${pkgdir}/usr/src/linux-${_kernver}"
|
|
||||||
|
|
||||||
# fix permissions on scripts dir
|
|
||||||
chmod og-w -R "${pkgdir}/usr/src/linux-${_kernver}/scripts"
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions"
|
|
||||||
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel"
|
|
||||||
|
|
||||||
cp arch/${KARCH}/Makefile "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/"
|
|
||||||
|
|
||||||
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel/"
|
|
||||||
|
|
||||||
# add headers for lirc package
|
|
||||||
# pci
|
|
||||||
for i in bt8xx cx88 saa7134; do
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/pci/${i}"
|
|
||||||
cp -a drivers/media/pci/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/pci/${i}"
|
|
||||||
done
|
|
||||||
# usb
|
|
||||||
for i in cpia2 em28xx pwc; do
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
|
||||||
cp -a drivers/media/usb/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
|
||||||
done
|
|
||||||
# i2c
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/i2c"
|
|
||||||
cp drivers/media/i2c/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/i2c/"
|
|
||||||
for i in cx25840; do
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/i2c/${i}"
|
|
||||||
cp -a drivers/media/i2c/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/i2c/${i}"
|
|
||||||
done
|
|
||||||
|
|
||||||
# add docbook makefile
|
|
||||||
install -D -m644 Documentation/DocBook/Makefile \
|
|
||||||
"${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"
|
|
||||||
|
|
||||||
# add dm headers
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
|
||||||
cp drivers/md/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
|
||||||
|
|
||||||
# add inotify.h
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/linux"
|
|
||||||
cp include/linux/inotify.h "${pkgdir}/usr/src/linux-${_kernver}/include/linux/"
|
|
||||||
|
|
||||||
# add wireless headers
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
|
||||||
cp net/mac80211/*.h "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
|
||||||
|
|
||||||
# add dvb headers for external modules
|
|
||||||
# in reference to:
|
|
||||||
# http://bugs.archlinux.org/task/9912
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core"
|
|
||||||
cp drivers/media/dvb-core/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core/"
|
|
||||||
# and...
|
|
||||||
# http://bugs.archlinux.org/task/11194
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
|
||||||
cp include/config/dvb/*.h "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
|
||||||
|
|
||||||
# add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
|
|
||||||
# in reference to:
|
|
||||||
# http://bugs.archlinux.org/task/13146
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends/"
|
|
||||||
cp drivers/media/dvb-frontends/lgdt330x.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends/"
|
|
||||||
cp drivers/media/i2c/msp3400-driver.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/i2c/"
|
|
||||||
|
|
||||||
# add dvb headers
|
|
||||||
# in reference to:
|
|
||||||
# http://bugs.archlinux.org/task/20402
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb"
|
|
||||||
cp drivers/media/usb/dvb-usb/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb/"
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends"
|
|
||||||
cp drivers/media/dvb-frontends/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends/"
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners"
|
|
||||||
cp drivers/media/tuners/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners/"
|
|
||||||
|
|
||||||
# add xfs and shmem for aufs building
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs"
|
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
|
||||||
|
|
||||||
# copy in Kconfig files
|
|
||||||
for i in `find . -name "Kconfig*"`; do
|
|
||||||
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
|
||||||
cp ${i} "${pkgdir}/usr/src/linux-${_kernver}/${i}"
|
|
||||||
done
|
|
||||||
|
|
||||||
chown -R root.root "${pkgdir}/usr/src/linux-${_kernver}"
|
|
||||||
find "${pkgdir}/usr/src/linux-${_kernver}" -type d -exec chmod 755 {} \;
|
|
||||||
|
|
||||||
# strip scripts directory
|
|
||||||
find "${pkgdir}/usr/src/linux-${_kernver}/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
|
|
||||||
case "$(file -bi "${binary}")" in
|
|
||||||
*application/x-sharedlib*) # Libraries (.so)
|
|
||||||
/usr/bin/strip ${STRIP_SHARED} "${binary}";;
|
|
||||||
*application/x-archive*) # Libraries (.a)
|
|
||||||
/usr/bin/strip ${STRIP_STATIC} "${binary}";;
|
|
||||||
*application/x-executable*) # Binaries
|
|
||||||
/usr/bin/strip ${STRIP_BINARIES} "${binary}";;
|
|
||||||
esac
|
|
||||||
done
|
|
||||||
|
|
||||||
# remove unneeded architectures
|
|
||||||
rm -rf "${pkgdir}"/usr/src/linux-${_kernver}/arch/{alpha,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
|
||||||
}
|
|
||||||
|
|
||||||
pkgname=("${pkgbase}" "${pkgbase}-headers")
|
|
||||||
for _p in ${pkgname[@]}; do
|
|
||||||
eval "package_${_p}() {
|
|
||||||
_package${_p#${pkgbase}}
|
|
||||||
}"
|
|
||||||
done
|
|
File diff suppressed because it is too large
Load diff
File diff suppressed because it is too large
Load diff
|
@ -1,41 +0,0 @@
|
||||||
# arg 1: the new package version
|
|
||||||
# arg 2: the old package version
|
|
||||||
|
|
||||||
KERNEL_NAME=-kirkwood
|
|
||||||
KERNEL_VERSION=4.4.271-1-ARCH
|
|
||||||
|
|
||||||
post_install () {
|
|
||||||
# updating module dependencies
|
|
||||||
echo ">>> Updating module dependencies. Please wait ..."
|
|
||||||
depmod ${KERNEL_VERSION}
|
|
||||||
|
|
||||||
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
|
|
||||||
mkinitcpio -p linux${KERNEL_NAME}
|
|
||||||
|
|
||||||
echo "**********************************************************************"
|
|
||||||
echo "WARNING! This kernel requires a newer U-Boot than many devices such as"
|
|
||||||
echo " the Dockstar and Pogoplug v2 originally came with. If you do"
|
|
||||||
echo " not have an updated version, your system WILL NOT BOOT."
|
|
||||||
echo "**********************************************************************"
|
|
||||||
}
|
|
||||||
|
|
||||||
post_upgrade() {
|
|
||||||
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
|
|
||||||
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
|
|
||||||
echo "WARNING: /boot appears to be a separate partition but is not mounted."
|
|
||||||
echo " You probably just broke your system. Congratulations."
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
# updating module dependencies
|
|
||||||
echo ">>> Updating module dependencies. Please wait ..."
|
|
||||||
depmod ${KERNEL_VERSION}
|
|
||||||
|
|
||||||
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
|
|
||||||
mkinitcpio -p linux${KERNEL_NAME}
|
|
||||||
}
|
|
||||||
|
|
||||||
post_remove() {
|
|
||||||
# also remove the compat symlinks
|
|
||||||
rm -f boot/initramfs-linux.img
|
|
||||||
}
|
|
|
@ -1,10 +0,0 @@
|
||||||
# mkinitcpio preset file for the 'linux-aarch64' package
|
|
||||||
|
|
||||||
ALL_config="/etc/mkinitcpio.conf"
|
|
||||||
ALL_kver="4.3.0-1-ARCH"
|
|
||||||
|
|
||||||
PRESETS=('default')
|
|
||||||
|
|
||||||
#default_config="/etc/mkinitcpio.conf"
|
|
||||||
default_image="/boot/initramfs-linux.img"
|
|
||||||
#default_options=""
|
|
Loading…
Reference in a new issue