extra/gstreamer to 1.22.2-1

This commit is contained in:
Kevin Mihelich 2023-05-03 23:25:43 +00:00
parent 62eaab38f7
commit 29b5a95a55
5 changed files with 115 additions and 82 deletions

View file

@ -4,14 +4,15 @@ Date: Mon, 6 Jun 2022 00:30:08 +0200
Subject: [PATCH] HACK: meson: Disable broken tests
---
subprojects/gst-editing-services/meson.build | 1 -
subprojects/gst-python/meson.build | 1 -
subprojects/gst-rtsp-server/tests/check/meson.build | 1 -
subprojects/gstreamer-vaapi/meson.build | 1 -
4 files changed, 4 deletions(-)
subprojects/gst-editing-services/meson.build | 1 -
subprojects/gst-plugins-good/tests/check/elements/flvmux.c | 1 -
subprojects/gst-python/meson.build | 1 -
subprojects/gst-rtsp-server/tests/check/meson.build | 1 -
subprojects/gstreamer-vaapi/meson.build | 1 -
5 files changed, 5 deletions(-)
diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
index 6b768600932a..be99474e97ba 100644
index 89078bbd7a3b..5745256d3b2f 100644
--- a/subprojects/gst-editing-services/meson.build
+++ b/subprojects/gst-editing-services/meson.build
@@ -270,7 +270,6 @@ subdir('ges')
@ -22,8 +23,20 @@ index 6b768600932a..be99474e97ba 100644
if not get_option('examples').disabled()
subdir('examples')
endif
diff --git a/subprojects/gst-plugins-good/tests/check/elements/flvmux.c b/subprojects/gst-plugins-good/tests/check/elements/flvmux.c
index 53a8e634e41a..f270c1d11bfb 100644
--- a/subprojects/gst-plugins-good/tests/check/elements/flvmux.c
+++ b/subprojects/gst-plugins-good/tests/check/elements/flvmux.c
@@ -1162,7 +1162,6 @@ flvmux_suite (void)
tcase_add_test (tc_chain, test_speex_streamable);
tcase_add_test (tc_chain, test_increasing_timestamp_when_pts_none);
- tcase_add_test (tc_chain, test_video_caps_late);
tcase_add_test (tc_chain, test_audio_caps_change_streamable);
tcase_add_test (tc_chain, test_video_caps_change_streamable);
tcase_add_test (tc_chain, test_audio_caps_change_streamable_single);
diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
index 6f5747a4c8d4..2113fca44cf6 100644
index 9f35ee5a4a16..6698e392b72c 100644
--- a/subprojects/gst-python/meson.build
+++ b/subprojects/gst-python/meson.build
@@ -107,5 +107,4 @@ if not get_option('plugin').disabled()
@ -45,7 +58,7 @@ index 229af32f8117..b9372c125d77 100644
'gst/sessionpool',
'gst/stream',
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
index aa2dce6c2e9c..84b61fd6a014 100644
index 8fef4f81e833..16d96d6a4ed6 100644
--- a/subprojects/gstreamer-vaapi/meson.build
+++ b/subprojects/gstreamer-vaapi/meson.build
@@ -219,7 +219,6 @@ plugins = []

View file

@ -1,62 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Fri, 3 Mar 2023 16:46:35 +0000
Subject: [PATCH] zxing: update to 2.0.0 tag
---
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 4 ++--
subprojects/gst-plugins-bad/ext/zxing/meson.build | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
index 7836dbbcf18e..a7a24168383f 100644
--- a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
+++ b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
@@ -369,32 +369,32 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
if (result.isValid ()) {
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
result.text ().c_str (),
- ToString (result.format ()));
+ ToString (result.format ()).c_str ());
} else {
goto out;
}
/* extract results */
if (zxing->message) {
GstMessage *m;
GstStructure *s;
GstSample *sample;
GstCaps *sample_caps;
GstClockTime timestamp, running_time, stream_time;
timestamp = GST_BUFFER_TIMESTAMP (frame->buffer);
running_time =
gst_segment_to_running_time (&GST_BASE_TRANSFORM (zxing)->segment,
GST_FORMAT_TIME, timestamp);
stream_time =
gst_segment_to_stream_time (&GST_BASE_TRANSFORM (zxing)->segment,
GST_FORMAT_TIME, timestamp);
s = gst_structure_new ("barcode",
"timestamp", G_TYPE_UINT64, timestamp,
"stream-time", G_TYPE_UINT64, stream_time,
"running-time", G_TYPE_UINT64, running_time,
- "type", G_TYPE_STRING, ToString (result.format ()),
+ "type", G_TYPE_STRING, ToString (result.format ()).c_str (),
"symbol", G_TYPE_STRING,
result.text ().c_str (), NULL);
diff --git a/subprojects/gst-plugins-bad/ext/zxing/meson.build b/subprojects/gst-plugins-bad/ext/zxing/meson.build
index 2dbad9ab1eea..89e1f6592e7a 100644
--- a/subprojects/gst-plugins-bad/ext/zxing/meson.build
+++ b/subprojects/gst-plugins-bad/ext/zxing/meson.build
@@ -2,7 +2,7 @@ zxing_sources = [
'gstzxing.cpp',
'gstzxingplugin.c',
]
-zxing_dep = dependency('zxing', version : '>= 1.4.0', required : get_option('zxing'))
+zxing_dep = dependency('zxing', version : '>= 2.0.0', required : get_option('zxing'))
if zxing_dep.found()
gstzxing = library('gstzxing',
zxing_sources,

View file

@ -0,0 +1,80 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Mon, 10 Apr 2023 16:06:19 +0200
Subject: [PATCH] tests: allocators: Fix fdmem test with recent GLib
The test failed with recent GLib, where `g_close` emits a critical
warning on EBADF. Remove the `g_close` check from `test_fdmem` and add
another version that tests `GST_FD_MEMORY_FLAG_DONT_CLOSE`.
We will depend on the Valgrind test run to warn us about leaked FDs.
Fixes: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/2480
---
.../tests/check/libs/allocators.c | 39 ++++++++++++++++++-
1 file changed, 38 insertions(+), 1 deletion(-)
diff --git a/subprojects/gst-plugins-base/tests/check/libs/allocators.c b/subprojects/gst-plugins-base/tests/check/libs/allocators.c
index 6b974b2900e9..c8ee75bcdbe3 100644
--- a/subprojects/gst-plugins-base/tests/check/libs/allocators.c
+++ b/subprojects/gst-plugins-base/tests/check/libs/allocators.c
@@ -95,21 +95,58 @@ GST_START_TEST (test_fdmem)
gst_memory_unmap (mem, &info);
gst_memory_unref (mem);
- fail_unless (g_close (fd, NULL) == 0);
+ gst_object_unref (alloc);
+}
+
+GST_END_TEST;
+
+GST_START_TEST (test_fdmem_dont_close)
+{
+ GstAllocator *alloc;
+ GstMemory *mem;
+ GstMapInfo info;
+ GError *error = NULL;
+ int fd;
+ const char *data = "0123456789";
+
+ fd = g_file_open_tmp (NULL, NULL, &error);
+ fail_if (error);
+ fail_unless (write (fd, data, 10) == 10);
+
+ alloc = gst_fd_allocator_new ();
+ fail_unless (alloc);
+ mem = gst_fd_allocator_alloc (alloc, fd, 10,
+ GST_FD_MEMORY_FLAG_KEEP_MAPPED | GST_FD_MEMORY_FLAG_DONT_CLOSE);
+
+ fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
+ fail_unless (info.data[5] == '5');
+ gst_memory_unmap (mem, &info);
+
+ fail_unless (gst_memory_map (mem, &info, GST_MAP_WRITE));
+ info.data[5] = 'X';
+ gst_memory_unmap (mem, &info);
+
+ fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
+ fail_unless (info.data[5] == 'X');
+ gst_memory_unmap (mem, &info);
+
+ gst_memory_unref (mem);
+ fail_unless (g_close (fd, NULL));
gst_object_unref (alloc);
}
GST_END_TEST;
static Suite *
allocators_suite (void)
{
Suite *s = suite_create ("allocators");
TCase *tc_chain = tcase_create ("general");
suite_add_tcase (s, tc_chain);
tcase_add_test (tc_chain, test_dmabuf);
tcase_add_test (tc_chain, test_fdmem);
+ tcase_add_test (tc_chain, test_fdmem_dont_close);
return s;
}

View file

@ -31,8 +31,8 @@ pkgname=(
gst-python
gstreamer-docs
)
pkgver=1.22.1
pkgrel=2
pkgver=1.22.2
pkgrel=1
pkgdesc="Multimedia graph framework"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@ -81,15 +81,15 @@ source=(
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git?signed#tag=$pkgver"
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-$pkgver.tar.xz"{,.asc}
0001-HACK-meson-Disable-broken-tests.patch
0002-zxing-update-to-2.0.0-tag.patch
0003-imagesequencesrc-Properly-set-default-location.patch
0002-imagesequencesrc-Properly-set-default-location.patch
0003-tests-allocators-Fix-fdmem-test-with-recent-GLib.patch
)
b2sums=('SKIP'
'9f8e55732a60aebc8f0f50ba41ef06a739c80290f552f19c80ce71206e1094aadec5dcc57c908a277b33770f505b8f6b6e0e196abc8237778a3d4880bcd6d89a'
'7156bcd222dd35d063711cafb86bb944cdd493362c945be57192be32987604f6bb1981c39c73f130347a108398907063cc7286f7d25950a0eeaa55c367888956'
'SKIP'
'7fa36829d5ebfb7b673a0fc36b8606d7e8e23975158e59406e9e31c2d82a6c774221b21ae6a49ef234f109e3a352ca04bf50d15f0e66b30667dd5df8cb80bc48'
'9934ab83fb55e2c8b48ede8d1d018d3757725dc869bb9fe20bd66982d04ca164f41a07968c83105be96e4262fd05d9917ed365cd7eb360259174ee9ba6d8f1ad'
'fd5bfeaf5a08f225bfb81df1beac55c3d7332aa4ffb1ba0a3e662dccea6b5ca43eecee92578c54d2fc1e3aa2edc73eb09a02e9c0a8ac3ad2002995a6a0396fa2')
'9437da39122a15e6501a325193bce135b2706de72f6dd0133120b70ad1b05b8b0191aae4d740430ddfb9787164930cb184afa57ebd0b431edd9452317661d2e5'
'fd5bfeaf5a08f225bfb81df1beac55c3d7332aa4ffb1ba0a3e662dccea6b5ca43eecee92578c54d2fc1e3aa2edc73eb09a02e9c0a8ac3ad2002995a6a0396fa2'
'8ba563a47ef4aa063b244f0e2ca8be2aee2d61174bdd4affa86979131ef8862d44da0f1be2a965482fbe1a8bbaee5d8103fc6644806a78e2d977e3fd0e46ed23')
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
prepare() {
@ -98,11 +98,13 @@ prepare() {
# Disable broken tests
git apply -3 ../0001-HACK-meson-Disable-broken-tests.patch
# Fix build with zxing-cpp 2.0
git apply -3 ../0002-zxing-update-to-2.0.0-tag.patch
# Fix crash
git apply -3 ../0003-imagesequencesrc-Properly-set-default-location.patch
# https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/4109
git apply -3 ../0002-imagesequencesrc-Properly-set-default-location.patch
# Fix fdmem test
# https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/4381
git apply -3 ../0003-tests-allocators-Fix-fdmem-test-with-recent-GLib.patch
}
build() {