mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/ruby to 2.7.0-1
This commit is contained in:
parent
06d9b2030a
commit
2a1ef0f44b
2 changed files with 12 additions and 9 deletions
|
@ -1,17 +1,17 @@
|
|||
From 058bf8ae8686bd441188a62e950227e50214056b Mon Sep 17 00:00:00 2001
|
||||
From bc148b24448c68bc2720a10db4424d8a6d5772b3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 14 Jan 2019 21:34:02 -0700
|
||||
Subject: [PATCH] Use only unsigned long for rb_serial_t
|
||||
|
||||
---
|
||||
internal.h | 10 ----------
|
||||
1 file changed, 10 deletions(-)
|
||||
internal.h | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/internal.h b/internal.h
|
||||
index 28a2f74..8c16c5a 100644
|
||||
index baefb36c02..f57dc911ef 100644
|
||||
--- a/internal.h
|
||||
+++ b/internal.h
|
||||
@@ -941,19 +941,9 @@ struct rb_subclass_entry {
|
||||
@@ -1000,22 +1000,10 @@ struct rb_subclass_entry {
|
||||
rb_subclass_entry_t *next;
|
||||
};
|
||||
|
||||
|
@ -19,18 +19,21 @@ index 28a2f74..8c16c5a 100644
|
|||
-typedef unsigned LONG_LONG rb_serial_t;
|
||||
-#define SERIALT2NUM ULL2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_LONG_LONG
|
||||
-#elif defined(HAVE_UINT64_T)
|
||||
-typedef uint64_t rb_serial_t;
|
||||
-#define SERIALT2NUM SIZET2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_UINT64_T
|
||||
-#else
|
||||
typedef unsigned long rb_serial_t;
|
||||
#define SERIALT2NUM ULONG2NUM
|
||||
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
|
||||
#define SIZEOF_SERIAL_T SIZEOF_LONG
|
||||
-#endif
|
||||
|
||||
struct rb_classext_struct {
|
||||
struct st_table *iv_index_tbl;
|
||||
--
|
||||
2.20.1
|
||||
2.24.1
|
||||
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
# - patch to fix running ruby on 32-bit ARM
|
||||
|
||||
pkgname=(ruby ruby-docs)
|
||||
pkgver=2.6.5
|
||||
pkgver=2.7.0
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
url='https://www.ruby-lang.org/en/'
|
||||
|
@ -16,8 +16,8 @@ makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
|
|||
options=(!emptydirs)
|
||||
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||
0001-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||
sha512sums=('e8ae3b5d4d23a93d0ef6057235ad0e573665a8b4b6544e1c70b4cce9c4d2fb9094e5c8fe8a9ab7b9996efe3ada603f9b4ef1fd08fb5a83253c1ae2b5e3f202db'
|
||||
'e832b64ee46721b4a8be4c44cc62a4ae3ca25e1a9fa9803e5001757d6ce11565bfa82d87182029b6d054f45bb556d4a1b515047edec8932c31dab4d0f3ad060c')
|
||||
sha512sums=('dd5690c631bf3a2b76cdc06902bcd76a89713a045e136debab9b8a81ff8c433bbb254aa09e4014ca1cf85a69ff4bcb13de11da5e40c224e7268be43ef2194af7'
|
||||
'ae1a9e00ab3bfb1bf29cda872ddf6d64dd6ec5745bd25f00e3692a1d769dd81bbce8921ed63e0f5776ec3e610655087b739fde26ede9649c6c2e095b27381926')
|
||||
|
||||
prepare() {
|
||||
cd ruby-${pkgver}
|
||||
|
|
Loading…
Reference in a new issue