community/gimp-nufraw: fix

This commit is contained in:
Kevin Mihelich 2022-02-28 22:35:57 +00:00
parent 15c3245167
commit 2a2be2edad
2 changed files with 18 additions and 5 deletions

View file

@ -1,7 +1,7 @@
# Maintainer: Christian Hesse <mail@eworm.de>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - add -fsigned-char to CXXFLAGS
# - patch to fix signed char declaration for ARM
pkgname=gimp-nufraw
_realver=0.43-3
@ -17,14 +17,17 @@ conflicts=('gimp-ufraw')
replaces=('gimp-ufraw')
optdepends=('gimp: to use the gimp import plugin for raw images')
source=("https://downloads.sourceforge.net/nufraw/nufraw-${_realver}.tar.gz"
nufraw-glib-2.70.patch)
nufraw-glib-2.70.patch
signed-char.patch)
sha256sums=('2c7dcc1590993ec267b3112562b2433010d6f94f6acc6506c76aa29cf8c6c32c'
'0e422f77b277f3c38b454426ee155d1004e47ced8d5d05942448584557c9ed07')
'0e422f77b277f3c38b454426ee155d1004e47ced8d5d05942448584557c9ed07'
'93b20b1b6634de7b56a6b50fe35f320dbf68e9dc7b530c5540a88637a14d3fa0')
prepare() {
cd "nufraw-${_realver}"
patch -p1 < ../nufraw-glib-2.70.patch # Fix build with glib 2.70
patch -p1 < ../signed-char.patch
autoreconf -fi
@ -35,8 +38,6 @@ prepare() {
build() {
cd "nufraw-${_realver}"
CXXFLAGS+=" -fsigned-char"
./configure \
--prefix=/usr \
--enable-extras \

View file

@ -0,0 +1,12 @@
diff -urN a/dcraw.cc b/dcraw.cc
--- a/dcraw.cc 2020-03-02 02:56:55.000000000 -0700
+++ b/dcraw.cc 2022-02-28 15:24:45.071540692 -0700
@@ -2297,7 +2297,7 @@
void CLASS kodak_radc_load_raw()
{
- static const char src[] = {
+ static const signed char src[] = {
1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,