extra/firefox to 86.0.1-1

This commit is contained in:
Kevin Mihelich 2021-03-11 19:13:28 +00:00
parent babbba5df3
commit 2a3913081c
2 changed files with 3 additions and 42 deletions

View file

@ -1,34 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Jeff Muizelaar <jmuizelaar@mozilla.com>
Date: Thu, 25 Feb 2021 13:18:47 +0000
Subject: [PATCH] Bug 1694670. Fix the OOB check in write_u32/u16. r=aosmond,
a=RyanVM
Differential Revision: https://phabricator.services.mozilla.com/D106362
---
gfx/qcms/src/iccread.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/gfx/qcms/src/iccread.rs b/gfx/qcms/src/iccread.rs
index 0113e17aff3e6..f1107d50a86b6 100644
--- a/gfx/qcms/src/iccread.rs
+++ b/gfx/qcms/src/iccread.rs
@@ -229,16 +229,16 @@ fn read_uInt16Number(mem: &mut MemSource, offset: usize) -> uInt16Number {
read_u16(mem, offset)
}
pub fn write_u32(mem: &mut [u8], offset: usize, value: u32) {
- if offset <= mem.len() - std::mem::size_of_val(&value) {
+ if offset > mem.len() - std::mem::size_of_val(&value) {
panic!("OOB");
}
let mem = mem.as_mut_ptr();
unsafe {
std::ptr::write_unaligned(mem.add(offset) as *mut u32, cpu_to_be32(value));
}
}
pub fn write_u16(mem: &mut [u8], offset: usize, value: u16) {
- if offset <= mem.len() - std::mem::size_of_val(&value) {
+ if offset > mem.len() - std::mem::size_of_val(&value) {
panic!("OOB");
}
let mem = mem.as_mut_ptr();

View file

@ -10,8 +10,8 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=86.0
pkgrel=2
pkgver=86.0.1
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -30,14 +30,12 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
arm.patch
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
0002-Bug-1694670.-Fix-the-OOB-check-in-write_u32-u16.-r-a.patch
$pkgname.desktop)
sha256sums=('c3ac474a2cf6a8e31a962f57c7357dbe67b5088b6aceea9980f25ce7a99b58dd'
sha256sums=('74f99c226ae6747f0170566f4f88be410866b0120214d2a593566cd1fff3d3df'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'ea8c317a50e84829c3b94ad73b5b9cfb8a08a73e406f8bd9bfb7730854611539'
'7ca4d5270c5bf4505ab867807bfff65b30cd1d0d8c50b76b406a3233ae3b5ad3'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -61,9 +59,6 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# https://bugs.archlinux.org/task/69821
patch -Np1 -i ../0002-Bug-1694670.-Fix-the-OOB-check-in-write_u32-u16.-r-a.patch
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key