From 90b08e8f740d3728d23740d701025fc5f9260f98 Mon Sep 17 00:00:00 2001
From: Daniel Wallace <danielwallace@gtmanfred.com>
Date: Fri, 8 Feb 2013 14:18:28 -0500
Subject: [PATCH] add compton-git

---
 aur/compton-git/PKGBUILD | 48 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
 create mode 100644 aur/compton-git/PKGBUILD

diff --git a/aur/compton-git/PKGBUILD b/aur/compton-git/PKGBUILD
new file mode 100644
index 000000000..1bd95f598
--- /dev/null
+++ b/aur/compton-git/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: OK100 <ok100@lavabit.com>
+# Previous Maintainer: Valère Monseur <valere dot monseur at ymail dot com>
+
+pkgname=compton-git
+pkgver=20121204
+pkgrel=1
+pkgdesc="X Compositor (a fork of xcompmgr-dana)"
+arch=(i686 x86_64)
+url="https://github.com/chjj/compton"
+license=('MIT')
+depends=('libx11' 'libxcomposite' 'libxdamage' 'libxfixes' 'libxext' 'libxrender' 'xproto' 'bash' 'xorg-xprop' 'xorg-xwininfo' 'pcre' 'libconfig' 'mesa' 'libxrandr')
+makedepends=('git' 'make' 'pkg-config' 'asciidoc')
+
+_gitroot="git://github.com/chjj/compton.git"
+_gitname="compton"
+
+build() {
+  msg "Connecting to GIT server...."
+
+  if [ -d $_gitname ] ; then
+    cd $_gitname && git pull origin
+    msg "The local files are updated."
+  else
+    git clone $_gitroot $_gitname
+  fi
+
+  msg "GIT checkout done or server timeout"
+  msg "Starting make..."
+
+  rm -rf "$srcdir/$_gitname-build"
+  git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+
+  cd "$srcdir/$_gitname-build"
+  make PREFIX=/usr
+  make docs
+}
+
+package() {
+  cd $_gitname-build
+
+  make PREFIX="$pkgdir/usr" install
+
+  # install license
+  install -D -m644 "LICENSE" "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+
+  # example conf
+  install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"
+}