mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/pacman to 5.0.1-2
This commit is contained in:
parent
6715bc603d
commit
2a9c7a049f
2 changed files with 39 additions and 3 deletions
32
core/pacman/0001-libmakepkg-fix-is_array-function.patch
Normal file
32
core/pacman/0001-libmakepkg-fix-is_array-function.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
From 2822a45fa91b430c99b4b8bd3531ee745ada1ab7 Mon Sep 17 00:00:00 2001
|
||||
From: Allan McRae <allan@archlinux.org>
|
||||
Date: Fri, 26 Feb 2016 15:01:11 +1000
|
||||
Subject: [PATCH] libmakepkg: fix is_array function
|
||||
|
||||
This happened to work for the majority of cases because the only calling
|
||||
function used a variable named "i" that was related to the variable being
|
||||
passed to the function.
|
||||
|
||||
Fixes FS#48340.
|
||||
|
||||
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||
---
|
||||
scripts/libmakepkg/util/util.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/libmakepkg/util/util.sh b/scripts/libmakepkg/util/util.sh
|
||||
index 675e75d..f9f1c20 100644
|
||||
--- a/scripts/libmakepkg/util/util.sh
|
||||
+++ b/scripts/libmakepkg/util/util.sh
|
||||
@@ -46,7 +46,7 @@ is_array() {
|
||||
local shellopts=$(shopt -p)
|
||||
shopt -s extglob
|
||||
|
||||
- if [[ $(declare -p "$i") == declare\ -*([[:alnum:]])a*([[:alnum:]])\ * ]]; then
|
||||
+ if [[ $(declare -p "$v") == declare\ -*([[:alnum:]])a*([[:alnum:]])\ * ]]; then
|
||||
ret=0
|
||||
fi
|
||||
|
||||
--
|
||||
2.7.1
|
||||
|
|
@ -10,8 +10,8 @@
|
|||
# - patch to sync filesystem after install/remove
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=5.0.0
|
||||
pkgrel=1
|
||||
pkgver=5.0.1
|
||||
pkgrel=2
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
|
@ -28,12 +28,14 @@ replaces=('pacman-contrib')
|
|||
backup=(etc/pacman.conf etc/makepkg.conf)
|
||||
options=('strip' 'debug')
|
||||
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
||||
0001-libmakepkg-fix-is_array-function.patch
|
||||
0001-Sychronize-filesystem.patch
|
||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
pacman.conf
|
||||
makepkg.conf)
|
||||
md5sums=('9ecf8a5b659c0e02232c945ab198e6e1'
|
||||
md5sums=('377a2664d6007d72d6d8a126add83bcf'
|
||||
'SKIP'
|
||||
'55732144f1048f714f1f93203e9b7728'
|
||||
'11869a104d0944cc86215098cf5a32bf'
|
||||
'd4692c3add0b0dab87036edad3f59626'
|
||||
'372fa63a5333ef22a0197d44b2a454ca'
|
||||
|
@ -43,6 +45,8 @@ validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD') # Allan McRae <allan@
|
|||
prepare() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
patch -p1 -i $srcdir/0001-libmakepkg-fix-is_array-function.patch
|
||||
|
||||
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
||||
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue