extra/chromium to 117.0.5938.92-2

This commit is contained in:
Kevin Mihelich 2023-09-23 16:15:54 +00:00
parent 56a482517c
commit 2af57b8fb7
2 changed files with 71 additions and 1 deletions

View file

@ -16,7 +16,7 @@ highmem=1
pkgname=chromium
pkgver=117.0.5938.92
pkgrel=1
pkgrel=2
_launcher_ver=8
_gcc_patchset=116-patchset-2
_manual_clone=0
@ -40,6 +40,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/stha09/chromium-patches/releases/download/chromium-$_gcc_patchset/chromium-$_gcc_patchset.tar.xz
add-memory-for-std-unique_ptr-in-third_party-ip.patch
roll-src-third_party-libavif-src-b33d9ebfc.676aded35.patch
free-the-X11-pixmap-in-the-NativePixmapEGLX11Bind.patch
REVERT-disable-autoupgrading-debug-info.patch
material-color-utilities-cmath.patch
use-oauth2-client-switches-as-default.patch
@ -51,6 +52,7 @@ sha256sums=('65ca491927902557cafc384c879b567c3728b06fc8ea0c46c45e2f0ce543342c'
'25ad7c1a5e0b7332f80ed15ccf07d7e871d8ffb4af64df7c8fef325a527859b0'
'7b9708f0dbfd697be7043d3cfe52da991185aa0ee29a3b8263506cd3ae4d41a9'
'30841fbe0785f8df584eeaa86584fe75f89da26e71df80cf536887557ddef0b6'
'ab1eb107ec1c915065dc59cf4832da27e17d60eb29038e2aec633daeb946cc6a'
'1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
'55e6097d347be40cffebf3ce13ba84ea92d940f60865f1bd7c9af1ef2a2ef8e1'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
@ -142,6 +144,7 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../add-memory-for-std-unique_ptr-in-third_party-ip.patch
patch -Np1 -i ../roll-src-third_party-libavif-src-b33d9ebfc.676aded35.patch
patch -Np1 -i ../free-the-X11-pixmap-in-the-NativePixmapEGLX11Bind.patch
# Revert addition of compiler flag that needs newer clang
patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch

View file

@ -0,0 +1,67 @@
From 42d57d016f5fb6d2a1a354743b9be911c1be87e8 Mon Sep 17 00:00:00 2001
From: Jianhui Dai <jianhui.j.dai@intel.com>
Date: Fri, 22 Sep 2023 21:30:04 +0000
Subject: [PATCH] [GL] Free the X11 pixmap in the NativePixmapEGLX11Binding
destructor
This CL frees the X11 pixmap in the NativePixmapEGLX11Binding destructor
to prevent a memory leak in the X server.
Bug: 1467689
Change-Id: Id4cba30825417db52176f9165db34d7234a05a05
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4886249
Reviewed-by: Ted (Chromium) Meyer <tmathmeyer@chromium.org>
Commit-Queue: Ted (Chromium) Meyer <tmathmeyer@chromium.org>
Reviewed-by: Maksim Sisov <msisov@igalia.com>
Cr-Commit-Position: refs/heads/main@{#1200486}
---
.../platform/x11/native_pixmap_egl_x11_binding.cc | 12 +++++++++---
.../platform/x11/native_pixmap_egl_x11_binding.h | 2 ++
2 files changed, 11 insertions(+), 3 deletions(-)
diff --git a/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.cc b/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.cc
index 46a2d3274b9..b46eb67b9de 100644
--- a/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.cc
+++ b/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.cc
@@ -147,9 +147,17 @@ NativePixmapEGLX11Binding::~NativePixmapEGLX11Binding() {
if (surface_) {
eglDestroySurface(display_, surface_);
}
+
+ if (pixmap_ != x11::Pixmap::None) {
+ auto* connection = x11::Connection::Get();
+ connection->FreePixmap({pixmap_});
+ }
}
bool NativePixmapEGLX11Binding::Initialize(x11::Pixmap pixmap) {
+ CHECK_NE(pixmap, x11::Pixmap::None);
+ pixmap_ = pixmap;
+
if (eglInitialize(display_, nullptr, nullptr) != EGL_TRUE) {
return false;
}
@@ -223,9 +231,7 @@ std::unique_ptr<NativePixmapGLBinding> NativePixmapEGLX11Binding::Create(
return nullptr;
}
- // TODO(https://crbug.com/1411749): if we early out below, should we call
- // FreePixmap()?
-
+ // Transfer the ownership of `pixmap` to `NativePixmapEGLX11Binding`.
if (!binding->Initialize(std::move(pixmap))) {
VLOG(1) << "Unable to initialize binding from pixmap";
return nullptr;
diff --git a/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.h b/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.h
index 013df3f776a..99b262b82ce 100644
--- a/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.h
+++ b/ui/ozone/platform/x11/native_pixmap_egl_x11_binding.h
@@ -47,6 +47,8 @@ class NativePixmapEGLX11Binding : public NativePixmapGLBinding {
EGLSurface surface_ = nullptr;
EGLDisplay display_;
gfx::BufferFormat format_;
+
+ x11::Pixmap pixmap_ = x11::Pixmap::None;
};
} // namespace ui