mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added community/tachyon
This commit is contained in:
parent
fe55a62d7d
commit
2b43b5b677
2 changed files with 97 additions and 0 deletions
53
community/tachyon/PKGBUILD
Normal file
53
community/tachyon/PKGBUILD
Normal file
|
@ -0,0 +1,53 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Rémy Oudompheng <remy@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - set ARM architectures to use linux-thr profile
|
||||
# - sed to remove -m32 from CFLAGS
|
||||
|
||||
pkgname=tachyon
|
||||
pkgver=0.98.9
|
||||
pkgrel=3
|
||||
pkgdesc="Multithreaded ray tracing software"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://jedi.ks.uiuc.edu/~johns/raytracer/"
|
||||
license=('BSD')
|
||||
depends=('libjpeg-turbo' 'libpng')
|
||||
makedepends=()
|
||||
source=("http://jedi.ks.uiuc.edu/~johns/raytracer/files/$pkgver/$pkgname-$pkgver.tar.gz" 'enable-jpeg-png.patch')
|
||||
md5sums=('eb39e10bb37bccc949b45b8fc28dabd7'
|
||||
'e0f0c2bd974d0beac509d6dd237ad77c')
|
||||
|
||||
case "$CARCH" in
|
||||
arm*) _target=linux-thr ;;
|
||||
"i686") _target=linux-thr ;;
|
||||
"x86_64") _target=linux-64-thr ;;
|
||||
esac
|
||||
|
||||
prepare(){
|
||||
cd $pkgname
|
||||
# enable JPEG and PNG support
|
||||
patch -p0 -i "$srcdir"/enable-jpeg-png.patch
|
||||
|
||||
# remove -m32 for ARM
|
||||
sed -i 's/-m32//g' unix/Make-arch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname/unix
|
||||
make $_target
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname/compile/$_target
|
||||
install -D -m 755 tachyon $pkgdir/usr/bin/tachyon
|
||||
install -D -m 644 libtachyon.a $pkgdir/usr/lib/libtachyon.a
|
||||
|
||||
cd $srcdir/$pkgname/scenes
|
||||
install -d "$pkgdir"/usr/share/tachyon/scenes/imaps
|
||||
install -m 644 README *.dat *.cam *.ac "$pkgdir"/usr/share/tachyon/scenes
|
||||
install -m 644 imaps/* "$pkgdir"/usr/share/tachyon/scenes/imaps
|
||||
|
||||
install -d "$pkgdir"/usr/share/licenses/tachyon
|
||||
install $srcdir/$pkgname/Copyright "$pkgdir"/usr/share/licenses/tachyon
|
||||
}
|
44
community/tachyon/enable-jpeg-png.patch
Normal file
44
community/tachyon/enable-jpeg-png.patch
Normal file
|
@ -0,0 +1,44 @@
|
|||
--- unix/Make-config.orig 2015-01-08 20:45:17.968890865 +0100
|
||||
+++ unix/Make-config 2015-01-08 20:46:16.223075085 +0100
|
||||
@@ -108,14 +108,14 @@
|
||||
# http://www.ijg.org/files/
|
||||
##########################################################################
|
||||
# Uncomment the following lines to disable JPEG support
|
||||
-USEJPEG=
|
||||
-JPEGINC=
|
||||
-JPEGLIB=
|
||||
+#USEJPEG=
|
||||
+#JPEGINC=
|
||||
+#JPEGLIB=
|
||||
|
||||
# Uncomment the following lines to enable JPEG support
|
||||
-#USEJPEG= -DUSEJPEG
|
||||
-#JPEGINC= -I/usr/local/include
|
||||
-#JPEGLIB= -L/usr/local/lib -ljpeg
|
||||
+USEJPEG= -DUSEJPEG
|
||||
+JPEGINC= -I/usr/include
|
||||
+JPEGLIB= -L/usr/lib -ljpeg
|
||||
|
||||
|
||||
##########################################################################
|
||||
@@ -128,14 +128,14 @@
|
||||
# http://www.libpng.org/
|
||||
##########################################################################
|
||||
# Uncomment the following lines to disable PNG support
|
||||
-USEPNG=
|
||||
-PNGINC=
|
||||
-PNGLIB=
|
||||
+#USEPNG=
|
||||
+#PNGINC=
|
||||
+#PNGLIB=
|
||||
|
||||
# Uncomment the following lines to enable PNG support
|
||||
-#USEPNG= -DUSEPNG
|
||||
-#PNGINC= -I/usr/local/include
|
||||
-#PNGLIB= -L/usr/local/lib -lpng -lz
|
||||
+USEPNG= -DUSEPNG
|
||||
+PNGINC= -I/usr/include
|
||||
+PNGLIB= -L/usr/lib -lpng -lz
|
||||
|
||||
|
||||
##########################################################################
|
Loading…
Reference in a new issue