mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/ghc to 8.2.1-1
This commit is contained in:
parent
a0d6450e0e
commit
2bc453924a
5 changed files with 84 additions and 120 deletions
|
@ -1,63 +0,0 @@
|
||||||
From 6576bf83cdf4eac05eb88a24aa934a736c91e3da Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ben Gamari <bgamari.foss@gmail.com>
|
|
||||||
Date: Thu, 1 Dec 2016 12:55:23 -0500
|
|
||||||
Subject: [PATCH] rts: Ensure we always give MADV_DONTNEED a chance in
|
|
||||||
osDecommitMemory
|
|
||||||
|
|
||||||
As described in #12865, newer Linux kernels support both MADV_FREE and
|
|
||||||
MADV_DONTNEED. Previously a runtime would fail to try MADV_DONTNEED if
|
|
||||||
MADV_FREE failed (e.g. since the kernel which the image is running on
|
|
||||||
doesn't support the latter). Now we try MADV_DONTNEED if MADV_FREE
|
|
||||||
failed to ensure that binaries compiled on a kernel supporting MADV_FREE
|
|
||||||
don't fail on decommit.
|
|
||||||
|
|
||||||
Test Plan: Validate
|
|
||||||
|
|
||||||
Reviewers: austin, erikd, simonmar
|
|
||||||
|
|
||||||
Reviewed By: simonmar
|
|
||||||
|
|
||||||
Subscribers: thomie
|
|
||||||
|
|
||||||
Differential Revision: https://phabricator.haskell.org/D2780
|
|
||||||
|
|
||||||
GHC Trac Issues: #12865
|
|
||||||
---
|
|
||||||
rts/posix/OSMem.c | 19 ++++++++++++++++---
|
|
||||||
1 file changed, 16 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/rts/posix/OSMem.c b/rts/posix/OSMem.c
|
|
||||||
index 5291745..beffeda 100644
|
|
||||||
--- a/rts/posix/OSMem.c
|
|
||||||
+++ b/rts/posix/OSMem.c
|
|
||||||
@@ -541,11 +541,24 @@ void osDecommitMemory(void *at, W_ size)
|
|
||||||
|
|
||||||
#ifdef MADV_FREE
|
|
||||||
// Try MADV_FREE first, FreeBSD has both and MADV_DONTNEED
|
|
||||||
- // just swaps memory out
|
|
||||||
+ // just swaps memory out. Linux >= 4.5 has both DONTNEED and FREE; either
|
|
||||||
+ // will work as they both allow the system to free anonymous pages.
|
|
||||||
+ // It is important that we try both methods as the kernel which we were
|
|
||||||
+ // built on may differ from the kernel we are now running on.
|
|
||||||
r = madvise(at, size, MADV_FREE);
|
|
||||||
-#else
|
|
||||||
- r = madvise(at, size, MADV_DONTNEED);
|
|
||||||
+ if(r < 0) {
|
|
||||||
+ if (errno == EINVAL) {
|
|
||||||
+ // Perhaps the system doesn't support MADV_FREE; fall-through and
|
|
||||||
+ // try MADV_DONTNEED.
|
|
||||||
+ } else {
|
|
||||||
+ sysErrorBelch("unable to decommit memory");
|
|
||||||
+ }
|
|
||||||
+ } else {
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
#endif
|
|
||||||
+
|
|
||||||
+ r = madvise(at, size, MADV_DONTNEED);
|
|
||||||
if(r < 0)
|
|
||||||
sysErrorBelch("unable to decommit memory");
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.9.1
|
|
||||||
|
|
|
@ -13,37 +13,33 @@ buildarch=4
|
||||||
# Libraries depend on versions specified by those hashes.
|
# Libraries depend on versions specified by those hashes.
|
||||||
# This implies that all libraries need to be rebuilt when ghc is rebuilt.
|
# This implies that all libraries need to be rebuilt when ghc is rebuilt.
|
||||||
|
|
||||||
# use the following command to print out packages that need to get rebuilt
|
shopt -s extglob
|
||||||
# grep -r ghc /var/abs/ | awk -F '/' '{ print $5; }' | sort -u
|
|
||||||
|
|
||||||
pkgbase=ghc
|
pkgbase=ghc
|
||||||
pkgname=(ghc ghc-static)
|
pkgname=(ghc-libs ghc ghc-static)
|
||||||
pkgver=8.0.2
|
pkgver=8.2.1
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
pkgdesc='The Glasgow Haskell Compiler'
|
pkgdesc='The Glasgow Haskell Compiler'
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://www.haskell.org/ghc/'
|
url='http://www.haskell.org/ghc/'
|
||||||
license=('custom')
|
license=('custom')
|
||||||
makedepends=('ghc-static' 'perl' 'libxslt' 'docbook-xsl' 'python-sphinx' 'haskell-hscolour'
|
makedepends=('ghc-static' 'perl' 'libxslt' 'docbook-xsl' 'python-sphinx' 'haskell-hscolour'
|
||||||
'texlive-bin' 'texlive-latexextra' 'ttf-dejavu')
|
'texlive-bin' 'texlive-latexextra' 'ttf-dejavu')
|
||||||
source=("https://downloads.haskell.org/~ghc/$pkgver/$pkgname-${pkgver}-src.tar.xz"
|
source=("https://downloads.haskell.org/~ghc/$pkgver/$pkgbase-${pkgver}-src.tar.xz"
|
||||||
ghc-rebuild-doc-index.hook ghc-register.hook ghc-unregister.hook MADV_FREE.patch)
|
ghc-rebuild-doc-index.hook ghc-register.hook ghc-unregister.hook)
|
||||||
noextract=("$pkgname-${pkgver}-src.tar.xz")
|
noextract=("$pkgbase-${pkgver}-src.tar.xz")
|
||||||
md5sums=('d0afb5ec441b14527a53d2445cc26ec3'
|
md5sums=('8942b6fb393984aeb8304d09bc326851'
|
||||||
'cc9aa11fddde15d8e5e15e99748874a1'
|
'4966d798a2868b289022aea8b655bf17'
|
||||||
'3b1949e77038b0276ebd5590ab89e1af'
|
'700bcd96afd059d668e50b51c19650d5'
|
||||||
'587efb0cb73a6b336cd9333fc5697de4'
|
'2355771881c91cb46e6249a81352aea2')
|
||||||
'3bf341c04e2e501a5ace07127de23e8f')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
# Need to extract this tarball with a UTF-8 locale instead of a chroot's "C"
|
# Need to extract this tarball with a UTF-8 locale instead of a chroot's "C"
|
||||||
# locale; otherwise we get:
|
# locale; otherwise we get:
|
||||||
# bsdtar: Pathname can't be converted from UTF-8 to current locale.
|
# bsdtar: Pathname can't be converted from UTF-8 to current locale.
|
||||||
LANG=en_US.UTF-8 bsdtar xf $pkgname-${pkgver}-src.tar.xz
|
LANG=en_US.UTF-8 bsdtar xf $pkgbase-${pkgver}-src.tar.xz
|
||||||
|
|
||||||
cd ghc-$pkgver
|
cd ghc-$pkgver
|
||||||
# FS#54823
|
|
||||||
patch -p1 -i ../MADV_FREE.patch
|
|
||||||
|
|
||||||
cp mk/build.mk{.sample,}
|
cp mk/build.mk{.sample,}
|
||||||
sed -i '1iBuildFlavour = perf' mk/build.mk
|
sed -i '1iBuildFlavour = perf' mk/build.mk
|
||||||
|
@ -61,48 +57,76 @@ build() {
|
||||||
}
|
}
|
||||||
|
|
||||||
package_ghc-static() {
|
package_ghc-static() {
|
||||||
pkgdesc='The Glasgow Haskell Compiler - Static Libraries'
|
pkgdesc='The Glasgow Haskell Compiler - Static Libraries and Documentation'
|
||||||
depends=('ghc')
|
depends=('ghc')
|
||||||
|
|
||||||
cd ghc-$pkgver
|
cd ghc-$pkgver
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" -j1 install
|
make DESTDIR="$pkgdir" install
|
||||||
|
|
||||||
mv "$pkgdir"/usr/lib/ghc-$pkgver/package.conf.d "$srcdir"/static-package.conf.d
|
mv "$pkgdir"/usr/lib/ghc-$pkgver/package.conf.d "$srcdir"/static-package.conf.d
|
||||||
find "$pkgdir"/usr/lib ! \( -name "*.a" -o -name "*.p_hi" \) -type f -delete
|
find "$pkgdir"/usr/lib ! \( -name "*.a" -o -name "*.p_hi" \) -type f -delete
|
||||||
find "$pkgdir"/usr/lib -type d -empty -delete
|
find "$pkgdir"/usr/lib -type d -empty -delete
|
||||||
mv "$srcdir"/static-package.conf.d "$pkgdir"/usr/lib/ghc-$pkgver/
|
mv "$srcdir"/static-package.conf.d "$pkgdir"/usr/lib/ghc-$pkgver/
|
||||||
rm -r "$pkgdir"/usr/share "$pkgdir"/usr/bin
|
rm -r "$pkgdir"/usr/bin "$pkgdir"/usr/share/man
|
||||||
|
|
||||||
|
install -Dm644 "$srcdir"/ghc-rebuild-doc-index.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-rebuild-doc-index.hook
|
||||||
}
|
}
|
||||||
|
|
||||||
package_ghc() {
|
package_ghc() {
|
||||||
pkgdesc='The Glasgow Haskell Compiler'
|
pkgdesc='The Glasgow Haskell Compiler'
|
||||||
|
provides=("haskell-ghc=$pkgver")
|
||||||
|
replaces=("haskell-ghc")
|
||||||
|
depends=('ghc-libs')
|
||||||
|
|
||||||
|
cd ghc-$pkgver
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
|
||||||
|
# Remove static libs
|
||||||
|
find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.p_hi" \) -delete
|
||||||
|
|
||||||
|
# ghc-pkg is in ghc-libs
|
||||||
|
rm "$pkgdir"/usr/lib/ghc-$pkgver/bin/ghc-pkg*
|
||||||
|
rm "$pkgdir"/usr/bin/ghc-pkg*
|
||||||
|
(cd "$pkgdir"/usr/lib/ghc-$pkgver; rm -r !(bin|ghc-$pkgver))
|
||||||
|
|
||||||
|
# docs moved to ghc-static
|
||||||
|
rm -r "$pkgdir"/usr/share/doc
|
||||||
|
|
||||||
|
install -Dm644 utils/completion/ghc.bash \
|
||||||
|
"$pkgdir/usr/share/bash-completion/completions/ghc"
|
||||||
|
}
|
||||||
|
|
||||||
|
package_ghc-libs() {
|
||||||
|
pkgdesc='The Glasgow Haskell Compiler - Dynamic Libraries'
|
||||||
install='ghc.install'
|
install='ghc.install'
|
||||||
depends=('gcc' 'gmp' 'libffi' 'perl' 'llvm37')
|
depends=('gcc' 'gmp' 'libffi' 'perl' 'llvm37')
|
||||||
provides=('haskell-array=0.5.1.1'
|
provides=('haskell-array=0.5.2.0'
|
||||||
'haskell-base=4.9.1.0'
|
'haskell-base=4.10.0.0'
|
||||||
'haskell-binary=0.8.3.0'
|
'haskell-binary=0.8.5.1'
|
||||||
'haskell-bytestring=0.10.8.1'
|
'haskell-bytestring=0.10.8.2'
|
||||||
'haskell-containers=0.5.7.1'
|
'haskell-containers=0.5.10.2'
|
||||||
'haskell-deepseq=1.4.2.0'
|
'haskell-deepseq=1.4.3.0'
|
||||||
'haskell-directory=1.3.0.0'
|
'haskell-directory=1.3.0.2'
|
||||||
'haskell-filepath=1.4.1.1'
|
'haskell-filepath=1.4.1.2'
|
||||||
'haskell-ghc-boot=8.0.2'
|
'haskell-ghc-boot=8.2.1'
|
||||||
'haskell-ghc-boot-th=8.0.2'
|
'haskell-ghc-boot-th=8.2.1'
|
||||||
'haskell-ghc-prim=0.5.0.0'
|
'haskell-ghc-compact=0.1.0.0'
|
||||||
'haskell-haskeline=0.7.3.0'
|
'haskell-ghci=8.2.1'
|
||||||
'haskell-hoopl=3.10.2.1'
|
'haskell-ghc-prim=0.5.1.0'
|
||||||
|
'haskell-haskeline=0.7.4.0'
|
||||||
|
'haskell-hoopl=3.10.2.2'
|
||||||
'haskell-hpc=0.6.0.3'
|
'haskell-hpc=0.6.0.3'
|
||||||
'haskell-integer-gmp=1.0.0.1'
|
'haskell-integer-gmp=1.0.1.0'
|
||||||
'haskell-pretty=1.1.3.3'
|
'haskell-pretty=1.1.3.3'
|
||||||
'haskell-process=1.4.3.0'
|
'haskell-process=1.6.1.0'
|
||||||
'haskell-template-haskell=2.11.1.0'
|
'haskell-template-haskell=2.12.0.0'
|
||||||
'haskell-terminfo=0.4.0.2'
|
'haskell-terminfo=0.4.1.0'
|
||||||
'haskell-time=1.6.0.1'
|
'haskell-time=1.8.0.2'
|
||||||
'haskell-transformers=0.5.2.0'
|
'haskell-transformers=0.5.2.0'
|
||||||
'haskell-unix=2.7.2.1'
|
'haskell-unix=2.7.2.2'
|
||||||
'haskell-xhtml=3000.2.1'
|
'haskell-xhtml=3000.2.2'
|
||||||
'haskell-cabal=1.24.2.0')
|
'haskell-cabal=2.0.0.2')
|
||||||
replaces=('haskell-array'
|
replaces=('haskell-array'
|
||||||
'haskell-base'
|
'haskell-base'
|
||||||
'haskell-binary'
|
'haskell-binary'
|
||||||
|
@ -113,6 +137,8 @@ package_ghc() {
|
||||||
'haskell-filepath'
|
'haskell-filepath'
|
||||||
'haskell-ghc-boot'
|
'haskell-ghc-boot'
|
||||||
'haskell-ghc-boot-th'
|
'haskell-ghc-boot-th'
|
||||||
|
'haskell-ghc-compact'
|
||||||
|
'haskell-ghci'
|
||||||
'haskell-ghc-prim'
|
'haskell-ghc-prim'
|
||||||
'haskell-haskeline'
|
'haskell-haskeline'
|
||||||
'haskell-hoopl'
|
'haskell-hoopl'
|
||||||
|
@ -127,25 +153,26 @@ package_ghc() {
|
||||||
'haskell-unix'
|
'haskell-unix'
|
||||||
'haskell-xhtml'
|
'haskell-xhtml'
|
||||||
'haskell-cabal')
|
'haskell-cabal')
|
||||||
provides+=("haskell-ghc=$pkgver")
|
|
||||||
replaces+=("haskell-ghc")
|
|
||||||
|
|
||||||
cd ghc-$pkgver
|
cd ghc-$pkgver
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" -j1 install
|
make DESTDIR="$pkgdir" install
|
||||||
|
|
||||||
for _hook in ghc-rebuild-doc-index.hook ghc-register.hook ghc-unregister.hook; do
|
|
||||||
install -D -m644 "$srcdir/$_hook" \
|
|
||||||
"$pkgdir/usr/share/libalpm/hooks/$_hook"
|
|
||||||
done
|
|
||||||
|
|
||||||
install -d -m755 "${pkgdir}"/usr/share/haskell/{register,unregister}
|
|
||||||
|
|
||||||
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
|
||||||
|
|
||||||
# Remove static libs
|
# Remove static libs
|
||||||
find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.p_hi" \) -delete
|
find "$pkgdir"/usr/lib \( -name "*.a" -o -name "*.p_hi" \) -delete
|
||||||
|
|
||||||
install -Dm644 utils/completion/ghc.bash \
|
# ghc library and other exes are in the ghc package
|
||||||
"$pkgdir/usr/share/bash-completion/completions/ghc"
|
rm -r "$pkgdir"/usr/lib/ghc-$pkgver/ghc-$pkgver
|
||||||
|
(cd "$pkgdir"/usr/lib/ghc-$pkgver/bin; rm !(ghc-pkg*))
|
||||||
|
(cd "$pkgdir"/usr/bin; rm !(ghc-pkg*))
|
||||||
|
|
||||||
|
# docs moved to ghc-static
|
||||||
|
rm -r "$pkgdir"/usr/share/{man,doc}
|
||||||
|
|
||||||
|
install -Dm644 "$srcdir"/ghc-register.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-register.hook
|
||||||
|
install -Dm644 "$srcdir"/ghc-unregister.hook "$pkgdir"/usr/share/libalpm/hooks/ghc-unregister.hook
|
||||||
|
|
||||||
|
install -dm755 "$pkgdir"/usr/share/haskell/{register,unregister}
|
||||||
|
|
||||||
|
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
|
||||||
}
|
}
|
||||||
|
|
|
@ -10,5 +10,5 @@ Target = !usr/share/doc/ghc/html/libraries/index.html
|
||||||
Description = Rebuilding Haskell doc index...
|
Description = Rebuilding Haskell doc index...
|
||||||
When = PostTransaction
|
When = PostTransaction
|
||||||
Exec = /bin/bash -c "cd /usr/share/doc/ghc/html/libraries && ./gen_contents_index"
|
Exec = /bin/bash -c "cd /usr/share/doc/ghc/html/libraries && ./gen_contents_index"
|
||||||
Depends = ghc
|
Depends = ghc-static
|
||||||
Depends = bash
|
Depends = bash
|
||||||
|
|
|
@ -8,5 +8,5 @@ Target = usr/share/haskell/register/*.sh
|
||||||
Description = Registering Haskell modules...
|
Description = Registering Haskell modules...
|
||||||
When = PostTransaction
|
When = PostTransaction
|
||||||
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" 2>&1 >/dev/null ; done'
|
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" 2>&1 >/dev/null ; done'
|
||||||
Depends = ghc
|
Depends = ghc-libs
|
||||||
NeedsTargets
|
NeedsTargets
|
||||||
|
|
|
@ -8,5 +8,5 @@ Target = usr/share/haskell/unregister/*.sh
|
||||||
Description = Unregistering Haskell modules...
|
Description = Unregistering Haskell modules...
|
||||||
When = PreTransaction
|
When = PreTransaction
|
||||||
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" 2>&1 >/dev/null ; done'
|
Exec = /bin/sh -c 'while read -r f; do /bin/sh "/$f" 2>&1 >/dev/null ; done'
|
||||||
Depends = ghc
|
Depends = ghc-libs
|
||||||
NeedsTargets
|
NeedsTargets
|
||||||
|
|
Loading…
Reference in a new issue