mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/gcc to 5.3.0-4
This commit is contained in:
parent
e69e159b60
commit
2c1341f21a
2 changed files with 64 additions and 5 deletions
|
@ -18,8 +18,8 @@ pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
|
||||||
pkgver=5.3.0
|
pkgver=5.3.0
|
||||||
_pkgver=5
|
_pkgver=5
|
||||||
_islver=0.15
|
_islver=0.15
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
#_snapshot=5-20150623
|
_snapshot=5-20160209
|
||||||
pkgdesc="The GNU Compiler Collection"
|
pkgdesc="The GNU Compiler Collection"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||||
|
@ -27,12 +27,14 @@ url="http://gcc.gnu.org"
|
||||||
makedepends=('binutils>=2.25' 'libmpc' 'doxygen')
|
makedepends=('binutils>=2.25' 'libmpc' 'doxygen')
|
||||||
checkdepends=('dejagnu' 'inetutils')
|
checkdepends=('dejagnu' 'inetutils')
|
||||||
options=('!emptydirs' '!distcc')
|
options=('!emptydirs' '!distcc')
|
||||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||||
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
|
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
|
||||||
|
Unlink-the-response-file.patch
|
||||||
0001-ARMv5-disable-LDRD-STRD.patch)
|
0001-ARMv5-disable-LDRD-STRD.patch)
|
||||||
md5sums=('c9616fd448f980259c31de613e575719'
|
md5sums=('499161c65b639aa5c12a14944582b7ec'
|
||||||
'8428efbbc6f6e2810ce5c1ba73ecf98c'
|
'8428efbbc6f6e2810ce5c1ba73ecf98c'
|
||||||
|
'1f4d4ef71004261376d26d5ba6a84499'
|
||||||
'924a9bcdd7852410667f04ce18c305d7')
|
'924a9bcdd7852410667f04ce18c305d7')
|
||||||
|
|
||||||
if [ -n "${_snapshot}" ]; then
|
if [ -n "${_snapshot}" ]; then
|
||||||
|
@ -60,6 +62,9 @@ prepare() {
|
||||||
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
|
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
|
||||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
||||||
|
|
||||||
|
# https://bugs.archlinux.org/task/47874 - commit f591a95d
|
||||||
|
patch -p1 -i $srcdir/Unlink-the-response-file.patch
|
||||||
|
|
||||||
# ALARM: Specify build host types, triplet patch
|
# ALARM: Specify build host types, triplet patch
|
||||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft"
|
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft"
|
||||||
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
|
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
|
||||||
|
|
54
core/gcc/Unlink-the-response-file.patch
Normal file
54
core/gcc/Unlink-the-response-file.patch
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
From f591a95d1532ac7791c146a8e55ba3a32b3e476f Mon Sep 17 00:00:00 2001
|
||||||
|
From: ebotcazou <ebotcazou@138bc75d-0d04-0410-961f-82ee72b054a4>
|
||||||
|
Date: Tue, 23 Jun 2015 20:48:07 +0000
|
||||||
|
Subject: [PATCH] * collect-utils.c (collect_wait): Unlink the
|
||||||
|
response file here instead of... (do_wait): ...here.
|
||||||
|
(utils_cleanup): ...and here.
|
||||||
|
|
||||||
|
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@224858 138bc75d-0d04-0410-961f-82ee72b054a4
|
||||||
|
---
|
||||||
|
gcc/ChangeLog | 7 +++++++
|
||||||
|
gcc/collect-utils.c | 14 ++++++--------
|
||||||
|
2 files changed, 13 insertions(+), 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/gcc/collect-utils.c b/gcc/collect-utils.c
|
||||||
|
index 6bbe9eb..517a075 100644
|
||||||
|
--- a/gcc/collect-utils.c
|
||||||
|
+++ b/gcc/collect-utils.c
|
||||||
|
@@ -68,6 +68,12 @@ collect_wait (const char *prog, struct pex_obj *pex)
|
||||||
|
fatal_error (input_location, "can't get program status: %m");
|
||||||
|
pex_free (pex);
|
||||||
|
|
||||||
|
+ if (response_file && !save_temps)
|
||||||
|
+ {
|
||||||
|
+ unlink (response_file);
|
||||||
|
+ response_file = NULL;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (status)
|
||||||
|
{
|
||||||
|
if (WIFSIGNALED (status))
|
||||||
|
@@ -90,12 +96,6 @@ do_wait (const char *prog, struct pex_obj *pex)
|
||||||
|
int ret = collect_wait (prog, pex);
|
||||||
|
if (ret != 0)
|
||||||
|
fatal_error (input_location, "%s returned %d exit status", prog, ret);
|
||||||
|
-
|
||||||
|
- if (response_file && !save_temps)
|
||||||
|
- {
|
||||||
|
- unlink (response_file);
|
||||||
|
- response_file = NULL;
|
||||||
|
- }
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
@@ -224,7 +224,5 @@ utils_cleanup (bool from_signal)
|
||||||
|
calls to maybe_unlink fails. */
|
||||||
|
cleanup_done = true;
|
||||||
|
|
||||||
|
- if (response_file)
|
||||||
|
- maybe_unlink (response_file);
|
||||||
|
tool_cleanup (from_signal);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.7.1
|
||||||
|
|
Loading…
Reference in a new issue