mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
alarm/kodi-rpi: remove unneeded patches
This commit is contained in:
parent
c0f4abfae8
commit
2c17d3666b
4 changed files with 11 additions and 85 deletions
|
@ -8,17 +8,17 @@ Subject: [PATCH 2/2] add dav1d patch to build system
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
||||
index a18b21c..fb7326f 100644
|
||||
index 9ce807c..de4287d 100644
|
||||
--- a/cmake/modules/FindFFMPEG.cmake
|
||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
||||
@@ -280,6 +280,7 @@ if(NOT FFMPEG_FOUND)
|
||||
@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
|
||||
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
|
||||
<SOURCE_DIR> &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch &&
|
||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-add-dav1d-patch-to-build-system.patch &&
|
||||
echo "########################################## patched ffmpeg ##############################"
|
||||
)
|
||||
|
||||
--
|
||||
2.36.0
|
||||
|
||||
--
|
||||
2.37.2
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
From 11071b94eff58eeaf69f2b81afe317b72cd22b54 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Sat, 7 May 2022 06:10:06 -0400
|
||||
Subject: [PATCH 1/2] mcpu=cortex-xxx application to ffmpeg
|
||||
|
||||
Get build system to patch ffmpeg source removing the -march= flag
|
||||
---
|
||||
cmake/modules/FindFFMPEG.cmake | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
||||
index 9ce807c..a18b21c 100644
|
||||
--- a/cmake/modules/FindFFMPEG.cmake
|
||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
||||
@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
|
||||
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
|
||||
<SOURCE_DIR> &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
||||
echo "########################################## patched ffmpeg ##############################"
|
||||
)
|
||||
|
||||
--
|
||||
2.36.0
|
||||
|
|
@ -54,9 +54,7 @@ source=(
|
|||
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
|
||||
kodi.config.txt
|
||||
build-fix-for-dav1d-1.0.0.patch
|
||||
use-mcpu-avoiding-march-and-mtune.patch
|
||||
0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
0002-add-dav1d-patch-to-build-system.patch
|
||||
0001-add-dav1d-patch-to-build-system.patch
|
||||
)
|
||||
backup=(boot/kodi.config.txt etc/conf.d/kodi-standalone)
|
||||
noextract=(
|
||||
|
@ -83,9 +81,7 @@ sha256sums=('ea57f7d2339bede8086082865afbb47c953f195dbfbaf54c43aeb4b46b8f9f2e'
|
|||
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
|
||||
'92d063169017bf9e1770d8a7cce77c0c55d197692d10820a7e4aecad9e58178c'
|
||||
'bcde6299a805430c3ca1f2807101edc7001e77b1934088db9057f74d9a9dd8f6'
|
||||
'c226f082349e6442b8920e1108005792c42b9461f7cec0e1576ae079520eed13'
|
||||
'afe90ded82e70af8e5680347a72edcbdc1dcae498083a90cc453dce00b665fce'
|
||||
'7f6e8e5c2084ab88d10ab2c55982212a8c6cbcf4101079be343763127f129a22')
|
||||
'6ddcfe192cac6edaa18b3adfd0f19c9c3be897c064ec88e0db27e30530d4313a')
|
||||
|
||||
prepare() {
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
|
@ -93,16 +89,11 @@ prepare() {
|
|||
|
||||
cd "xbmc-$_commit"
|
||||
|
||||
# put patches in source tree so kodi build system can pick it up
|
||||
cp ../use-mcpu-avoiding-march-and-mtune.patch \
|
||||
tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch
|
||||
|
||||
cp ../build-fix-for-dav1d-1.0.0.patch \
|
||||
tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch
|
||||
tools/depends/target/ffmpeg/0002-add-dav1d-patch-to-build-system.patch
|
||||
|
||||
# patch kodi build system to apply the patches we just copied over
|
||||
patch -p1 -i ../0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
patch -p1 -i ../0002-add-dav1d-patch-to-build-system.patch
|
||||
patch -p1 -i ../0001-add-dav1d-patch-to-build-system.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
From 2e2417894ac5d35bc3d93b86c18f4df299f4d933 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Sat, 12 Dec 2020 09:10:28 -0500
|
||||
Subject: [PATCH] use -mcpu= avoiding -march and -mtune for armv7h
|
||||
|
||||
From what I understand, when building on ARM, it's best to avoid the -march=
|
||||
flag and rather use -mcpu= flag due to differences in meaning on ARM vs x86[1].
|
||||
Additionally, this patch avoids thousands of warns like the following when
|
||||
building for armv7h:
|
||||
cc1: warning: switch '-mcpu=cortex-a72' conflicts with '-march=armv8-a'
|
||||
|
||||
This is due to the way ffmpeg's configure script defines -march=armv8-a when it
|
||||
encounters any cortex-a* passed to it.
|
||||
|
||||
for reference and to experiment:
|
||||
untar ffmpeg, run ./configure, then inspect the output of ffbuild/config.mak and adjust:
|
||||
kodi-build/build/ffmpeg/src/ffmpeg-build/ffmpeg-prefix/src/ffmpeg-build/ffbuild/config.mak
|
||||
|
||||
1. https://community.arm.com/developer/tools-software/tools/b/tools-software-ides-blog/posts/compiler-flags-across-architectures-march-mtune-and-mcpu
|
||||
|
||||
---
|
||||
configure | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 8569a60..0d3aafb 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -4948,7 +4948,7 @@ elif enabled arm; then
|
||||
|
||||
case $cpu in
|
||||
armv*)
|
||||
- cpuflags="-march=$cpu"
|
||||
+ cpuflags="-mcpu=cortex-a53"
|
||||
subarch=$(echo $cpu | sed 's/[^a-z0-9]//g')
|
||||
;;
|
||||
*)
|
||||
--
|
||||
2.29.2
|
||||
|
Loading…
Reference in a new issue