Core mods

This commit is contained in:
Mike Staszel 2009-10-10 09:15:23 -05:00
parent c3c9251057
commit 2c19ad2b19
21 changed files with 29 additions and 267 deletions

View file

@ -1,23 +0,0 @@
2009-01-29 Allan McRae <allan@archlinux.org>
* texinfo 4.13a-3
* Add gzip dependency for compress info pages
* Add findutils dependency for post_install script
2008-09-26 Eric Belanger <eric@archlinux.org>
* texinfo 4.13a-1
* Upstream update
* Moved to base group
* Added install scriptlet to handle info pages
2008-04-28 Eric Belanger <eric@archlinux.org>
* texinfo 4.12-2
* Added to base-devel group
2008-04-21 Eric Belanger <eric@archlinux.org>
* texinfo 4.12-1
* Upstream update
* Updated license

View file

@ -1,16 +1,16 @@
# Maintainer: Krzysztof "hiciu" Warzecha <kwarzecha7@gmail.com>
pkgname=texinfo
pkgver=4.13a
pkgrel=3
pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file"
arch=(arm)
arch=('arm')
url="http://www.gnu.org/software/texinfo/"
license=('GPL3')
groups=('base')
depends=('ncurses' 'findutils' 'gzip')
source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('71ba711519209b5fb583fed2b3d86fcb')
sha1sums=('a1533cf8e03ea4fa6c443b73f4c85e4da04dead0')
build() {
cd ${srcdir}/${pkgname}-4.13

View file

@ -1,21 +0,0 @@
infodir=/usr/share/info
filelist=(info.info.gz info-stnd.info.gz texinfo.gz texinfo-1.gz texinfo-2.gz texinfo-3.gz)
post_install() {
# Scan *all* info files on install
for file in $(find $infodir -type f ! -name dir); do
install-info $file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
pre_remove() {
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 35429 2009-04-13 15:58:46Z andyrtr $
# Maintainer: Philipp Scholl <pscholl@bawue.de>
# Maintainer: Andreas Radke <andyrtr@archlinux.org>

View file

@ -1,13 +1,13 @@
# $Id: PKGBUILD 48501 2009-08-02 16:29:45Z tpowa $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
# arm Maintainer: Philipp Scholl <pscholl@bawue.de>
pkgname=udev
pkgver=145
pkgrel=1
pkgdesc="The userspace dev tools (udev)"
arch=(arm)
arch=('arm')
url="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
license=('GPL')
groups=('base')
@ -20,12 +20,16 @@ backup=(etc/udev/udev.conf
etc/modprobe.d/framebuffer_blacklist.conf)
conflicts=('pcmcia-cs' 'hotplug')
replaces=('devfsd')
# older initscripts versions required start_udev
conflicts=('initscripts<2009.07')
options=(!makeflags !libtool)
source=(http://www.kernel.org/pub/linux/utils/kernel/hotplug/$pkgname-$pkgver.tar.bz2
81-arch.rules load-modules.sh resolve-modalias.c cdsymlinks.sh root-link.sh
arch-udev-rules.patch ignore-remove.sh)
81-arch.rules
load-modules.sh
resolve-modalias.c
cdsymlinks.sh
root-link.sh
arch-udev-rules.patch
ignore-remove.sh)
md5sums=('b3d3b5f88c7b81e7615700a04db685e1'
'cc6406e8b67b2b8711942098a66cde6b'
'f4951f61438d69894b728212dac7318b'

View file

@ -1,33 +0,0 @@
From: Martin Pitt <martin.pitt@ubuntu.com>
Date: Fri, 4 Sep 2009 15:12:28 +0000 (+0200)
Subject: make raw USB printer devices accessible for lp
X-Git-Url: http://git.kernel.org/?p=linux%2Fhotplug%2Fudev.git;a=commitdiff_plain;h=f61e72d8973cf9d889a4f1233150870085c0b3e1
make raw USB printer devices accessible for lp
Starting from version 1.4, cups now uses libusb and printer USB devices instead
of the usblp generated /dev/usb/lpX ones. In order to not require the cups USB
backend to run as root now, change raw USB printer devices to be root:lp 0660,
similar to usblpX devices.
This might also enable the hplip backend to not run as root, since this has
always used raw device nodes.
https://launchpad.net/bugs/420015
---
diff --git a/rules/rules.d/50-udev-default.rules b/rules/rules.d/50-udev-default.rules
index 2507420..4e9a737 100644
--- a/rules/rules.d/50-udev-default.rules
+++ b/rules/rules.d/50-udev-default.rules
@@ -60,6 +60,10 @@ SUBSYSTEM=="ppdev", GROUP="lp"
SUBSYSTEM=="usb", KERNEL=="lp*", NAME="usb/%k", SYMLINK+="usb%k", GROUP="lp"
KERNEL=="lp[0-9]*", GROUP="lp"
KERNEL=="irlpt[0-9]*", GROUP="lp"
+# hplip and cups 1.4+ use raw USB devices, so permissions should be similar to
+# the ones from the old usblp kernel module
+SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
+SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}==":0701*:", GROUP="lp", MODE="660"
# block
SUBSYSTEM=="block", GROUP="disk"

View file

@ -1,12 +1,12 @@
# $Id: PKGBUILD 46453 2009-07-18 12:36:22Z allan $
# Maintainer: Judd Vinet <jvinet@zeroflux.org>
# Contributor: Curtis Campbell <curtisjamescampbell@hotmail.com>
# arm Maintainer: Philipp Scholl <pscholl@bawue.de>
pkgname=usbutils
pkgver=0.84
pkgrel=1
pkgdesc="USB Device Utilities"
arch=(arm)
arch=('arm')
license=('GPL')
groups=('base')
makedepends=('wget')

View file

@ -1,11 +1,12 @@
# Maintainer: Philipp Scholl <pscholl@bawue.de>
pkgname=util-linux-ng
pkgver=2.14.2
_loop_date=20090214
pkgrel=1
pkgdesc="Miscellaneous system utilities for Linux"
url="http://userweb.kernel.org/~kzak/util-linux-ng/"
arch=(arm)
arch=('arm')
groups=('base')
depends=('bash' 'ncurses>=5.7' 'zlib' 'e2fsprogs')
replaces=('linux32' 'util-linux')
@ -13,7 +14,7 @@ conflicts=('linux32' 'util-linux')
provides=('linux32' 'util-linux')
license=('GPL2')
source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.14/${pkgname}-${pkgver}.tar.bz2
http://loop-aes.sourceforge.net/updates/${pkgname}-${pkgver}-${_loop_date}.diff.bz2)
http://loop-aes.sourceforge.net/updates/${pkgname}-${pkgver}-${_loop_date}.diff.bz2)
md5sums=('b9d0053a22cfcbf0b9c0aa6d6eccfbc8'
'72c5b3e961efc1bda2750dbad019e414')
@ -31,4 +32,3 @@ build() {
# remove files
rm -f ${pkgdir}/bin/kill
}

View file

@ -5,7 +5,7 @@ _pkgname=nvi
pkgver=1.81.6
pkgrel=3
pkgdesc='A reimplementation of the ex/vi text editors with unicode support.'
arch=(arm)
arch=('arm')
url='http://www.kotnet.org/~skimo/nvi/'
license=('custom:nvi')
conflicts=('nvi-unicode')

View file

@ -1,30 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 27support_C_locale.dpatch by <hesso@pool.math.tu-berlin.de>
##
## DP: Allow users to edit 8-bit files even under LC_CTYPE=C.
@DPATCH@
--- nvi-1.81.6.orig/common/conv.c 2007-11-18 17:41:42.000000000 +0100
+++ nvi-1.81.6/common/conv.c 2009-03-09 16:45:37.812022582 +0100
@@ -322,11 +322,16 @@
else {
setlocale(LC_ALL, "");
#ifdef USE_WIDECHAR
- sp->conv.sys2int = cs_char2int;
- sp->conv.int2sys = cs_int2char;
- sp->conv.file2int = fe_char2int;
- sp->conv.int2file = fe_int2char;
- sp->conv.input2int = ie_char2int;
+ if (!strcmp(LANGCODESET, "ANSI_X3.4-1968")) {
+ sp->conv.file2int = sp->conv.input2int = sp->conv.sys2int = raw2int;
+ sp->conv.int2sys = sp->conv.int2file = int2raw;
+ } else {
+ sp->conv.sys2int = cs_char2int;
+ sp->conv.int2sys = cs_int2char;
+ sp->conv.file2int = fe_char2int;
+ sp->conv.int2file = fe_int2char;
+ sp->conv.input2int = ie_char2int;
+ }
#endif
#ifdef USE_ICONV
o_set(sp, O_FILEENCODING, OS_STRDUP, nl_langinfo(CODESET), 0);

View file

@ -1,27 +0,0 @@
diff --git a/cl/cl_main.c b/cl/cl_main.c
index 0ecbe44..87feb28 100644
--- a/cl/cl_main.c
+++ b/cl/cl_main.c
@@ -57,6 +57,9 @@ main(int argc, char **argv)
int rval;
char **p_av, **t_av, *ttype;
+ /* Hack for db-4.7. */
+ unsetenv("LANG");
+ unsetenv("LC_ALL");
/* If loaded at 0 and jumping through a NULL pointer, stop. */
if (reenter++)
abort();
diff --git a/common/db.h b/common/db.h
index fd1dc64..00a7ce7 100644
--- a/common/db.h
+++ b/common/db.h
@@ -18,7 +18,7 @@
#if DB_VERSION_MAJOR >= 4 && DB_VERSION_MINOR >= 1
#define db_open(db,file,type,flags,mode) \
- (db)->open(db, NULL, file, NULL, type, flags, mode)
+ (db)->open(db, NULL, file, NULL, type, flags | DB_CREATE, mode)
#else
#define db_open(db,file,type,flags,mode) \
(db)->open(db, file, NULL, type, flags, mode)

View file

@ -1,67 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 13widechar_horrors.dpatch by <hesso@pool.math.tu-berlin.de>
##
## DP: This patch tries to cope with the fact that widechar support
## DP: in nvi is at best rudimentary.
## DP: Hunk 1)
## DP: * Due to "ch = *t", this code is not wide-char aware, so
## DP: cast the value to a proper type so the KEY_ macros make
## DP: the right choice.
## DP: Hunk 2)
## DP: * Printing of the in-/decreased number back into the screen
## DP: buffer is not widechar-aware, either. Add a dirty fix.
## DP: Cf. #497349.
@DPATCH@
--- nvi-1.81.6.orig/vi/vs_msg.c 2007-11-18 17:41:42.000000000 +0100
+++ nvi-1.81.6/vi/vs_msg.c 2009-03-01 14:51:08.211414132 +0100
@@ -472,10 +472,10 @@
*/
if (ch == '\t')
ch = ' ';
- chlen = KEY_LEN(sp, ch);
+ chlen = KEY_LEN(sp, (unsigned char)ch);
if (cbp + chlen >= ecbp)
FLUSH;
- for (kp = KEY_NAME(sp, ch); chlen--;)
+ for (kp = KEY_NAME(sp, (unsigned char)ch); chlen--;)
*cbp++ = *kp++;
}
if (cbp > cbuf)
--- nvi-1.81.6.orig/vi/v_increment.c 2007-11-18 17:41:42.000000000 +0100
+++ nvi-1.81.6/vi/v_increment.c 2009-03-01 15:12:50.950415874 +0100
@@ -57,7 +57,7 @@
long change, ltmp, lval;
size_t beg, blen, end, len, nlen, wlen;
int base, isempty, rval;
- char *ntype, nbuf[100];
+ char *ntype, nbuf[100 * sizeof(CHAR_T)];
CHAR_T *bp, *p, *t;
/* Validate the operator. */
@@ -202,7 +202,7 @@
/* If we cross 0, signed numbers lose their sign. */
if (lval == 0 && ntype == fmt[SDEC])
ntype = fmt[DEC];
- nlen = snprintf(nbuf, sizeof(nbuf), ntype, lval);
+ nlen = snprintf(nbuf, sizeof(nbuf)/sizeof(CHAR_T), ntype, lval);
} else {
if ((nret = nget_uslong(sp, &ulval, t, NULL, base)) != NUM_OK)
goto err;
@@ -224,7 +224,15 @@
if (base == 16)
wlen -= 2;
- nlen = snprintf(nbuf, sizeof(nbuf), ntype, wlen, ulval);
+ nlen = snprintf(nbuf, sizeof(nbuf)/sizeof(CHAR_T), ntype, wlen, ulval);
+ }
+
+ /* Inflate the printed char buffer to CHAR_T elements if necessary */
+ if (sizeof(CHAR_T) > sizeof(char)) {
+ int nlen_inflate;
+ for (nlen_inflate = nlen; nlen_inflate >= 0; nlen_inflate--) {
+ ((CHAR_T *)nbuf)[nlen_inflate] = nbuf[nlen_inflate];
+ }
}
/* Build the new line. */

View file

@ -1,5 +1,5 @@
# $Id: PKGBUILD 21431 2008-12-13 09:15:06Z thomas $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgname=vpnc
pkgver=0.5.3
pkgrel=1
@ -7,9 +7,10 @@ pkgdesc="VPN client for cisco3000 VPN Concentrators"
url="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
license=('GPL')
depends=('libgcrypt' 'openssl' 'iproute')
arch=('i686' 'x86_64')
arch=('arm')
source=(http://www.unix-ag.uni-kl.de/~massar/vpnc/$pkgname-$pkgver.tar.gz
vpnc.conf vpnc.rc)
vpnc.conf
vpnc.rc)
backup=(etc/vpnc/default.conf)
md5sums=('4378f9551d5b077e1770bbe09995afb3'
'a3f4e0cc682f437e310a1c86ae198e45'

View file

@ -4,7 +4,7 @@ pkgname=wget
pkgver=1.11.4
pkgrel=2
pkgdesc="A network utility to retrieve files from the Web"
arch=(arm)
arch=('arm')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
groups=('base')

View file

@ -1,20 +0,0 @@
infodir=/usr/share/info
filelist=(wget.info)
post_install() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
post_install $1
}
pre_remove() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}

View file

@ -18,4 +18,3 @@ build() {
make || return 1
make DESTDIR=$startdir/pkg install
}

View file

@ -1,20 +0,0 @@
infodir=/usr/share/info
filelist=(which.info)
post_install() {
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
post_install $1
}
pre_remove() {
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}
# vim:set ts=2 sw=2 et:

View file

@ -5,7 +5,7 @@ pkgver=0.6.9
#_madwifi_ver=0.9.4
pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
arch=(arm)
arch=('arm')
depends=('openssl' 'dbus-core>=1.2.4' 'readline' 'libnl')
optdepends=('wpa_supplicant_gui: wpa_gui program')
license=('GPL')

View file

@ -1,10 +1,10 @@
# $Id: PKGBUILD 48339 2009-08-01 14:41:14Z jgc $
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgname=xfsprogs
pkgver=3.0.1
pkgrel=2
pkgdesc="XFS filesystem utilities"
arch=(i686 x86_64)
arch=('arm')
license=('LGPL')
url="http://oss.sgi.com/projects/xfs/"
groups=('base')

View file

@ -4,7 +4,7 @@ pkgname=xinetd
pkgver=2.3.14
pkgrel=5
pkgdesc="xinetd is a secure replacement for inetd"
arch=(arm)
arch=('arm')
url="http://www.xinetd.org/"
license=('custom')
depends=('tcp_wrappers')
@ -13,9 +13,9 @@ backup=('etc/xinetd.conf' 'etc/xinetd.d/servers' 'etc/xinetd.d/services')
source=(http://www.xinetd.org/xinetd-$pkgver.tar.gz xinetd.conf xinetd \
servers services)
md5sums=('567382d7972613090215c6c54f9b82d9'
'f109f699a07bc8cfb5791060f5e87f9e'
'f109f699a07bc8cfb5791060f5e87f9e'
'ea37a2794f202e6b953d9b6956dad16a'
'21f47b4aa20921cfaddddd9f9a407f81'
'21f47b4aa20921cfaddddd9f9a407f81'
'9fa2061dc7dd738c8424251deb86f81e')
build() {

View file

@ -4,7 +4,7 @@ pkgname=zlib
pkgver=1.2.3.3
pkgrel=2
pkgdesc="A compression/decompression Library"
arch=(arm)
arch=('arm')
license=('custom:zlib')
url="http://www.zlib.net/"
groups=('base')