core/linux-armv7 to 3.19.0-1

This commit is contained in:
Kevin Mihelich 2015-02-12 00:24:56 +00:00
parent 2d6413de48
commit 2c1edc8172
8 changed files with 255 additions and 243 deletions

View file

@ -1,7 +1,7 @@
From 771ae3d1b217bc1ba0d749be1f067b5a49384a1b Mon Sep 17 00:00:00 2001
From ea11cc13a722f1fa6ec494be4de346cb15a06308 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/6] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/5] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.

View file

@ -1,7 +1,7 @@
From abdf77b0eed2ce6dcdd3afc76cdfbceb2493e662 Mon Sep 17 00:00:00 2001
From 1aa5fd13b027f5b97581593d1d9b1215d6b28162 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/6] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/5] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC

View file

@ -1,7 +1,7 @@
From 4f0e1c29c503ed3c9c25eb16d0e11d169e99374c Mon Sep 17 00:00:00 2001
From 0624580ab2aba0c2a57d6c6b06ec90ec95c748f5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/6] SMILE Plug device tree file
Subject: [PATCH 3/5] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -9,28 +9,28 @@ dts with the LED definitions.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/armada-370-smileplug.dts | 167 +++++++++++++++++++++++++++++
2 files changed, 168 insertions(+)
arch/arm/boot/dts/armada-370-smileplug.dts | 173 +++++++++++++++++++++++++++++
2 files changed, 174 insertions(+)
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 38c89ca..80651e3 100644
index 91bd5bd..22618d7 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -493,6 +493,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
@@ -527,6 +527,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-mirabox.dtb \
+ armada-370-smileplug.dtb \
armada-370-netgear-rn102.dtb \
armada-370-netgear-rn104.dtb \
armada-370-rd.dtb
armada-370-rd.dtb \
diff --git a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
new file mode 100644
index 0000000..6b30e82
index 0000000..0a01264
--- /dev/null
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts
@@ -0,0 +1,167 @@
@@ -0,0 +1,173 @@
+/*
+ * Device Tree file for Marvell SMILE Plug
+ *
@ -126,6 +126,8 @@ index 0000000..6b30e82
+ };
+
+ mdio {
+ pinctrl-0 = <&mdio_pins>;
+ pinctrl-names = "default";
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ };
@ -135,11 +137,15 @@ index 0000000..6b30e82
+ };
+ };
+ ethernet@70000 {
+ pinctrl-0 = <&ge0_rgmii_pins>;
+ pinctrl-names = "default";
+ status = "okay";
+ phy = <&phy0>;
+ phy-mode = "rgmii-id";
+ };
+ ethernet@74000 {
+ pinctrl-0 = <&ge1_rgmii_pins>;
+ pinctrl-names = "default";
+ status = "okay";
+ phy = <&phy1>;
+ phy-mode = "rgmii-id";

View file

@ -1,7 +1,7 @@
From 58868972118abc6766471cc20ddc431267e8ded4 Mon Sep 17 00:00:00 2001
From 0dfc0dfe1bf869b09d2a0bb3665bdf221e960f2d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/6] fix mvsdio eMMC timing
Subject: [PATCH 4/5] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 6b4c5ad..9f50234 100644
index 4f8618f..ab95bb7 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -97,7 +97,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
@ -24,7 +24,7 @@ index 6b4c5ad..9f50234 100644
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
@@ -614,6 +614,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
@@ -619,6 +619,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
if (m > MVSD_BASE_DIV_MAX)
m = MVSD_BASE_DIV_MAX;

View file

@ -1,57 +0,0 @@
From 2bfc92e7ef0bc8b5acb8f5caf83984ba4ec62d6a Mon Sep 17 00:00:00 2001
From: Andrew Lunn <andrew@lunn.ch>
Date: Wed, 12 Nov 2014 23:10:08 +0100
Subject: [PATCH 5/6] mmc: mvsdio: Work around broken TX DMA
In order to use the mvsdio driver for sdio, it has been necessary to
use a module parameter to disable DMA so to force PIO is used. It is
then possible to use wireless LAN devices like mwifiex found on
topkick and mirabox. However, accessing an MMC SD card does work with
DMA.
Investigation has shown that MMC block device accesses are always
aligned to 64 byte boundaries, where as transfers from mwifiex are
rarely more than word aligned. It has also been determined that card
to host transfers work with DMA for SDIO devices, but host to card
transfers with DMA have problems.
This patch extends the current checks for buffers which are not word
aligned or multiple of words. All host to card transfers which are not
64 byte aligned are now also performed via PIO. This should not affect
the performance of SD cards, but allow sdio devices to work out of the
box, and they are likely to be more efficient since DMA will be used
for card to host transfers.
Tested on mirabox for wifi via mwifiex
Tested on 370 RD for file systems on an SD card.
Signed-off-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
---
drivers/mmc/host/mvsdio.c | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 9f50234..ab95bb7 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -111,10 +111,15 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
mvsd_write(MVSD_BLK_COUNT, data->blocks);
mvsd_write(MVSD_BLK_SIZE, data->blksz);
- if (nodma || (data->blksz | data->sg->offset) & 3) {
+ if (nodma || (data->blksz | data->sg->offset) & 3 ||
+ ((!(data->flags & MMC_DATA_READ) && data->sg->offset & 0x3f))) {
/*
* We cannot do DMA on a buffer which offset or size
* is not aligned on a 4-byte boundary.
+ *
+ * It also appears the host to card DMA can corrupt
+ * data when the buffer is not aligned on a 64 byte
+ * boundary.
*/
host->pio_size = data->blocks * data->blksz;
host->pio_ptr = sg_virt(data->sg);
--
2.2.2

View file

@ -1,14 +1,14 @@
From 845153f87f2b984be0d793087334813ff77625bf Mon Sep 17 00:00:00 2001
From 5adf2285dd2774c763be4663e01238ddf4654da9 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 6/6] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/5] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index d07bf4c..5ae60ab 100644
index 26423ad..e29a323 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -59,6 +59,7 @@

View file

@ -4,46 +4,43 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-3.18
_srcname=linux-3.19
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=3.18.5
pkgver=3.19.0
pkgrel=1
rcnrel=armv7-x2
rcnrel=armv7-x3
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}.1+" # 3.18.1+
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
'0004-fix-mvsdio-eMMC-timing.patch'
'0005-mmc-mvsdio-Work-around-broken-TX-DMA.patch'
'0006-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'config')
md5sums=('9e854df51ca3fef8bfe566dbd7b89241'
'e8563b2feaa6c33d20d23ac7add9d385'
'ce78a6ce1c1b75c423d942ee71df0f7f'
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
'7026d1bb4abcbd3b2598e6f068a21a4e'
'SKIP'
'877449857f711e8f880fb023a9285641'
'201c4c6ba7d459c4617c7bd30ea2c5b4'
'65cddba7c44de41e59c68ccb13f93cbc'
'e2ea54e5ab30266a15beba5222792a18'
'246bd40b4b57fd490465e70f6ea711b9'
'8a37d76eee241f62f99415a7e14b5c2f'
'7edd5c951ff921a77e5c5e120044ee50')
'f08e4d6f28ef4bdba33ddccecaa3d547'
'2e5ce0eab008104e2e72fd41207725c6'
'7adbffa76463850fefd5cf12f63c86e9'
'3e51a3538a08e8f87dcc7cea1cc25b68'
'52db768a824523895d8ff8b41403283a'
'ae3dc19260a86e04658a5b6c2a71d76a')
prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# RCN patch
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
@ -53,8 +50,7 @@ prepare() {
git apply ../0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
git apply ../0003-SMILE-Plug-device-tree-file.patch
git apply ../0004-fix-mvsdio-eMMC-timing.patch
git apply ../0005-mmc-mvsdio-Work-around-broken-TX-DMA.patch
git apply ../0006-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
@ -62,10 +58,10 @@ prepare() {
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/linux
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" ./include/uapi/linux
patch -p1 -i ../aufs3-standalone/aufs3-kbuild.patch
patch -p1 -i ../aufs3-standalone/aufs3-base.patch
patch -p1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -p1 -i ../aufs3-standalone/aufs3-standalone.patch
git apply ../aufs3-standalone/aufs3-kbuild.patch
git apply ../aufs3-standalone/aufs3-base.patch
git apply ../aufs3-standalone/aufs3-mmap.patch
git apply ../aufs3-standalone/aufs3-standalone.patch
cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff