mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/grpc to 1.36.4-2
This commit is contained in:
parent
721ef79a86
commit
2c5525e1af
3 changed files with 28 additions and 58 deletions
|
@ -10,7 +10,7 @@ pkgname=('grpc' 'python-grpcio' 'php-grpc' 'php7-grpc' 'grpc-cli')
|
||||||
pkgver=1.36.4
|
pkgver=1.36.4
|
||||||
_gtestver=c9ccac7cb7345901884aabf5d1a786cfa6e2f397
|
_gtestver=c9ccac7cb7345901884aabf5d1a786cfa6e2f397
|
||||||
_abseilcppver=20200923.2
|
_abseilcppver=20200923.2
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="High performance, open source, general RPC framework that puts mobile and HTTP/2 first."
|
pkgdesc="High performance, open source, general RPC framework that puts mobile and HTTP/2 first."
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://grpc.io'
|
url='https://grpc.io'
|
||||||
|
@ -20,15 +20,20 @@ makedepends=('re2' 're2c' 'protobuf' 'php' 'php7' 'c-ares' 'openssl' 'chrpath' '
|
||||||
source=("https://github.com/grpc/grpc/archive/v$pkgver/$pkgbase-$pkgver.tar.gz"
|
source=("https://github.com/grpc/grpc/archive/v$pkgver/$pkgbase-$pkgver.tar.gz"
|
||||||
"https://github.com/google/googletest/archive/$_gtestver/googletest-$_gtestver.tar.gz"
|
"https://github.com/google/googletest/archive/$_gtestver/googletest-$_gtestver.tar.gz"
|
||||||
"https://github.com/abseil/abseil-cpp/archive/$_abseilcppver/abseil-cpp-$_abseilcppver.tar.gz"
|
"https://github.com/abseil/abseil-cpp/archive/$_abseilcppver/abseil-cpp-$_abseilcppver.tar.gz"
|
||||||
|
parse_json-fix-status-error.patch
|
||||||
"atomic.patch")
|
"atomic.patch")
|
||||||
sha256sums=('8eb9d86649c4d4a7df790226df28f081b97a62bf12c5c5fe9b5d31a29cd6541a'
|
sha256sums=('8eb9d86649c4d4a7df790226df28f081b97a62bf12c5c5fe9b5d31a29cd6541a'
|
||||||
'443d383db648ebb8e391382c0ab63263b7091d03197f304390baac10f178a468'
|
'443d383db648ebb8e391382c0ab63263b7091d03197f304390baac10f178a468'
|
||||||
'bf3f13b13a0095d926b25640e060f7e13881bd8a792705dd9e161f3c2b9aa976'
|
'bf3f13b13a0095d926b25640e060f7e13881bd8a792705dd9e161f3c2b9aa976'
|
||||||
|
'6cb2101c74e0817a8037f7d5e0f0e251e5c6e87de41e286e0c930f50fe6485af'
|
||||||
'2f1285c8874cad70a7e1800f80b1673e8a1b7e2ff11f1f3e198063988cc5ab06')
|
'2f1285c8874cad70a7e1800f80b1673e8a1b7e2ff11f1f3e198063988cc5ab06')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$srcdir/$pkgbase-$pkgver"
|
cd "$srcdir/$pkgbase-$pkgver"
|
||||||
|
|
||||||
|
# https://github.com/grpc/grpc/pull/25731
|
||||||
|
patch -Np1 -i ../parse_json-fix-status-error.patch
|
||||||
|
|
||||||
ln -sf "$srcdir/googletest-$_gtestver/"{googlemock,googletest} \
|
ln -sf "$srcdir/googletest-$_gtestver/"{googlemock,googletest} \
|
||||||
third_party/googletest
|
third_party/googletest
|
||||||
|
|
||||||
|
|
|
@ -1,57 +0,0 @@
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index ef11396..dd10886 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -44,6 +44,7 @@ set(gRPC_INSTALL_CMAKEDIR "lib/cmake/${PACKAGE_NAME}" CACHE STRING "Installation
|
|
||||||
set(gRPC_INSTALL_SHAREDIR "share/grpc" CACHE STRING "Installation directory for root certificates")
|
|
||||||
|
|
||||||
# Options
|
|
||||||
+option(gRPC_BUILD_CLI "Build cli" ON)
|
|
||||||
option(gRPC_BUILD_TESTS "Build tests" OFF)
|
|
||||||
option(gRPC_BUILD_CODEGEN "Build codegen" ON)
|
|
||||||
option(gRPC_BUILD_CSHARP_EXT "Build C# extensions" ON)
|
|
||||||
@@ -84,7 +85,7 @@ set_property(CACHE gRPC_PROTOBUF_PROVIDER PROPERTY STRINGS "module" "package")
|
|
||||||
set(gRPC_PROTOBUF_PACKAGE_TYPE "" CACHE STRING "Algorithm for searching protobuf package")
|
|
||||||
set_property(CACHE gRPC_PROTOBUF_PACKAGE_TYPE PROPERTY STRINGS "CONFIG" "MODULE")
|
|
||||||
|
|
||||||
-if(gRPC_BUILD_TESTS)
|
|
||||||
+if(gRPC_BUILD_TESTS OR gRPC_BUILD_CLI)
|
|
||||||
set(gRPC_GFLAGS_PROVIDER "module" CACHE STRING "Provider of gflags library")
|
|
||||||
set_property(CACHE gRPC_GFLAGS_PROVIDER PROPERTY STRINGS "module" "package")
|
|
||||||
|
|
||||||
@@ -4278,7 +4279,7 @@ target_link_libraries(b64_test
|
|
||||||
|
|
||||||
|
|
||||||
endif()
|
|
||||||
-if(gRPC_BUILD_TESTS)
|
|
||||||
+if(gRPC_BUILD_TESTS OR gRPC_BUILD_CLI)
|
|
||||||
|
|
||||||
add_executable(bad_server_response_test
|
|
||||||
test/core/end2end/bad_server_response_test.cc
|
|
||||||
@@ -4401,7 +4402,7 @@ target_link_libraries(bin_decoder_test
|
|
||||||
|
|
||||||
|
|
||||||
endif()
|
|
||||||
-if(gRPC_BUILD_TESTS)
|
|
||||||
+if(gRPC_BUILD_TESTS OR gRPC_BUILD_CLI)
|
|
||||||
|
|
||||||
add_executable(bin_encoder_test
|
|
||||||
test/core/transport/chttp2/bin_encoder_test.cc
|
|
||||||
@@ -5167,7 +5168,7 @@ target_link_libraries(fake_resolver_test
|
|
||||||
|
|
||||||
|
|
||||||
endif()
|
|
||||||
-if(gRPC_BUILD_TESTS)
|
|
||||||
+if(gRPC_BUILD_TESTS OR gRPC_BUILD_CLI)
|
|
||||||
|
|
||||||
add_executable(fake_transport_security_test
|
|
||||||
test/core/tsi/fake_transport_security_test.cc
|
|
||||||
@@ -10762,7 +10763,7 @@ target_link_libraries(global_config_test
|
|
||||||
|
|
||||||
|
|
||||||
endif()
|
|
||||||
-if(gRPC_BUILD_TESTS)
|
|
||||||
+if(gRPC_BUILD_TESTS OR gRPC_BUILD_CLI)
|
|
||||||
|
|
||||||
add_executable(grpc_cli
|
|
||||||
${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/reflection/v1alpha/reflection.pb.cc
|
|
22
community/grpc/parse_json-fix-status-error.patch
Normal file
22
community/grpc/parse_json-fix-status-error.patch
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
From d30b04ed7b53f36fded3f94c32ebaed88cfa1232 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Esun Kim <veblush@google.com>
|
||||||
|
Date: Wed, 17 Mar 2021 10:00:44 -0700
|
||||||
|
Subject: [PATCH] Fix status error (#25731)
|
||||||
|
|
||||||
|
---
|
||||||
|
test/cpp/qps/parse_json.cc | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/cpp/qps/parse_json.cc b/test/cpp/qps/parse_json.cc
|
||||||
|
index 8777f171420d..f3ac1052d4d5 100644
|
||||||
|
--- a/test/cpp/qps/parse_json.cc
|
||||||
|
+++ b/test/cpp/qps/parse_json.cc
|
||||||
|
@@ -34,7 +34,7 @@ void ParseJson(const std::string& json, const std::string& type,
|
||||||
|
auto status = JsonToBinaryString(
|
||||||
|
type_resolver.get(), "type.googleapis.com/" + type, json, &binary);
|
||||||
|
if (!status.ok()) {
|
||||||
|
- std::string errmsg(status.error_message());
|
||||||
|
+ std::string errmsg(status.message());
|
||||||
|
gpr_log(GPR_ERROR, "Failed to convert json to binary: errcode=%d msg=%s",
|
||||||
|
status.code(), errmsg.c_str());
|
||||||
|
gpr_log(GPR_ERROR, "JSON: %s", json.c_str());
|
Loading…
Reference in a new issue