mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added extra/ilmbase
This commit is contained in:
parent
5d99a9f6ba
commit
2c9c0eddf0
3 changed files with 62 additions and 0 deletions
38
extra/ilmbase/PKGBUILD
Normal file
38
extra/ilmbase/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
|||
# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
|
||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - ARM patch from https://github.com/openexr/openexr/issues/29
|
||||
|
||||
pkgname=ilmbase
|
||||
pkgver=2.0.0
|
||||
pkgrel=1
|
||||
depends=('gcc-libs')
|
||||
pkgdesc="Base libraries from ILM for OpenEXR"
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.openexr.com"
|
||||
license=('custom')
|
||||
options=('!libtool')
|
||||
source=(http://download.savannah.nongnu.org/releases/openexr/$pkgname-$pkgver.tar.gz
|
||||
arm.patch)
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
patch -p1 -i ../arm.patch
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
# one of the tests fails randomly for an unknown reason
|
||||
make check || true
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
|
||||
}
|
||||
md5sums=('70f1413840c2a228783d1332b8b168e6'
|
||||
'b652c8106907d867a2f52fe93ac6c5ec')
|
12
extra/ilmbase/arm.patch
Normal file
12
extra/ilmbase/arm.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN a/IexMath/IexMathFpu.cpp b/IexMath/IexMathFpu.cpp
|
||||
--- a/IexMath/IexMathFpu.cpp 2013-03-06 16:18:50.000000000 -0700
|
||||
+++ b/IexMath/IexMathFpu.cpp 2013-04-20 19:45:33.400749953 -0600
|
||||
@@ -53,7 +53,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#ifdef HAVE_UCONTEXT_H
|
||||
+#if defined(HAVE_UCONTEXT_H) && (defined(__x86_64__) || defined(__i386__))
|
||||
|
||||
|
||||
#include <ucontext.h>
|
12
extra/ilmbase/ilmbase-IexMath.patch
Normal file
12
extra/ilmbase/ilmbase-IexMath.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- IexMath/IexMathFpu.cpp.orig 2012-07-26 20:51:55.000000000 +0200
|
||||
+++ IexMath/IexMathFpu.cpp 2012-10-04 15:30:47.000000000 +0200
|
||||
@@ -27,8 +27,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#ifdef HAVE_UCONTEXT_H
|
||||
-
|
||||
+#if defined(HAVE_UCONTEXT_H) && (defined(x86_64) || defined(i386_))
|
||||
|
||||
#include <ucontext.h>
|
||||
#include <signal.h>
|
Loading…
Reference in a new issue