mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-odroid-c1 to 3.10.96-1
This commit is contained in:
parent
ad0f934344
commit
2ca5d6ff12
4 changed files with 15 additions and 111 deletions
|
@ -1,7 +1,7 @@
|
||||||
From 9f8c694381ac8c9afabde2e7a2fe4d9b0450dc65 Mon Sep 17 00:00:00 2001
|
From ebf576e456d152ef2f54d58bfb730b4910ad9467 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Tue, 23 Jun 2015 18:02:40 -0600
|
Date: Tue, 23 Jun 2015 18:02:40 -0600
|
||||||
Subject: [PATCH 1/2] gcc 5.1 fix for mac address
|
Subject: [PATCH] gcc 5.1 fix for mac address
|
||||||
|
|
||||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
---
|
---
|
||||||
|
@ -106,5 +106,5 @@ index c39df30..a192128 100644
|
||||||
memcpy(DEFMAC, mac, 6);
|
memcpy(DEFMAC, mac, 6);
|
||||||
g_mac_addr_setup++;
|
g_mac_addr_setup++;
|
||||||
--
|
--
|
||||||
2.7.0
|
2.7.3
|
||||||
|
|
||||||
|
|
|
@ -1,81 +0,0 @@
|
||||||
From 3c717585eb00c0efca07a1a7f29a833db4726e93 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Yevgeny Pats <yevgeny@perception-point.io>
|
|
||||||
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
|
||||||
Subject: [PATCH 2/2] KEYS: Fix keyring ref leak in join_session_keyring()
|
|
||||||
|
|
||||||
This fixes CVE-2016-0728.
|
|
||||||
|
|
||||||
If a thread is asked to join as a session keyring the keyring that's already
|
|
||||||
set as its session, we leak a keyring reference.
|
|
||||||
|
|
||||||
This can be tested with the following program:
|
|
||||||
|
|
||||||
#include <stddef.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <keyutils.h>
|
|
||||||
|
|
||||||
int main(int argc, const char *argv[])
|
|
||||||
{
|
|
||||||
int i = 0;
|
|
||||||
key_serial_t serial;
|
|
||||||
|
|
||||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
|
||||||
"leaked-keyring");
|
|
||||||
if (serial < 0) {
|
|
||||||
perror("keyctl");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
if (keyctl(KEYCTL_SETPERM, serial,
|
|
||||||
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
|
||||||
perror("keyctl");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
for (i = 0; i < 100; i++) {
|
|
||||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
|
||||||
"leaked-keyring");
|
|
||||||
if (serial < 0) {
|
|
||||||
perror("keyctl");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
If, after the program has run, there something like the following line in
|
|
||||||
/proc/keys:
|
|
||||||
|
|
||||||
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
|
||||||
|
|
||||||
with a usage count of 100 * the number of times the program has been run,
|
|
||||||
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
|
||||||
has been garbage collected, then the problem is fixed.
|
|
||||||
|
|
||||||
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
|
||||||
Signed-off-by: David Howells <dhowells@redhat.com>
|
|
||||||
Acked-by: Don Zickus <dzickus@redhat.com>
|
|
||||||
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
|
||||||
Acked-by: Jarod Wilson <jarod@redhat.com>
|
|
||||||
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
|
||||||
---
|
|
||||||
security/keys/process_keys.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
|
||||||
index 42defae..cd871dc 100644
|
|
||||||
--- a/security/keys/process_keys.c
|
|
||||||
+++ b/security/keys/process_keys.c
|
|
||||||
@@ -792,6 +792,7 @@ long join_session_keyring(const char *name)
|
|
||||||
ret = PTR_ERR(keyring);
|
|
||||||
goto error2;
|
|
||||||
} else if (keyring == new->session_keyring) {
|
|
||||||
+ key_put(keyring);
|
|
||||||
ret = 0;
|
|
||||||
goto error2;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.7.0
|
|
||||||
|
|
|
@ -4,12 +4,12 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgbase=linux-odroid-c1
|
pkgbase=linux-odroid-c1
|
||||||
_commit=5dd67345adb61e5a8a77d249b616dc49344f32ef
|
_commit=7ab9b9a07ec7ba32730a099a36b427dad2e32782
|
||||||
_srcname=linux-${_commit}
|
_srcname=linux-${_commit}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ODROID-C1"
|
_desc="ODROID-C1"
|
||||||
pkgver=3.10.80
|
pkgver=3.10.96
|
||||||
pkgrel=22
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="https://github.com/hardkernel/linux"
|
url="https://github.com/hardkernel/linux"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -18,21 +18,18 @@ options=('!strip')
|
||||||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||||
"git+https://github.com/mdrjr/c1_bootini.git"
|
"git+https://github.com/mdrjr/c1_bootini.git"
|
||||||
'0001-gcc-5.1-fix-for-mac-address.patch'
|
'0001-gcc-5.1-fix-for-mac-address.patch'
|
||||||
'0002-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch'
|
|
||||||
'config'
|
'config'
|
||||||
'amlogic.service')
|
'amlogic.service')
|
||||||
md5sums=('242357643ca872f5e877f6b56845bd26'
|
md5sums=('364006e40d0c53ded0d2073f4d4f3c16'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'cc526d3d7ec020f42fd47401f3af0eac'
|
'969cd9ee3116cdd18fed121c87094065'
|
||||||
'ff03cd607742634a7c8e90dc521cb60b'
|
'dddd80ff069133bb5c96caf3b71e20b2'
|
||||||
'5e865f0ab9b6b1ab6f42ad054d7d1078'
|
|
||||||
'b8956789318f49cec5b8bb0b41654a9b')
|
'b8956789318f49cec5b8bb0b41654a9b')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
git apply ../0001-gcc-5.1-fix-for-mac-address.patch
|
git apply ../0001-gcc-5.1-fix-for-mac-address.patch
|
||||||
git apply ../0002-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
|
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Automatically generated file; DO NOT EDIT.
|
# Automatically generated file; DO NOT EDIT.
|
||||||
# Linux/arm 3.10.80-21 Kernel Configuration
|
# Linux/arm 3.10.96-1 Kernel Configuration
|
||||||
#
|
#
|
||||||
CONFIG_ARM=y
|
CONFIG_ARM=y
|
||||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||||
|
@ -3437,12 +3437,13 @@ CONFIG_SND_SOC=y
|
||||||
CONFIG_SND_AML_M8_SOC=y
|
CONFIG_SND_AML_M8_SOC=y
|
||||||
# CONFIG_SND_AML_M_DUMMY_CODEC is not set
|
# CONFIG_SND_AML_M_DUMMY_CODEC is not set
|
||||||
CONFIG_SND_AML_M8=y
|
CONFIG_SND_AML_M8=y
|
||||||
|
CONFIG_SND_ODROID_HIFI1=m
|
||||||
# CONFIG_SND_AML_M8_PCM is not set
|
# CONFIG_SND_AML_M8_PCM is not set
|
||||||
CONFIG_SND_SOC_I2C_AND_SPI=y
|
CONFIG_SND_SOC_I2C_AND_SPI=y
|
||||||
# CONFIG_SND_SOC_ALL_CODECS is not set
|
# CONFIG_SND_SOC_ALL_CODECS is not set
|
||||||
CONFIG_SND_SOC_AML_M8_CODEC=y
|
CONFIG_SND_SOC_AML_M8_CODEC=y
|
||||||
CONFIG_SND_SOC_DUMMY_CODEC=y
|
CONFIG_SND_SOC_DUMMY_CODEC=y
|
||||||
CONFIG_SND_SOC_PCM5102=y
|
CONFIG_SND_SOC_PCM5102=m
|
||||||
# CONFIG_SND_SIMPLE_CARD is not set
|
# CONFIG_SND_SIMPLE_CARD is not set
|
||||||
# CONFIG_SOUND_PRIME is not set
|
# CONFIG_SOUND_PRIME is not set
|
||||||
CONFIG_AC97_BUS=m
|
CONFIG_AC97_BUS=m
|
||||||
|
@ -4403,25 +4404,12 @@ CONFIG_F2FS_FS=y
|
||||||
CONFIG_F2FS_STAT_FS=y
|
CONFIG_F2FS_STAT_FS=y
|
||||||
CONFIG_F2FS_FS_XATTR=y
|
CONFIG_F2FS_FS_XATTR=y
|
||||||
CONFIG_F2FS_FS_POSIX_ACL=y
|
CONFIG_F2FS_FS_POSIX_ACL=y
|
||||||
CONFIG_AUFS_FS=y
|
# CONFIG_AUFS_FS is not set
|
||||||
CONFIG_AUFS_BRANCH_MAX_127=y
|
# CONFIG_AUFS_BRANCH_MAX_127 is not set
|
||||||
# CONFIG_AUFS_BRANCH_MAX_511 is not set
|
# CONFIG_AUFS_BRANCH_MAX_511 is not set
|
||||||
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
|
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
|
||||||
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
|
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
|
||||||
CONFIG_AUFS_SBILIST=y
|
# CONFIG_AUFS_HFSNOTIFY is not set
|
||||||
CONFIG_AUFS_HNOTIFY=y
|
|
||||||
CONFIG_AUFS_HFSNOTIFY=y
|
|
||||||
CONFIG_AUFS_EXPORT=y
|
|
||||||
CONFIG_AUFS_XATTR=y
|
|
||||||
CONFIG_AUFS_FHSM=y
|
|
||||||
CONFIG_AUFS_RDU=y
|
|
||||||
CONFIG_AUFS_SHWH=y
|
|
||||||
CONFIG_AUFS_BR_RAMFS=y
|
|
||||||
CONFIG_AUFS_BR_FUSE=y
|
|
||||||
CONFIG_AUFS_POLL=y
|
|
||||||
CONFIG_AUFS_BR_HFSPLUS=y
|
|
||||||
CONFIG_AUFS_BDEV_LOOP=y
|
|
||||||
# CONFIG_AUFS_DEBUG is not set
|
|
||||||
CONFIG_NETWORK_FILESYSTEMS=y
|
CONFIG_NETWORK_FILESYSTEMS=y
|
||||||
CONFIG_NFS_FS=y
|
CONFIG_NFS_FS=y
|
||||||
CONFIG_NFS_V2=y
|
CONFIG_NFS_V2=y
|
||||||
|
|
Loading…
Reference in a new issue