alarm/kodi-rpi-git to 20.x.60751.a09e05e00a-1

This commit is contained in:
graysky 2022-07-14 11:53:59 -04:00
parent eb2ccf1620
commit 2ccb472ed0
2 changed files with 13 additions and 13 deletions

View file

@ -1,6 +1,6 @@
From b06428ed9945f818095f1b8e725850b2d3b8551b Mon Sep 17 00:00:00 2001
From: graysky <graysky@archlinux.us>
Date: Thu, 10 Mar 2022 17:36:13 -0500
From ff40de29a49bc212a0cdc4ef640effc2bad3cdfe Mon Sep 17 00:00:00 2001
From: graysky <therealgraysky@proton.me>
Date: Thu, 14 Jul 2022 11:19:30 -0400
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
Get build system to patch ffmpeg source removing the -march= flag
@ -10,17 +10,17 @@ Get build system to patch ffmpeg source removing the -march= flag
1 file changed, 1 insertion(+)
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
index 6b957f760e..296ed09968 100644
index 2ad78aa..5a81750 100644
--- a/cmake/modules/FindFFMPEG.cmake
+++ b/cmake/modules/FindFFMPEG.cmake
@@ -97,6 +97,7 @@ macro(buildFFMPEG)
${CMAKE_SOURCE_DIR}/cmake/modules/FindGnuTLS.cmake
@@ -98,6 +98,7 @@ macro(buildFFMPEG)
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/CMakeLists.txt
<SOURCE_DIR> &&
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
echo "########################################## patched ffmpeg ##############################")
echo "########################################## patched ffmpeg ##############################"
)
BUILD_DEP_TARGET()
--
2.35.1
2.37.1

View file

@ -13,8 +13,8 @@ pkgname=(
'kodi-rpi-git-eventclients' 'kodi-rpi-git-tools-texturepacker' 'kodi-rpi-git-dev'
)
_commitnumber=60733
_commit=a7ecb4ca5081b8433b2441eb8cdd7e458bbdee23
_commitnumber=60751
_commit=a09e05e00a25c5d68c80769f29c255194fd974fc
# set this to anything to build with clang
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
@ -78,7 +78,7 @@ noextract=(
"fstrcmp-$_fstrcmp_version.tar.gz"
"libudfread-$_libudfread_version.tar.gz"
)
sha256sums=('904a198d07b838046abdc255d360b77c82a3a42215eb50a748dd65829e8f91d7'
sha256sums=('7c61d2309ca2c32ad185741c274b4ff8a13a313eb8be0625ba9011952597c4ce'
'f38c4a4e7a4f4da6d8e83b8852489aa3bb6588a915dc41f5ee89d9aad305a06e'
'584f62a3896794408d46368e2ecf2c6217ab9c676ce85921b2d68b8961f49dfc'
'719130091e3adc9725ba72df808f24a14737a009dca5a4c38c601c0c76449b62'
@ -91,7 +91,7 @@ sha256sums=('904a198d07b838046abdc255d360b77c82a3a42215eb50a748dd65829e8f91d7'
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
'92d063169017bf9e1770d8a7cce77c0c55d197692d10820a7e4aecad9e58178c'
'16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
'7b9ac44b29462418a3e4bb038995960e5122840048a6f592a7d6a39bbc74a4a6')
'9c58877a1622d582e72f76940848dd19a6999c3e1d814abb79c6d35b6acad908')
prepare() {
[[ -d kodi-build ]] && rm -rf kodi-build