core/initscripts to 2012.07.5-1

This commit is contained in:
Kevin Mihelich 2012-07-29 00:59:04 +00:00
parent 023079dc46
commit 2cfe7ebfd4
4 changed files with 16 additions and 73 deletions

View file

@ -1,28 +0,0 @@
From 55bd14c586f0f64b8ee5515161be1aa1098d3226 Mon Sep 17 00:00:00 2001
From: Dave Reisner <dreisner@archlinux.org>
Date: Tue, 3 Jul 2012 22:28:05 -0400
Subject: [initscripts][PATCH] remove /run/nologin before leaving rc.multi
To: arch-projects@archlinux.org
systemd-186 writes this file when running systemd-tmpfiles, but
initscripts never removes it. This disallows all non-root logins.
Reported-by: Dan McGee <dan@archlinux.org>
Signed-off-by: Dave Reisner <dreisner@archlinux.org>
---
rc.multi | 2 ++
1 file changed, 2 insertions(+)
diff --git a/rc.multi b/rc.multi
index daf2372..7d4acaa 100755
--- a/rc.multi
+++ b/rc.multi
@@ -31,4 +31,6 @@ run_hook multi_end
bootlogd_stop
+rm -f /run/nologin
+
# vim: set ts=2 sw=2 noet:
--
1.7.11.1

View file

@ -5,17 +5,17 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - inittab serial setup for v5/v7
# - patch to adjust naming to ALARM, turn off LEDs on shutdown
# - patch to turn off LEDs on shutdown, remount / rw
pkgname=initscripts
pkgver=2012.06.3
pkgrel=2.1
pkgver=2012.07.5
pkgrel=1
pkgdesc="System initialization/bootup scripts"
arch=('any')
url="http://www.archlinux.org"
license=('GPL2')
groups=('base')
backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown etc/conf.d/wireless)
backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown)
depends=('glibc' 'bash' 'coreutils' 'systemd-tools' 'iproute2' 'ncurses' 'findutils' 'sysvinit')
optdepends=('bridge-utils: Network bridging support'
'dhcpcd: DHCP network configuration'
@ -24,25 +24,19 @@ optdepends=('bridge-utils: Network bridging support'
makedepends=(asciidoc)
install=initscripts.install
source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz"
'0001-remove-run-nologin-before-leaving-rc.multi.patch'
'wireless.conf.d'
'alarm.patch'
'rc.conf')
md5sums=('34493c768b587ac59c6ee7e14f275c1d'
'87f02d111e0c613dd9fc61a9613f9c92'
'027576534885b8d5dded9be546057b12'
'd705daeda72c8635ccb4b906417cde2b'
md5sums=('2e3589c8e0baac7a4ea9e353edbcf26c'
'e7ec1f2d469258b91bbda84284d37c4c'
'c618e099f522f861e08a475f8960a6c2')
package() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -p1 -i "${srcdir}/alarm.patch"
patch -Np1 <"$srcdir/0001-remove-run-nologin-before-leaving-rc.multi.patch"
cp "${srcdir}/rc.conf" .
[ "${CARCH}" == "arm" ] && sed -i 's/@TTY@/ttyS0/' inittab
[ "${CARCH}" == "armv7h" ] && sed -i 's/@TTY@/ttyO2/' inittab
make DESTDIR=${pkgdir} install
install -D -m644 ${srcdir}/wireless.conf.d ${pkgdir}/etc/conf.d/wireless
}

View file

@ -1,6 +1,6 @@
diff -urN a/inittab b/inittab
--- a/inittab 2012-06-29 07:26:59.000000000 -0600
+++ b/inittab 2012-07-15 16:02:29.969505191 -0600
--- a/inittab 2012-07-26 23:19:28.000000000 +0000
+++ b/inittab 2012-07-29 00:48:54.000000000 +0000
@@ -24,12 +24,13 @@
su:S:wait:/sbin/sulogin -p
@ -20,9 +20,9 @@ diff -urN a/inittab b/inittab
# Serial Virtual Console for KVM and others VMs
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux
diff -urN a/rc.shutdown b/rc.shutdown
--- a/rc.shutdown 2012-06-29 07:26:59.000000000 -0600
+++ b/rc.shutdown 2012-07-15 16:02:29.969505191 -0600
@@ -76,6 +76,10 @@
--- a/rc.shutdown 2012-07-26 23:19:28.000000000 +0000
+++ b/rc.shutdown 2012-07-29 00:48:54.000000000 +0000
@@ -69,6 +69,10 @@
run_hook shutdown_poweroff
@ -34,25 +34,14 @@ diff -urN a/rc.shutdown b/rc.shutdown
# decide what we want to do
diff -urN a/rc.sysinit b/rc.sysinit
--- a/rc.sysinit 2012-06-29 07:26:59.000000000 -0600
+++ b/rc.sysinit 2012-07-15 19:59:55.346823548 -0600
@@ -13,8 +13,8 @@
fi
echo " "
-printhl "Arch Linux\n"
-printhl "${C_H2}http://www.archlinux.org"
+printhl "Arch Linux ARM\n"
+printhl "${C_H2}http://www.archlinuxarm.org"
printsep
# mount the api filesystems
@@ -109,7 +109,7 @@
--- a/rc.sysinit 2012-07-26 23:19:28.000000000 +0000
+++ b/rc.sysinit 2012-07-29 00:50:05.000000000 +0000
@@ -99,7 +99,7 @@
fsck_reboot $fsckret
status "Remounting Root and API filesystems" \
status "Remounting root and API filesystems" \
- /usr/lib/systemd/systemd-remount-fs
+ mount -o remount,rw /
# now mount all the local filesystems
# Now mount all the local filesystems
run_hook sysinit_premount

View file

@ -1,12 +0,0 @@
#
# Settings for wireless cards
#
# For each wireless interface declared in INTERFACES (in rc.conf), declare
# a wlan_${IF} variable that contains the arguments to be passed to
# iwconfig(8). Then list the original interface name in the
# WLAN_INTERFACES array.
#
#wlan_eth0="eth0 mode managed essid default"
#WLAN_INTERFACES=(eth0)