mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mesa to 21.1.0-1
This commit is contained in:
parent
02585b7abd
commit
2d84ae603e
3 changed files with 6 additions and 90 deletions
|
@ -1,29 +0,0 @@
|
||||||
From 93eb334093467272ad3028a62c515df3fb88bcb5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
|
|
||||||
Date: Sat, 24 Apr 2021 16:23:43 +0200
|
|
||||||
Subject: [PATCH] amd/common: Add missing line from backport for coherency.
|
|
||||||
|
|
||||||
The line initializing the variable was missed.
|
|
||||||
|
|
||||||
Fixes: ccc4abdbf4b ("ac/gpu_info: fix more non-coherent RB and GL2 combinations")
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
src/amd/common/ac_gpu_info.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/amd/common/ac_gpu_info.c b/src/amd/common/ac_gpu_info.c
|
|
||||||
index 47e6b8c332f..44728827197 100644
|
|
||||||
--- a/src/amd/common/ac_gpu_info.c
|
|
||||||
+++ b/src/amd/common/ac_gpu_info.c
|
|
||||||
@@ -710,6 +710,8 @@ bool ac_query_gpu_info(int fd, void *dev_p, struct radeon_info *info,
|
|
||||||
info->num_tcc_blocks = info->max_tcc_blocks;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ info->tcc_rb_non_coherent = !util_is_power_of_two_or_zero(info->num_tcc_blocks);
|
|
||||||
+
|
|
||||||
info->mc_arb_ramcfg = amdinfo->mc_arb_ramcfg;
|
|
||||||
info->gb_addr_config = amdinfo->gb_addr_cfg;
|
|
||||||
if (info->chip_class >= GFX9) {
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
|
@ -1,40 +0,0 @@
|
||||||
From 960c86d6787437b643825baa230bc0cd7f9f7540 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastian Beranek <bastian.beischer@rwth-aachen.de>
|
|
||||||
Date: Sat, 1 May 2021 09:52:01 +0200
|
|
||||||
Subject: [PATCH] glx: Assign unique serial number to GLXBadFBConfig error
|
|
||||||
|
|
||||||
Since commit f39fd3dce72 a new GLX error is issued in case context creation
|
|
||||||
fails. This broke wine on certain hardware: While wine installs an error handler
|
|
||||||
to ignore this kind of error, it does not function because it expects the
|
|
||||||
dpy->request serial number of the error to be incremented since the installation
|
|
||||||
of the handler.
|
|
||||||
|
|
||||||
Workaround this by artificially increasing the request number. This also
|
|
||||||
guarantees a unique serial number for the error.
|
|
||||||
|
|
||||||
Fixes: f39fd3dce72eaef59ab39a23b75030ef9efc2a40
|
|
||||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/3969
|
|
||||||
Signed-off-by: Bastian Beranek <bastian.beischer@rwth-aachen.de>
|
|
||||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10565>
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
src/glx/create_context.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/glx/create_context.c b/src/glx/create_context.c
|
|
||||||
index e3a513f58f6..7e1cec98c64 100644
|
|
||||||
--- a/src/glx/create_context.c
|
|
||||||
+++ b/src/glx/create_context.c
|
|
||||||
@@ -146,6 +146,9 @@ glXCreateContextAttribsARB(Display *dpy, GLXFBConfig config,
|
|
||||||
* somehow on the client side. clean up the server resource and panic.
|
|
||||||
*/
|
|
||||||
xcb_glx_destroy_context(c, xid);
|
|
||||||
+ /* increment dpy->request in order to give a unique serial number to the
|
|
||||||
+ * error */
|
|
||||||
+ XNoOp(dpy);
|
|
||||||
__glXSendError(dpy, GLXBadFBConfig, xid, 0, False);
|
|
||||||
} else {
|
|
||||||
gc->xid = xid;
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
|
@ -11,8 +11,8 @@
|
||||||
pkgbase=mesa
|
pkgbase=mesa
|
||||||
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-broadcom' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-broadcom' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||||
pkgver=21.0.3
|
pkgver=21.1.0
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||||
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
||||||
|
@ -21,14 +21,10 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence
|
||||||
url="https://www.mesa3d.org/"
|
url="https://www.mesa3d.org/"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||||
0001-amd-common-Add-missing-line-from-backport-for-cohere.patch
|
|
||||||
0001-glx-Assign-unique-serial-number-to-GLXBadFBConfig-er.patch
|
|
||||||
0001-Rip-out-VC4-forced-NEON.patch
|
0001-Rip-out-VC4-forced-NEON.patch
|
||||||
LICENSE)
|
LICENSE)
|
||||||
sha512sums=('4a8aee48a8ea7f32e8aa3bbbd91db26c6053b9a43e62ff88256929e6bc147884f0fef988726b5a3d59d7008663f017c746a0352fd3fcc1c476b8190af4a2531f'
|
sha512sums=('9d7617a6d5dd8ec1d93fdda8fe8b2f745695c02bc381d685f1257f7e7f08d5c06f3c57ae71c5f2dfaabb1742b8a88f47294a369bd3ac553f29835f24ce5dd350'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'f47c227dc888f2030491eaad42d42150539f2c9fc3bbc76d0fd46dc2d85482f520d929b01314cabb963dd36cc3729967f40c7bbfde28fc655024ef52d9fc71b7'
|
|
||||||
'7922e1c444e49f40c36d748f0fc0f76eba11d2d93d9c2f1c1dc4acbc5fe2ebf7c8f954a35265aef6dde3477cc6b5a49502786e1b6f01aa8027f7df215cde816c'
|
|
||||||
'57e23d911d3de9bb4021d3d417270483d6edd53a81ad2d59b4e9cf2a9970901cde582b4a2167ee6d9ed47bd9ca90c3abd4e7cee38c028ad5ad183493560e7faf'
|
'57e23d911d3de9bb4021d3d417270483d6edd53a81ad2d59b4e9cf2a9970901cde582b4a2167ee6d9ed47bd9ca90c3abd4e7cee38c028ad5ad183493560e7faf'
|
||||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||||
|
@ -41,11 +37,6 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
|
||||||
prepare() {
|
prepare() {
|
||||||
cd mesa-$pkgver
|
cd mesa-$pkgver
|
||||||
|
|
||||||
# fix FS#70554 - https://gitlab.freedesktop.org/mesa/mesa/-/issues/4691
|
|
||||||
patch -Np1 -i ../0001-amd-common-Add-missing-line-from-backport-for-cohere.patch
|
|
||||||
# fix FS#70015
|
|
||||||
patch -Np1 -i ../0001-glx-Assign-unique-serial-number-to-GLXBadFBConfig-er.patch
|
|
||||||
|
|
||||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -64,8 +55,7 @@ build() {
|
||||||
-D dri-drivers=r100,r200,nouveau \
|
-D dri-drivers=r100,r200,nouveau \
|
||||||
-D gallium-drivers=r300,r600,radeonsi,freedreno,nouveau,swrast,virgl,zink${GALLIUM} \
|
-D gallium-drivers=r300,r600,radeonsi,freedreno,nouveau,swrast,virgl,zink${GALLIUM} \
|
||||||
-D vulkan-drivers=amd,swrast,broadcom \
|
-D vulkan-drivers=amd,swrast,broadcom \
|
||||||
-D vulkan-overlay-layer=true \
|
-D vulkan-layers=device-select,overlay \
|
||||||
-D vulkan-device-select-layer=true \
|
|
||||||
-D dri3=enabled \
|
-D dri3=enabled \
|
||||||
-D egl=enabled \
|
-D egl=enabled \
|
||||||
-D gallium-extra-hud=true \
|
-D gallium-extra-hud=true \
|
||||||
|
@ -117,11 +107,9 @@ package_vulkan-mesa-layers() {
|
||||||
replaces=('vulkan-mesa-layer')
|
replaces=('vulkan-mesa-layer')
|
||||||
|
|
||||||
_install fakeinstall/usr/share/vulkan/explicit_layer.d
|
_install fakeinstall/usr/share/vulkan/explicit_layer.d
|
||||||
_install fakeinstall/usr/lib/libVkLayer_MESA_overlay.so
|
|
||||||
_install fakeinstall/usr/bin/mesa-overlay-control.py
|
|
||||||
|
|
||||||
_install fakeinstall/usr/share/vulkan/implicit_layer.d
|
_install fakeinstall/usr/share/vulkan/implicit_layer.d
|
||||||
_install fakeinstall/usr/lib/libVkLayer_MESA_device_select.so
|
_install fakeinstall/usr/lib/libVkLayer_*.so
|
||||||
|
_install fakeinstall/usr/bin/mesa-overlay-control.py
|
||||||
|
|
||||||
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
|
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
|
||||||
}
|
}
|
||||||
|
@ -220,9 +208,6 @@ package_mesa() {
|
||||||
_install fakeinstall/usr/lib/lib{gbm,glapi}.so*
|
_install fakeinstall/usr/lib/lib{gbm,glapi}.so*
|
||||||
_install fakeinstall/usr/lib/libOSMesa.so*
|
_install fakeinstall/usr/lib/libOSMesa.so*
|
||||||
|
|
||||||
# in vulkan-headers
|
|
||||||
rm -rfv fakeinstall/usr/include/vulkan
|
|
||||||
|
|
||||||
_install fakeinstall/usr/include
|
_install fakeinstall/usr/include
|
||||||
rm -f fakeinstall/usr/lib/pkgconfig/{egl,gl}.pc
|
rm -f fakeinstall/usr/lib/pkgconfig/{egl,gl}.pc
|
||||||
_install fakeinstall/usr/lib/pkgconfig
|
_install fakeinstall/usr/lib/pkgconfig
|
||||||
|
|
Loading…
Reference in a new issue