mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added community/kitty
This commit is contained in:
parent
1af437694e
commit
2ddaf8adb9
2 changed files with 65 additions and 0 deletions
26
community/kitty/0001-remove-lto.patch
Normal file
26
community/kitty/0001-remove-lto.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From bc83c1571b556c8bb906f34d7f3cbd28f95cd275 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 10 Jul 2018 12:50:51 -0600
|
||||
Subject: [PATCH] remove lto
|
||||
|
||||
---
|
||||
setup.py | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index a05c2539..76ecfb1c 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -211,9 +211,6 @@ def init_env(
|
||||
cppflags += shlex.split(os.environ.get('CPPFLAGS', ''))
|
||||
cflags += shlex.split(os.environ.get('CFLAGS', ''))
|
||||
ldflags += shlex.split(os.environ.get('LDFLAGS', ''))
|
||||
- if not debug and not sanitize:
|
||||
- # See https://github.com/google/sanitizers/issues/647
|
||||
- cflags.append('-flto'), ldflags.append('-flto')
|
||||
|
||||
if profile:
|
||||
cppflags.append('-DWITH_PROFILER')
|
||||
--
|
||||
2.18.0
|
||||
|
39
community/kitty/PKGBUILD
Normal file
39
community/kitty/PKGBUILD
Normal file
|
@ -0,0 +1,39 @@
|
|||
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||
# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
|
||||
# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove lto from hardcoded cflags
|
||||
|
||||
pkgname=kitty
|
||||
pkgver=0.11.3
|
||||
pkgrel=1
|
||||
pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator"
|
||||
arch=('x86_64')
|
||||
url="https://github.com/kovidgoyal/kitty"
|
||||
license=('GPL3')
|
||||
depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11' 'libxkbcommon-x11' 'hicolor-icon-theme' 'libgl')
|
||||
makedepends=('pkg-config' 'python-setuptools' 'libxinerama' 'libxcursor' 'libxrandr' 'libxkbcommon' 'glfw-x11' 'wayland-protocols' 'mesa' 'python-sphinx')
|
||||
optdepends=('imagemagick: viewing images with icat')
|
||||
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz"
|
||||
'0001-remove-lto.patch')
|
||||
sha512sums=('a5b4af74c70222df8ef6a6a8414eb18b7ebc5c959b4031d7a67d636ee912800a2c5fe627c57cf39d9a9eb9c6c1904dbebb4d40575cc8673bf704dd36f58b0783'
|
||||
'61d225a073bd03bf916d41254132025cee4744899c44ac195a039065b345301fdbca6ed5f5ac2328431c3122b4dce6ec8f5057aaddf25e4ea3f2fdc86ce9486f')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../0001-remove-lto.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
python3 setup.py linux-package
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
python3 setup.py linux-package --prefix ${pkgdir}/usr
|
||||
|
||||
install -Dm644 ${pkgdir}/usr/share/icons/hicolor/256x256/apps/kitty.png ${pkgdir}/usr/share/pixmaps/kitty.png
|
||||
}
|
Loading…
Reference in a new issue