mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/sshfs to 3.3.0-4
This commit is contained in:
parent
6b521088c9
commit
2e02fb9bf6
2 changed files with 33 additions and 6 deletions
21
community/sshfs/002-sshfs-3.3.0-sshfs.c.patch
Normal file
21
community/sshfs/002-sshfs-3.3.0-sshfs.c.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff -ura sshfs-3.3.0.orig/sshfs.c sshfs-3.3.0.new/sshfs.c
|
||||
--- sshfs-3.3.0.orig/sshfs.c 2017-09-20 14:08:27.000000000 -0300
|
||||
+++ sshfs-3.3.0.new/sshfs.c 2017-10-01 23:04:23.048755162 -0300
|
||||
@@ -428,9 +428,15 @@
|
||||
FUSE_OPT_KEY("writeback_cache=no", FUSE_OPT_KEY_DISCARD),
|
||||
FUSE_OPT_KEY("unreliable_append", FUSE_OPT_KEY_DISCARD),
|
||||
|
||||
-
|
||||
- FUSE_OPT_END
|
||||
+ /* These may come in from /etc/fstab - we just ignore them */
|
||||
+ FUSE_OPT_KEY("auto", FUSE_OPT_KEY_DISCARD),
|
||||
+ FUSE_OPT_KEY("noauto", FUSE_OPT_KEY_DISCARD),
|
||||
+ FUSE_OPT_KEY("user", FUSE_OPT_KEY_DISCARD),
|
||||
+ FUSE_OPT_KEY("nouser", FUSE_OPT_KEY_DISCARD),
|
||||
+ FUSE_OPT_KEY("users", FUSE_OPT_KEY_DISCARD),
|
||||
+ FUSE_OPT_KEY("_netdev", FUSE_OPT_KEY_DISCARD),
|
||||
|
||||
+ FUSE_OPT_END
|
||||
};
|
||||
|
||||
static struct fuse_opt workaround_opts[] = {
|
|
@ -8,18 +8,20 @@
|
|||
|
||||
pkgname=sshfs
|
||||
pkgver=3.3.0
|
||||
pkgrel=3.1
|
||||
pkgrel=4
|
||||
pkgdesc="FUSE client based on the SSH File Transfer Protocol"
|
||||
arch=(x86_64 i686)
|
||||
url="http://github.com/libfuse/sshfs"
|
||||
license=(GPL)
|
||||
depends=(fuse3 glib2 openssh)
|
||||
makedepends=('meson' 'python-docutils')
|
||||
source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/sshfs-$pkgver.tar.xz{,.asc}
|
||||
001-sshfs-3.3.0-meson.build.patch)
|
||||
source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc}
|
||||
001-sshfs-3.3.0-meson.build.patch
|
||||
002-sshfs-3.3.0-sshfs.c.patch)
|
||||
sha256sums=('9ddfcc2564fafe002706b093b6295afbcb2cc0a3bc52bc805cc5361cb69ca51d'
|
||||
'SKIP'
|
||||
'da928d31291ad86582ab616ea91619c345513dec00f6aafb5bac8f2929159e6b')
|
||||
'da928d31291ad86582ab616ea91619c345513dec00f6aafb5bac8f2929159e6b'
|
||||
'2655139190ee5d2d295afc89a4ae028e78b881ecad9e03fcf9cd1869b2e4e439')
|
||||
validpgpkeys=('ED31791B2C5C1613AF388B8AD113FCAC3C4E599F') # Nikolaus Rath <Nikolaus@rath.org>
|
||||
|
||||
prepare() {
|
||||
|
@ -27,10 +29,14 @@ prepare() {
|
|||
|
||||
# patch meson.build
|
||||
patch -p1 < ../001-sshfs-3.3.0-meson.build.patch
|
||||
|
||||
# patch sshfs.c
|
||||
patch -p1 < ../002-sshfs-3.3.0-sshfs.c.patch
|
||||
|
||||
[[ $CARCH == 'i686' || $CARCH == 'arm' || $CARCH == 'armv6h' || $CARCH == 'armv7h' ]] && export CFLAGS+=" -D_FILE_OFFSET_BITS=64"
|
||||
rm -rf build
|
||||
meson setup --prefix=/usr --sbindir=bin . build
|
||||
mkdir build
|
||||
cd build
|
||||
arch-meson ..
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue