mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/rust to 1.50.0-2
This commit is contained in:
parent
24f18726ae
commit
2e0f0aa433
2 changed files with 63 additions and 3 deletions
55
extra/rust/0001-Change-LLVM-targets.patch
Normal file
55
extra/rust/0001-Change-LLVM-targets.patch
Normal file
|
@ -0,0 +1,55 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Fri, 12 Mar 2021 17:31:56 +0100
|
||||
Subject: [PATCH] Change LLVM targets
|
||||
|
||||
- Change x86_64-unknown-linux-gnu to use x86_64-pc-linux-gnu
|
||||
- Change i686-unknown-linux-gnu to use i686-pc-linux-gnu
|
||||
|
||||
Add aliases to match.
|
||||
---
|
||||
compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs | 2 +-
|
||||
compiler/rustc_target/src/spec/mod.rs | 3 +++
|
||||
compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs | 2 +-
|
||||
3 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
index 083c115d084..2c20bca80bc 100644
|
||||
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
@@ -8,7 +8,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = true;
|
||||
|
||||
Target {
|
||||
- llvm_target: "i686-unknown-linux-gnu".to_string(),
|
||||
+ llvm_target: "i686-pc-linux-gnu".to_string(),
|
||||
pointer_width: 32,
|
||||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 8d72df6850f..367ceab88ee 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -1812,6 +1812,9 @@ macro_rules! target_aliases {
|
||||
}
|
||||
|
||||
target_aliases! {
|
||||
+ ("x86_64-pc-linux-gnu", "x86_64-unknown-linux-gnu"),
|
||||
+ ("i686-pc-linux-gnu", "i686-unknown-linux-gnu"),
|
||||
+
|
||||
// `x86_64-pc-solaris` is an alias for `x86_64_sun_solaris` for backwards compatibility reasons.
|
||||
// (See <https://github.com/rust-lang/rust/issues/40531>.)
|
||||
("x86_64-pc-solaris", "x86_64-sun-solaris"),
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index f127dd49bc4..a958e4fc11d 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -8,7 +8,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = true;
|
||||
|
||||
Target {
|
||||
- llvm_target: "x86_64-unknown-linux-gnu".to_string(),
|
||||
+ llvm_target: "x86_64-pc-linux-gnu".to_string(),
|
||||
pointer_width: 64,
|
||||
data_layout: "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"
|
||||
.to_string(),
|
|
@ -17,9 +17,9 @@ highmem=1
|
|||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.50.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
|
||||
_llvm_ver=11.0.1
|
||||
_llvm_ver=11.1.0
|
||||
|
||||
pkgdesc='Systems programming language focused on safety, speed and concurrency'
|
||||
url='https://www.rust-lang.org/'
|
||||
|
@ -35,12 +35,14 @@ options=('!emptydirs' '!strip')
|
|||
source=(
|
||||
"https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
|
||||
"https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz"{,.sig}
|
||||
0001-Change-LLVM-targets.patch
|
||||
libexec.diff
|
||||
)
|
||||
sha256sums=('95978f8d02bb6175ae3238930baf03563c240aedf9a70bebdc3eaa2a8c3c5a5e'
|
||||
'SKIP'
|
||||
'087be3f1116e861cd969c9b0b0903c27028b52eaf45157276f50a9c2500687fc'
|
||||
'def1fc00c764cd3abbba925c712ac38860a756a43b696b291f46fee09e453274'
|
||||
'SKIP'
|
||||
'66a4792e0169969c23e229d96c88374be0ac24b93ef17102b504892e968959fa'
|
||||
'9ba3070dbc877ab5e045b6a20be9134f80d8aece42766b4cfbad2a4a60c27514')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
|
||||
|
@ -49,6 +51,9 @@ validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag a
|
|||
prepare() {
|
||||
cd "rustc-$pkgver-src"
|
||||
|
||||
# Use our *-pc-linux-gnu targets, making LTO with clang simpler
|
||||
patch -Np1 -i ../0001-Change-LLVM-targets.patch
|
||||
|
||||
# Patch cargo so credential helpers are in /usr/lib instead of /usr/libexec
|
||||
patch -Np1 -i ../libexec.diff
|
||||
|
||||
|
|
Loading…
Reference in a new issue