mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/pacman to 5.2.1-5
This commit is contained in:
parent
e0bd7d513e
commit
2e20d87670
2 changed files with 35 additions and 3 deletions
|
@ -12,7 +12,7 @@
|
||||||
|
|
||||||
pkgname=pacman
|
pkgname=pacman
|
||||||
pkgver=5.2.1
|
pkgver=5.2.1
|
||||||
pkgrel=4
|
pkgrel=5
|
||||||
pkgdesc="A library-based package manager with dependency support"
|
pkgdesc="A library-based package manager with dependency support"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url="https://www.archlinux.org/pacman/"
|
url="https://www.archlinux.org/pacman/"
|
||||||
|
@ -30,7 +30,7 @@ options=('strip' 'debug')
|
||||||
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
|
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
|
||||||
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
|
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
|
||||||
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
||||||
pacman-5.2.1-fix-pactest-package-tar-format.patch::https://git.archlinux.org/pacman.git/patch/?id=b9faf652735c603d1bdf849a570185eb721f11c1
|
pacman-5.2.1-fix-pactest-package-tar-format.patch
|
||||||
makepkg-fix-one-more-file-seccomp-issue.patch
|
makepkg-fix-one-more-file-seccomp-issue.patch
|
||||||
0001-Sychronize-filesystem.patch
|
0001-Sychronize-filesystem.patch
|
||||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||||
|
@ -39,7 +39,7 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
|
||||||
makepkg.conf)
|
makepkg.conf)
|
||||||
sha256sums=('1930c407265fd039cb3a8e6edc82f69e122aa9239d216d9d57b9d1b9315af312'
|
sha256sums=('1930c407265fd039cb3a8e6edc82f69e122aa9239d216d9d57b9d1b9315af312'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'd268379269c9dfa6eb3358f8931d3c84ef5fa4d47fe22567022fcbac8e4638c1'
|
'824a5c9dd458fb27b05a9a0b4b5d75b7a392de0dae79a18f5cfe8beaf4d82f0c'
|
||||||
'e481a161bba76729cd434c97e0b319ddfcb1d93b2e4890d72b4e8a32982531d9'
|
'e481a161bba76729cd434c97e0b319ddfcb1d93b2e4890d72b4e8a32982531d9'
|
||||||
'187bef40b14461ef7caba83e8124b6725e0cc9d46fa84353dae3b2afdc013589'
|
'187bef40b14461ef7caba83e8124b6725e0cc9d46fa84353dae3b2afdc013589'
|
||||||
'83597d3092edb2414d3b1a3e2e7337c0edcf102636a5884f3d3f3755fdceb2b0'
|
'83597d3092edb2414d3b1a3e2e7337c0edcf102636a5884f3d3f3755fdceb2b0'
|
||||||
|
|
|
@ -0,0 +1,32 @@
|
||||||
|
From b9faf652735c603d1bdf849a570185eb721f11c1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Allan McRae <allan@archlinux.org>
|
||||||
|
Date: Tue, 12 Nov 2019 16:14:57 +1000
|
||||||
|
Subject: pactest: set package tar format to GNU_FORMAT
|
||||||
|
|
||||||
|
python-3.8 changed the default tar format to PAX_FORMAT. This caused
|
||||||
|
issues in our testsuite with package extraction of files with UTF-8
|
||||||
|
characters as we run the tests under the C locale.
|
||||||
|
|
||||||
|
sycn600.py:
|
||||||
|
error: error while reading package /tmp/pactest-xuhri4xa/var/cache/pacman/pkg/unicodechars-2.0-1.pkg.tar.gz: Pathname can't be converted from UTF-8 to current locale.
|
||||||
|
|
||||||
|
Set format back to GNU_FORMAT.
|
||||||
|
|
||||||
|
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||||
|
---
|
||||||
|
test/pacman/pmpkg.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/pacman/pmpkg.py b/test/pacman/pmpkg.py
|
||||||
|
index 6a845222..e40868cc 100644
|
||||||
|
--- a/test/pacman/pmpkg.py
|
||||||
|
+++ b/test/pacman/pmpkg.py
|
||||||
|
@@ -142,7 +142,7 @@ class pmpkg(object):
|
||||||
|
util.mkdir(os.path.dirname(self.path))
|
||||||
|
|
||||||
|
# Generate package metadata
|
||||||
|
- tar = tarfile.open(self.path, "w:gz")
|
||||||
|
+ tar = tarfile.open(self.path, "w:gz", format=tarfile.GNU_FORMAT)
|
||||||
|
for name, data in archive_files:
|
||||||
|
info = tarfile.TarInfo(name)
|
||||||
|
info.size = len(data)
|
Loading…
Reference in a new issue