extra/imagemagick: patch fix

This commit is contained in:
Kevin Mihelich 2014-12-31 22:25:59 +00:00
parent 2f13f6e077
commit 2e3c058d40

View file

@ -1,11 +1,18 @@
Index: ImageMagick/branches/ImageMagick-6/coders/palm.c
Index: ImageMagick/branches/ImageMagick-6/coders/rle.c
===================================================================
--- ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17434)
+++ ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17515)
@@ -511,5 +511,5 @@
IndexPacket index=ConstrainColormapIndex(image,(mask-transparentIndex));
if (bits_per_pixel != 16)
- SetMagickPixelPacket(image,image->colormap+index,
+ SetMagickPixelPacket(image,image->colormap+(ssize_t) index,
(const IndexPacket *) NULL,&transpix);
(void) TransparentPaintImage(image,&transpix,(Quantum)
--- ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17434)
+++ ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17516)
@@ -457,5 +457,5 @@
MagickFalse)
break;
- *p=colormap[index];
+ *p=colormap[(ssize_t) index];
p++;
}
@@ -468,5 +468,5 @@
(*p & mask)),&index,exception) == MagickFalse)
break;
- *p=colormap[index];
+ *p=colormap[(ssize_t) index];
p++;
}