mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/imagemagick: patch fix
This commit is contained in:
parent
2f13f6e077
commit
2e3c058d40
1 changed files with 17 additions and 10 deletions
|
@ -1,11 +1,18 @@
|
|||
Index: ImageMagick/branches/ImageMagick-6/coders/palm.c
|
||||
Index: ImageMagick/branches/ImageMagick-6/coders/rle.c
|
||||
===================================================================
|
||||
--- ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17434)
|
||||
+++ ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17515)
|
||||
@@ -511,5 +511,5 @@
|
||||
IndexPacket index=ConstrainColormapIndex(image,(mask-transparentIndex));
|
||||
if (bits_per_pixel != 16)
|
||||
- SetMagickPixelPacket(image,image->colormap+index,
|
||||
+ SetMagickPixelPacket(image,image->colormap+(ssize_t) index,
|
||||
(const IndexPacket *) NULL,&transpix);
|
||||
(void) TransparentPaintImage(image,&transpix,(Quantum)
|
||||
--- ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17434)
|
||||
+++ ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17516)
|
||||
@@ -457,5 +457,5 @@
|
||||
MagickFalse)
|
||||
break;
|
||||
- *p=colormap[index];
|
||||
+ *p=colormap[(ssize_t) index];
|
||||
p++;
|
||||
}
|
||||
@@ -468,5 +468,5 @@
|
||||
(*p & mask)),&index,exception) == MagickFalse)
|
||||
break;
|
||||
- *p=colormap[index];
|
||||
+ *p=colormap[(ssize_t) index];
|
||||
p++;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue