added community/libpgm

This commit is contained in:
Kevin Mihelich 2021-03-27 01:05:47 +00:00
parent f703320ec7
commit 2e5520ec82
2 changed files with 80 additions and 0 deletions

44
community/libpgm/PKGBUILD Normal file
View file

@ -0,0 +1,44 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Vladimir Kirillov <proger@wilab.org.ua>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch from debian to fix error in header used by other programs
pkgname=libpgm
pkgver=5.3.128
_pkgver="${pkgver//./-}"
pkgrel=1
pkgdesc="OpenPGM: implementation of the Pragmatic General Multicast (PGM, RFC3208)"
arch=('x86_64')
url='https://www.freshports.org/net/openpgm/'
license=('LGPL2.1')
depends=('glibc')
makedepends=('python')
options=(!strip)
#source=("http://openpgm.googlecode.com/files/$pkgname-$pkgver.tar.gz")
#source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/openpgm/libpgm-$pkgver.tar.gz")
source=("libpgm-$pkgver.tgz::https://github.com/steve-o/openpgm/archive/release-${_pkgver}.tar.gz"
'inline-pgm_family_string.patch')
sha256sums=('8d707ef8dda45f4a7bc91016d7f2fed6a418637185d76c7ab30b306499c6d393'
'0373d16324605639442d24020e09dcda3e3ab5b86fda7b01c865b49163650706')
prepare() {
cd "$srcdir/openpgm-release-$_pkgver/openpgm/pgm"
2to3 -wn version_generator.py
# 5.3.128 is a little broken
cp openpgm-5.2.pc.in openpgm-5.3.pc.in
patch -p3 -i $srcdir/inline-pgm_family_string.patch
}
build() {
cd "$srcdir/openpgm-release-$_pkgver/openpgm/pgm"
./bootstrap.sh
./configure --prefix=/usr
make
}
package() {
cd "$srcdir/openpgm-release-$_pkgver/openpgm/pgm"
make prefix="$pkgdir/usr" install
}

View file

@ -0,0 +1,36 @@
Description: <short summary of the patch>
TODO: Put a short summary on the line above and replace this paragraph
with a longer explanation of this change. Complete the meta-information
with other relevant fields (see below for details). To make it easier, the
information below has been extracted from the changelog. Adjust it or drop
it.
.
libpgm (5.2.122+git20200619~dfsg-2) UNRELEASED; urgency=medium
.
* Non-maintainer upload.
Author: root <root@julia.lsc.hu>
---
The information above should follow the Patch Tagging Guidelines, please
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
are templates for supplementary fields that you might want to add:
Origin: <vendor|upstream|other>, <url of original patch>
Bug: <url in upstream bugtracker>
Bug-Debian: https://bugs.debian.org/<bugnumber>
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
Forwarded: <no|not-needed|url proving that it has been forwarded>
Reviewed-By: <name and email of someone who approved the patch>
Last-Update: 2020-08-20
--- libpgm-5.2.122+git20200619~dfsg.orig/openpgm/pgm/include/pgm/socket.h
+++ libpgm-5.2.122+git20200619~dfsg/openpgm/pgm/include/pgm/socket.h
@@ -202,7 +202,7 @@ int pgm_wsapoll_info (pgm_sock_t*const r
int pgm_epoll_ctl (pgm_sock_t*const, const int, const int, const int);
#endif
-static
+static inline
const char*
pgm_family_string (
const int family