mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/aircrack-ng
This commit is contained in:
parent
95ae34e43c
commit
2e56b33139
2 changed files with 82 additions and 0 deletions
28
community/aircrack-ng/0001-no-neon.patch
Normal file
28
community/aircrack-ng/0001-no-neon.patch
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
From 766a1b30fe39d397e239e37e77f66fa4cd999722 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Tue, 8 May 2018 23:54:19 +0000
|
||||||
|
Subject: [PATCH] no neon
|
||||||
|
|
||||||
|
---
|
||||||
|
src/Makefile.am | 5 -----
|
||||||
|
1 file changed, 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index 4b0e863f..c1db9e15 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -115,11 +115,6 @@ endif
|
||||||
|
|
||||||
|
pkglibexec_PROGRAMS = aircrack-ng--generic
|
||||||
|
|
||||||
|
-if ARM
|
||||||
|
-pkglibexec_PROGRAMS += aircrack-ng--neon \
|
||||||
|
- aircrack-ng--asimd
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
if PPC
|
||||||
|
pkglibexec_PROGRAMS += aircrack-ng--altivec \
|
||||||
|
aircrack-ng--power8
|
||||||
|
--
|
||||||
|
2.17.0
|
||||||
|
|
54
community/aircrack-ng/PKGBUILD
Normal file
54
community/aircrack-ng/PKGBUILD
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
# $Id$
|
||||||
|
# Maintainer: Jonathan Steel <jsteel at archlinux.org>
|
||||||
|
# Contributor: Brad Fanella <bradfanella@archlinux.us>
|
||||||
|
# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
|
||||||
|
# Contributor: Corrado Primier <bardo@aur.archlinux.org>
|
||||||
|
# Contributor: ice-man <icemanf@gmail.com>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch out NEON variants
|
||||||
|
|
||||||
|
pkgname=aircrack-ng
|
||||||
|
_pkgver=1.2
|
||||||
|
pkgver=${_pkgver//-/}
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="Key cracker for the 802.11 WEP and WPA-PSK protocols"
|
||||||
|
arch=('x86_64')
|
||||||
|
url="https://www.aircrack-ng.org"
|
||||||
|
license=('GPL2')
|
||||||
|
depends=('openssl' 'sqlite' 'iw' 'net-tools' 'wireless_tools' 'ethtool')
|
||||||
|
conflicts=('aircrack-ng-scripts')
|
||||||
|
replaces=('aircrack-ng-scripts')
|
||||||
|
provides=('aircrack-ng-scripts')
|
||||||
|
source=(https://download.aircrack-ng.org/$pkgname-$_pkgver.tar.gz
|
||||||
|
0001-no-neon.patch)
|
||||||
|
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd $pkgname-$_pkgver
|
||||||
|
if [[ $CARCH != "aarch64" ]]
|
||||||
|
patch -p1 -i ../0001-no-neon.patch
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd $pkgname-$_pkgver
|
||||||
|
|
||||||
|
./autogen.sh
|
||||||
|
|
||||||
|
./configure --prefix=/usr
|
||||||
|
|
||||||
|
make sqlite=true experimental=true
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd $pkgname-$_pkgver
|
||||||
|
|
||||||
|
make DESTDIR="$pkgdir" sqlite=true experimental=true \
|
||||||
|
bindir=/usr/bin sbindir=/usr/bin mandir=/usr/share/man/man1/ \
|
||||||
|
smandir=/usr/share/man/man8/ install
|
||||||
|
}
|
||||||
|
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9'
|
||||||
|
'061f085f09de3da97521d7a98b1ddfe3')
|
||||||
|
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9'
|
||||||
|
'ffc5b66caa339222d0af56e615c94bd1')
|
Loading…
Reference in a new issue