extra/chromium to 100.0.4896.75-2

This commit is contained in:
David Beauchamp 2022-04-09 18:15:59 -04:00
parent 88ba5fa67f
commit 2e934a182c
2 changed files with 39 additions and 1 deletions

View file

@ -16,7 +16,7 @@ highmem=1
pkgname=chromium
pkgver=100.0.4896.75
pkgrel=1
pkgrel=2
_launcher_ver=8
_gcc_patchset=4
pkgdesc="A web browser built for speed, simplicity, and security"
@ -38,6 +38,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
webcodecs-stop-using-AudioOpusEncoder.patch
webrtc-check-existence-of-cursor-metadata.patch
enable-GlobalMediaControlsCastStartStop.patch
sql-make-VirtualCursor-standard-layout-type.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
@ -48,6 +49,7 @@ sha256sums=('244ed352dfaa1ab6b1f0877c4884fd17aa7d7133fa52f129a9fb01325ea0c0c0'
'a6120e7d4eb5e131b87b6ab3b922e0c6cd78e15501e54cfb2019875173688d80'
'064daaa2b9d95b96ec04d8ddebf4af441f92263d123365b58fe73966866080af'
'88b2c8d9c6c1917f6632453f18aad7a3fd94d605eecb6c77ae2394ac5856ba95'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'1518b4e3a89594f940f023da84ac3c222efb6f486596c44fe2b92419f15327ab'
@ -125,6 +127,10 @@ prepare() {
patch -Np1 -i ../webcodecs-stop-using-AudioOpusEncoder.patch
patch -Np1 -d third_party/webrtc <../webrtc-check-existence-of-cursor-metadata.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
patch -Rp1 -F3 -i ../enable-GlobalMediaControlsCastStartStop.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch

View file

@ -0,0 +1,32 @@
From b58f0f2725a8c1a8a131f9984b5fd53b54119dba Mon Sep 17 00:00:00 2001
From: Muyao Xu <muyaoxu@google.com>
Date: Thu, 20 Jan 2022 23:46:21 +0000
Subject: [PATCH] [Zenith] Enable GlobalMediaControlsCastStartStop flag by
default
The feature is rolled out to 100% stable through finch for M96+.
This CL enables it by default and fixes some unit tests failures.
Bug: 1287242, 1287305
Change-Id: I7e5c9625b77379fef253c41ef292a0dd6fc366fb
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3388416
Reviewed-by: Takumi Fujimoto <takumif@chromium.org>
Commit-Queue: Muyao Xu <muyaoxu@google.com>
Cr-Commit-Position: refs/heads/main@{#961658}
---
chrome/browser/media/router/media_router_feature.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/chrome/browser/media/router/media_router_feature.cc b/chrome/browser/media/router/media_router_feature.cc
index f28f9b0b802..a8d544f7d6d 100644
--- a/chrome/browser/media/router/media_router_feature.cc
+++ b/chrome/browser/media/router/media_router_feature.cc
@@ -33,7 +33,7 @@ const base::Feature kMediaRouter{"MediaRouter",
const base::Feature kCastAllowAllIPsFeature{"CastAllowAllIPs",
base::FEATURE_DISABLED_BY_DEFAULT};
const base::Feature kGlobalMediaControlsCastStartStop{
- "GlobalMediaControlsCastStartStop", base::FEATURE_DISABLED_BY_DEFAULT};
+ "GlobalMediaControlsCastStartStop", base::FEATURE_ENABLED_BY_DEFAULT};
const base::Feature kAllowAllSitesToInitiateMirroring{
"AllowAllSitesToInitiateMirroring", base::FEATURE_DISABLED_BY_DEFAULT};
const base::Feature kDialMediaRouteProvider{"DialMediaRouteProvider",