From 2f0ee5fb374fedaa1b67112ecbcd75ecd7b3e957 Mon Sep 17 00:00:00 2001
From: Hugo Ferreira <bytter@gmail.com>
Date: Sat, 18 Jan 2014 23:27:52 +0000
Subject: [PATCH] Update config to support LXC (Linux Containers)

These configurations enable usage of `lxc` and `docker` in the raspberrypi. The flags were chosen by running `lxc-checkconfig` and activating the missing features. This is the result of `lxc-checkconfig` before these changes:

```
--- Namespaces ---
Namespaces: enabled
Utsname namespace: enabled
Ipc namespace: enabled
Pid namespace: enabled
User namespace: missing
Network namespace: enabled
Multiple /dev/pts instances: missing

--- Control groups ---
Cgroup: enabled
Cgroup clone_children flag: enabled
Cgroup device: enabled
Cgroup sched: enabled
Cgroup cpu account: enabled
Cgroup memory controller: enabled

--- Misc ---
Veth pair device: missing
Macvlan: enabled
Vlan: enabled
File capabilities: enabled
```
---
 core/linux-raspberrypi-latest/config | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/core/linux-raspberrypi-latest/config b/core/linux-raspberrypi-latest/config
index bac10f705..cec461a16 100644
--- a/core/linux-raspberrypi-latest/config
+++ b/core/linux-raspberrypi-latest/config
@@ -128,7 +128,7 @@ CONFIG_BLK_CGROUP=y
 CONFIG_NAMESPACES=y
 CONFIG_UTS_NS=y
 CONFIG_IPC_NS=y
-# CONFIG_USER_NS is not set
+CONFIG_USER_NS=y
 CONFIG_PID_NS=y
 CONFIG_NET_NS=y
 # CONFIG_UIDGID_STRICT_TYPE_CHECKS is not set
@@ -1322,7 +1322,7 @@ CONFIG_NETPOLL=y
 # CONFIG_NETPOLL_TRAP is not set
 CONFIG_NET_POLL_CONTROLLER=y
 CONFIG_TUN=m
-# CONFIG_VETH is not set
+CONFIG_VETH=m
 # CONFIG_NLMON is not set
 
 #
@@ -1742,7 +1742,7 @@ CONFIG_VT_CONSOLE_SLEEP=y
 CONFIG_HW_CONSOLE=y
 CONFIG_VT_HW_CONSOLE_BINDING=y
 CONFIG_UNIX98_PTYS=y
-# CONFIG_DEVPTS_MULTIPLE_INSTANCES is not set
+CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
 # CONFIG_LEGACY_PTYS is not set
 # CONFIG_SERIAL_NONSTANDARD is not set
 # CONFIG_N_GSM is not set