mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/meson to 0.54.2-1
This commit is contained in:
parent
8f6dd74412
commit
2f2b49e88c
2 changed files with 2 additions and 95 deletions
|
@ -1,88 +0,0 @@
|
|||
From f61bab556a2cf6aae7935f6add8b00657666b5e2 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 30 Mar 2020 01:27:39 +0200
|
||||
Subject: [PATCH] Fix meson_jar_template so test suite passes
|
||||
|
||||
It was generating an extra comma.
|
||||
|
||||
The Meson build system
|
||||
Version: 0.54.0
|
||||
Source dir: /tmp/tmp34halxhe
|
||||
Build dir: /tmp/tmp34halxhe/build
|
||||
Build type: native build
|
||||
|
||||
meson.build:6:15: ERROR: Expecting rparen got comma.
|
||||
'Foo.java',,
|
||||
^
|
||||
For a block that started at 5,3
|
||||
jar('tmp34halxhe',
|
||||
^
|
||||
|
||||
A full log can be found at /tmp/tmp34halxhe/build/meson-logs/meson-log.txt
|
||||
Using "tmp34halxhe" (name of current directory) as project name.
|
||||
Using "tmp34halxhe" (project name) as name of executable to build.
|
||||
Detected source files: Foo.java
|
||||
Detected language: java
|
||||
Generated meson.build file:
|
||||
|
||||
project('tmp34halxhe', 'java',
|
||||
version : '0.1',
|
||||
default_options : ['warning_level=3'])
|
||||
|
||||
jar('tmp34halxhe',
|
||||
'Foo.java',,
|
||||
main_class: tmp34halxhe,
|
||||
install : true)
|
||||
|
||||
It was also missing quotes around the main class name.
|
||||
|
||||
The Meson build system
|
||||
Version: 0.54.0
|
||||
Source dir: /tmp/tmpjm5cg44a
|
||||
Build dir: /tmp/tmpjm5cg44a/build
|
||||
Build type: native build
|
||||
Project name: tmpjm5cg44a
|
||||
Project version: 0.1
|
||||
Java compiler for the host machine: javac (unknown 1.8.0)
|
||||
Host machine cpu family: x86_64
|
||||
Host machine cpu: x86_64
|
||||
|
||||
meson.build:5:0: ERROR: Unknown variable "tmpjm5cg44a".
|
||||
|
||||
A full log can be found at /tmp/tmpjm5cg44a/build/meson-logs/meson-log.txt
|
||||
Using "tmpjm5cg44a" (name of current directory) as project name.
|
||||
Using "tmpjm5cg44a" (project name) as name of executable to build.
|
||||
Detected source files: Foo.java
|
||||
Detected language: java
|
||||
Generated meson.build file:
|
||||
|
||||
project('tmpjm5cg44a', 'java',
|
||||
version : '0.1',
|
||||
default_options : ['warning_level=3'])
|
||||
|
||||
jar('tmpjm5cg44a',
|
||||
'Foo.java',
|
||||
main_class: tmpjm5cg44a,
|
||||
install : true)
|
||||
---
|
||||
mesonbuild/templates/mesontemplates.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/mesonbuild/templates/mesontemplates.py b/mesonbuild/templates/mesontemplates.py
|
||||
index 2739c9d8..6b341a21 100644
|
||||
--- a/mesonbuild/templates/mesontemplates.py
|
||||
+++ b/mesonbuild/templates/mesontemplates.py
|
||||
@@ -27,8 +27,8 @@ meson_jar_template = '''project('{project_name}', '{language}',
|
||||
default_options : [{default_options}])
|
||||
|
||||
jar('{executable}',
|
||||
- {sourcespec},{depspec},
|
||||
- main_class: {main_class},
|
||||
+ {sourcespec},{depspec}
|
||||
+ main_class: '{main_class}',
|
||||
install : true)
|
||||
'''
|
||||
|
||||
--
|
||||
2.26.0
|
||||
|
|
@ -6,7 +6,7 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.54.1
|
||||
pkgver=0.54.2
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
|
@ -21,12 +21,10 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
'python-pytest-xdist') # 'cuda')
|
||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
||||
skip-test.diff
|
||||
0001-Fix-meson_jar_template-so-test-suite-passes.patch
|
||||
arch-meson)
|
||||
sha512sums=('dbc3fed326ba208f5a6eee7e3106d07450e7a3569d425013fba8c51e7cfd6485f9b083836dc74be49bc9839bd640ce54741d9335097cbd28f6a320d5fec7ecfe'
|
||||
sha512sums=('ad5ec826879d3d85088ca40d768599a4c8e66983f2a6a7ebe8ab12051cad18b4ade9a2afd30fe543b0a75900822992c8ef7161d369489e2211dd7a1a8ccc32ed'
|
||||
'SKIP'
|
||||
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
|
||||
'1203c844466409fceb6e3bd4f419762d7dcd460f4dbf412eda7d966b002dd69710af97d9135fc399c71fdcd191aa512bf180e60562f5996932e2827acf591eb2'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
|
@ -35,9 +33,6 @@ prepare() {
|
|||
|
||||
# Our containers do not allow sanitizers to run
|
||||
patch -Np1 -i ../skip-test.diff
|
||||
|
||||
# https://github.com/mesonbuild/meson/pull/6868
|
||||
patch -Np1 -i ../0001-Fix-meson_jar_template-so-test-suite-passes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue