community/gimp-nufraw to 0.43.3-1

This commit is contained in:
Kevin Mihelich 2020-03-21 19:58:46 +00:00
parent bb2c524213
commit 2f91b2126a
4 changed files with 8 additions and 89 deletions

View file

@ -1,10 +0,0 @@
--- nufraw-0.42/nufraw_exiv2.cc.orig 2019-05-18 08:41:34.220544309 +0000
+++ nufraw-0.42/nufraw_exiv2.cc 2019-05-18 08:41:41.170631700 +0000
@@ -20,6 +20,7 @@
#include <exiv2/exif.hpp>
#include <sstream>
#include <cassert>
+#include <iostream>
/*
* Helper function to copy a string to a buffer, converting it from

View file

@ -1,25 +0,0 @@
--- a/nufraw_exiv2.cc
+++ b/nufraw_exiv2.cc
@@ -15,9 +15,7 @@
#include "nufraw.h"
#ifdef HAVE_EXIV2
-#include <exiv2/image.hpp>
-#include <exiv2/easyaccess.hpp>
-#include <exiv2/exif.hpp>
+#include <exiv2/exiv2.hpp>
#include <sstream>
#include <cassert>
@@ -67,7 +65,11 @@
if (exifData.empty()) {
std::string error(uf->filename);
error += ": No Exif data found in the file";
+#if EXIV2_TEST_VERSION(0,27,0)
+ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
+#else
throw Exiv2::Error(1, error);
+#endif
}
/* List of tag names taken from exiv2's printSummary() in actions.cpp */

View file

@ -1,32 +0,0 @@
--- a/dcraw_api.cc 2015-06-16 04:58:38.000000000 +0100
+++ b/dcraw_api.cc 2019-06-30 16:37:05.503409567 +0100
@@ -689,3 +689,3 @@
#pragma omp parallel for schedule(static) default(none) \
- shared(h,dark,rgbWB)
+ firstprivate(black,pixels) shared(h,dark,rgbWB)
#endif
@@ -702,3 +702,3 @@
#pragma omp parallel for schedule(static) default(none) \
- shared(h,dark,rgbWB)
+ firstprivate(black,pixels) shared(h,dark,rgbWB)
#endif
--- a/dcraw_indi.c 2015-06-16 04:58:38.000000000 +0100
+++ b/dcraw_indi.c 2019-06-30 17:03:59.692710441 +0100
@@ -140,2 +140,3 @@
default(none) \
+ firstprivate(iheight,iwidth,noise,threshold) \
shared(nc,image,size,noise) \
@@ -145,2 +146,3 @@
default(none) \
+ firstprivate(iheight,iwidth,noise,threshold) \
shared(nc,image,size) \
@@ -416,2 +418,3 @@
default(none) \
+ firstprivate(colors,filters,height,width) \
shared(image,code,prow,pcol,h) \
@@ -502,3 +502,4 @@
default(none) \
- shared(image,dir,diff) \
+ firstprivate(filters,height,width) \
+ shared(image,dir,diff) \
private(row,col,i,d,c,pix,guess)

View file

@ -4,8 +4,9 @@
# - add -fsigned-char to CXXFLAGS
pkgname=gimp-nufraw
pkgver=0.42
pkgrel=6
_realver=0.43-3
pkgver=0.43.3
pkgrel=1
pkgdesc='Converter for raw files; utility and GIMP plugin'
url='https://sourceforge.net/projects/nufraw/'
arch=('x86_64')
@ -15,26 +16,11 @@ makedepends=('gimp')
conflicts=('gimp-ufraw')
replaces=('gimp-ufraw')
optdepends=('gimp: to use the gimp import plugin for raw images')
source=("https://downloads.sourceforge.net/nufraw/nufraw-$pkgver.tar.gz"
'0001-nufraw-iostream.patch'
'0002-nufraw-exiv2-0.27.patch'
'0003-omp_definitions.patch')
sha256sums=('ddfb592a183618c802e990211f6efce75f4801a7708ecc364666f53af25c9f90'
'fd0120af2cfa8783edd3d91a39b638fbb30ced8c692815be230a302bc55a71ad'
'ec7caabbdaa8fb67097bfb72c26a1140754e184e756ec2013863af37eed67220'
'8f15799e1e682330072f04af4607380b91a55edc9c9f638bdeae1ee3d2318ccf')
source=("https://downloads.sourceforge.net/nufraw/nufraw-${_realver}.tar.gz")
sha256sums=('2c7dcc1590993ec267b3112562b2433010d6f94f6acc6506c76aa29cf8c6c32c')
prepare() {
cd "nufraw-$pkgver"
# Add missing include
patch -p1 -i ../0001-nufraw-iostream.patch
# Fix build with exiv2 0.27 (Gentoo)
patch -p1 -i ../0002-nufraw-exiv2-0.27.patch
# fix '... not specified in enclosing parallel'
patch -p1 -i ../0003-omp_definitions.patch
cd "nufraw-${_realver}"
autoreconf -fi
@ -43,7 +29,7 @@ prepare() {
}
build() {
cd "nufraw-$pkgver"
cd "nufraw-${_realver}"
CXXFLAGS+=" -fsigned-char"
@ -59,7 +45,7 @@ build() {
}
package() {
make -C "nufraw-$pkgver" DESTDIR="$pkgdir" install
make -C "nufraw-${_realver}" DESTDIR="$pkgdir" install
rm -f "$pkgdir/usr/bin/dcraw"
}