mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/pipewire: add patch
This commit is contained in:
parent
5af8bf173e
commit
2f9c865a90
1 changed files with 53 additions and 0 deletions
53
extra/pipewire/0001-disable-neon.patch
Normal file
53
extra/pipewire/0001-disable-neon.patch
Normal file
|
@ -0,0 +1,53 @@
|
|||
From 64a4a456897db045ebf94c2f801b888a172d138a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 24 Oct 2021 17:01:30 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
meson.build | 16 ----------------
|
||||
spa/plugins/support/cpu.c | 2 +-
|
||||
2 files changed, 1 insertion(+), 17 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 7172ee4f5..2251188f8 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -132,22 +132,6 @@ if host_machine.cpu_family() == 'aarch64'
|
||||
have_neon = true
|
||||
|
||||
endif
|
||||
-elif cc.has_argument('-mfpu=neon')
|
||||
- if cc.compiles('''
|
||||
- #include <arm_neon.h>
|
||||
- int main () {
|
||||
- float *s;
|
||||
- asm volatile(
|
||||
- " vld1.32 { q0 }, [%[s]]!\n"
|
||||
- " vcvt.s32.f32 q0, q0, #31\n"
|
||||
- : [s] "+r" (s) : :);
|
||||
- }
|
||||
- ''',
|
||||
- args: '-mfpu=neon',
|
||||
- name : 'arm Neon Support')
|
||||
- neon_args = ['-mfpu=neon']
|
||||
- have_neon = true
|
||||
- endif
|
||||
endif
|
||||
|
||||
libatomic = cc.find_library('atomic', required : false)
|
||||
diff --git a/spa/plugins/support/cpu.c b/spa/plugins/support/cpu.c
|
||||
index ee1816512..44fc279b0 100644
|
||||
--- a/spa/plugins/support/cpu.c
|
||||
+++ b/spa/plugins/support/cpu.c
|
||||
@@ -79,7 +79,7 @@ static char *read_file(const char *name, char *buffer, size_t len)
|
||||
#include "cpu-x86.c"
|
||||
#define init(t) x86_init(t)
|
||||
#define impl_cpu_zero_denormals x86_zero_denormals
|
||||
-# elif defined (__arm__) || defined (__aarch64__)
|
||||
+# elif defined (__aarch64__)
|
||||
#include "cpu-arm.c"
|
||||
#define init(t) arm_init(t)
|
||||
#define impl_cpu_zero_denormals arm_zero_denormals
|
||||
--
|
||||
2.33.0
|
||||
|
Loading…
Reference in a new issue