removed extra/libwebkit

This commit is contained in:
Kevin Mihelich 2011-05-01 22:59:47 -04:00
parent bd728f9712
commit 2fbc442c6a
2 changed files with 0 additions and 67 deletions

View file

@ -1,45 +0,0 @@
# $Id: PKGBUILD 109463 2011-02-09 20:43:10Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# - libtool is disabled for x86 because another tool takes its place for webkit.
# that tool doesn't run on arm, we have to use libtool.
plugrel=1
pkgname=libwebkit
pkgver=1.2.7
pkgrel=1
pkgdesc="an opensource web content engine, derived from KHTML and KJS from KDE"
arch=('i686' 'x86_64')
url="http://webkitgtk.org/"
license=('custom')
depends=('libxt' 'libxslt' 'sqlite3' 'gtk2' 'icu>=4.6' 'gstreamer0.10-base' 'libsoup' 'enchant')
makedepends=('gperf' 'gtk-doc' 'gobject-introspection')
provides=('webkitgtk-svn')
conflicts=('webkitgtk-svn')
replaces=('webkitgtk-svn')
#options=('!libtool')
source=(http://webkitgtk.org/webkit-${pkgver}.tar.gz
introspection.patch)
md5sums=('25c7e548b65aeb6d83c0182c32ef0927'
'e7e83312618cb30cc9a1567a21cd0e06')
build() {
cd "${srcdir}/webkit-${pkgver}"
patch -Np0 -i "${srcdir}/introspection.patch"
./configure --prefix=/usr \
--enable-video --enable-introspection \
--with-font-backend=freetype --enable-gtk-doc \
--enable-jit --with-unicode-backend=icu
#disable makeflags if parallel building fails
make ${MAKEFLAGS}
}
package() {
cd "${srcdir}/webkit-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 WebKit/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

View file

@ -1,22 +0,0 @@
--- WebKit/gtk/JSCore-1.0.gir 2010-09-29 14:54:07.000000000 +0200
+++ WebKit/gtk/JSCore-1.0.gir 2010-09-29 15:57:06.000000000 +0200
@@ -1,12 +1,14 @@
<?xml version="1.0"?>
-<repository version="1.0"
+<repository version="1.2"
xmlns="http://www.gtk.org/introspection/core/1.0"
xmlns:c="http://www.gtk.org/introspection/c/1.0">
<namespace name="JSCore" version="1.0" shared-library="webkit-1.0">
- <alias name="GlobalContextRef"
- target="none"
- c:type="JSGlobalContextRef"/>
- <alias name="ObjectRef" target="none" c:type="JSObjectRef"/>
+ <alias name="GlobalContextRef" target="none">
+ <type name="JSGlobalContextRef" c:type="JSGlobalContextRef"/>
+ </alias>
+ <alias name="ObjectRef" target="none">
+ <type name="JSObjectRef" c:type="JSObjectRef"/>
+ </alias>
<function name="EvaluateScript" c:identifier="JSEvaluateScript">
<return-value transfer-ownership="none">
<type name="none" c:type="void"/>