mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added community/openssh-askpass
This commit is contained in:
parent
24cc425b40
commit
2fe0e0cd0f
3 changed files with 79 additions and 0 deletions
42
community/openssh-askpass/PKGBUILD
Normal file
42
community/openssh-askpass/PKGBUILD
Normal file
|
@ -0,0 +1,42 @@
|
|||
# Maintainer: schuay <jakob.gruber@gmail.com>
|
||||
# Previous Maintainer: TDY <tdy@gmx.com>
|
||||
# Contributor: Massimiliano Torromeo <Massimiliano.Torromeo AT gmail DOT com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix qreal usage on ARM
|
||||
|
||||
pkgname=openssh-askpass
|
||||
pkgver=2.0.0
|
||||
pkgrel=2
|
||||
pkgdesc='A plasma-like passphrase dialog for ssh'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.phenix.bnl.gov/WWW/publish/hpereira/software/index.php?page=package&package_list=software_list_qt4&package=openssh-askpass&full=1'
|
||||
license=('GPL')
|
||||
depends=('openssh' 'qt4')
|
||||
makedepends=('cmake')
|
||||
provides=('x11-ssh-askpass')
|
||||
conflicts=('x11-ssh-askpass')
|
||||
source=("http://www.phenix.bnl.gov/WWW/publish/hpereira/software/tgz/$pkgname-$pkgver.tar.gz"
|
||||
"$pkgname.sh"
|
||||
'arm.patch')
|
||||
md5sums=('99b31e5bc2c12f91cc88869661ad92be'
|
||||
'baec3f0499b851aca6705968fa9e0df7'
|
||||
'c6c1f8d316bf526d1d7d959aafb4d020')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
patch -p1 -i "${srcdir}"/arm.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
||||
cmake -DCMAKE_INSTALL_PREFIX="/usr" ..
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver/build"
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/etc/profile.d/$pkgname.sh"
|
||||
}
|
36
community/openssh-askpass/arm.patch
Normal file
36
community/openssh-askpass/arm.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
diff -urN a/base-qt/CustomPixmap.cpp b/base-qt/CustomPixmap.cpp
|
||||
--- a/base-qt/CustomPixmap.cpp 2013-02-14 15:16:24.000000000 -0700
|
||||
+++ b/base-qt/CustomPixmap.cpp 2013-05-11 10:58:03.071698156 -0600
|
||||
@@ -169,7 +169,7 @@
|
||||
|
||||
Debug::Throw( "CustomPixmap::highlighted.\n" );
|
||||
if( opacity <= 0 ) return *this;
|
||||
- opacity = qMin( opacity, 1.0 );
|
||||
+ opacity = qMin( (double)opacity, 1.0 );
|
||||
|
||||
// compute mask
|
||||
QPixmap mask( *this );
|
||||
diff -urN a/base-qt/PathEditor_p.h b/base-qt/PathEditor_p.h
|
||||
--- a/base-qt/PathEditor_p.h 2013-02-14 02:02:20.000000000 -0700
|
||||
+++ b/base-qt/PathEditor_p.h 2013-05-11 11:04:16.119694794 -0600
|
||||
@@ -67,7 +67,7 @@
|
||||
{ mouseOver_ = value; }
|
||||
|
||||
//! border width
|
||||
- static const qreal BorderWidth;
|
||||
+ static const double BorderWidth;
|
||||
|
||||
protected:
|
||||
|
||||
diff -urN a/base-qt/PlacesWidget_p.h b/base-qt/PlacesWidget_p.h
|
||||
--- a/base-qt/PlacesWidget_p.h 2013-03-15 10:32:24.000000000 -0600
|
||||
+++ b/base-qt/PlacesWidget_p.h 2013-05-11 11:18:43.734230867 -0600
|
||||
@@ -131,7 +131,7 @@
|
||||
//@}
|
||||
|
||||
//! border width
|
||||
- static const qreal BorderWidth;
|
||||
+ static const double BorderWidth;
|
||||
|
||||
protected:
|
||||
|
1
community/openssh-askpass/openssh-askpass.sh
Normal file
1
community/openssh-askpass/openssh-askpass.sh
Normal file
|
@ -0,0 +1 @@
|
|||
export SSH_ASKPASS=/usr/bin/qt4-ssh-askpass
|
Loading…
Reference in a new issue