mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/openimageio to 1.8.14-2.1
This commit is contained in:
parent
253edd9272
commit
2fe575ba79
2 changed files with 7 additions and 40 deletions
|
@ -2,32 +2,21 @@
|
|||
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed intel-tbb from deps
|
||||
# - patch to explicitly link against libatomic for v5/v6
|
||||
# - link against libatomic for v5/v6
|
||||
|
||||
pkgname=openimageio
|
||||
pkgver=1.8.14
|
||||
pkgrel=2
|
||||
pkgrel=2.1
|
||||
pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
|
||||
arch=(x86_64)
|
||||
url="http://www.openimageio.org/"
|
||||
license=('custom')
|
||||
depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio' 'openssl' 'libpng')
|
||||
depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio' 'intel-tbb' 'openssl' 'libpng')
|
||||
makedepends=('cmake' 'qt5-base' 'python2' 'boost' 'mesa' 'git' 'freetype2' 'fontconfig' 'libxrender')
|
||||
optdepends=('qt5-base: iv image viewer'
|
||||
'python2: bindings support')
|
||||
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver}
|
||||
atomic.patch)
|
||||
md5sums=('SKIP'
|
||||
'a495ba4917d4a100dab54738c092e029')
|
||||
|
||||
prepare() {
|
||||
cd oiio
|
||||
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
patch -p1 -i ../atomic.patch
|
||||
fi
|
||||
}
|
||||
source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver})
|
||||
md5sums=('SKIP')
|
||||
|
||||
build() {
|
||||
cd oiio
|
||||
|
@ -35,6 +24,8 @@ build() {
|
|||
[[ -d build ]] && rm -r build
|
||||
mkdir build && cd build
|
||||
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && LDFLAGS="-latomic $LDFLAGS"
|
||||
|
||||
# Python is currently broken :(
|
||||
cmake .. \
|
||||
-DUSE_PYTHON=ON \
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
diff -urN a/src/libOpenImageIO/CMakeLists.txt b/src/libOpenImageIO/CMakeLists.txt
|
||||
--- a/src/libOpenImageIO/CMakeLists.txt 2018-03-29 18:30:02.061880022 -0600
|
||||
+++ b/src/libOpenImageIO/CMakeLists.txt 2018-03-29 18:31:08.701755694 -0600
|
||||
@@ -109,7 +109,7 @@
|
||||
${SANITIZE_LIBRARIES}
|
||||
${format_plugin_libs} # Add all the target link libraries from the plugins
|
||||
${Boost_LIBRARIES}
|
||||
- ${CMAKE_DL_LIBS})
|
||||
+ ${CMAKE_DL_LIBS} atomic)
|
||||
|
||||
|
||||
# Include OpenColorIO if using it
|
||||
diff -urN a/src/libutil/CMakeLists.txt b/src/libutil/CMakeLists.txt
|
||||
--- a/src/libutil/CMakeLists.txt 2018-03-29 18:30:01.021881953 -0600
|
||||
+++ b/src/libutil/CMakeLists.txt 2018-03-29 18:30:19.753847129 -0600
|
||||
@@ -46,7 +46,7 @@
|
||||
|
||||
add_executable (atomic_test atomic_test.cpp)
|
||||
set_target_properties (atomic_test PROPERTIES FOLDER "Unit Tests")
|
||||
- target_link_libraries (atomic_test OpenImageIO_Util ${Boost_LIBRARIES} ${CMAKE_DL_LIBS})
|
||||
+ target_link_libraries (atomic_test OpenImageIO_Util ${Boost_LIBRARIES} ${CMAKE_DL_LIBS} atomic)
|
||||
add_test (unit_atomic atomic_test)
|
||||
|
||||
add_executable (array_view_test array_view_test.cpp)
|
Loading…
Reference in a new issue