extra/lrs to 073-1

This commit is contained in:
Kevin Mihelich 2024-05-31 12:53:59 +00:00
parent af52c19f87
commit 2ff2bfb055
4 changed files with 42 additions and 31 deletions

15
extra/lrs/.SRCINFO Normal file
View file

@ -0,0 +1,15 @@
pkgbase = lrs
pkgdesc = C implementation of the reverse search algorithm for vertex enumeration/convex hull problems
pkgver = 073
pkgrel = 1
url = http://cgm.cs.mcgill.ca/~avis/C/lrs.html
arch = x86_64
license = GPL-2.0-or-later
depends = glibc
depends = gmp
source = http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/lrslib-073.tar.gz
source = lrs-system-cflags.patch
sha256sums = c49a4ebd856183473d1d5a62785fcdfe1057d5d671d4b96f3a1250eb1afe4e83
sha256sums = 617ed06ae2584ef3349a3b1f6ab1a4acd11f18211394458498e1223a65bb0e73
pkgname = lrs

View file

@ -0,0 +1,4 @@
[lrs]
source = 'regex'
url = 'http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/'
regex = 'lrslib-([\d.a-z]+)\.tar'

View file

@ -1,36 +1,27 @@
--- makefile.orig 2022-03-31 07:06:10.873873950 -0600
+++ makefile 2022-03-31 07:08:04.717729216 -0600
@@ -8,10 +8,10 @@
#try uncommenting next line if cc is the default C compiler
CC = gcc # or gcc7
--- makefile.orig 2024-05-31 06:48:10.051261886 -0600
+++ makefile 2024-05-31 06:49:58.003425835 -0600
@@ -24,14 +24,14 @@
#PLRSFLAGS=
-default: lrs lrsgmp lrsnash checkpred inedel
+#default: lrs lrsgmp lrsnash checkpred inedel
#choose line below instead if __int128 not supported
-#default: lrs64 lrsgmp
+default: lrs64 lrsgmp
#make lrs lrs,lrsgmp hybrid and gmp versions
#make lrs64 lrs,lrsgmp compilers without 128 bit support
@@ -45,12 +45,12 @@
# for 32 bit machines
-# BITS=
-# MPLRSOBJ2=
+BITS=
+MPLRSOBJ2=
# for 64 bit machines
#compilers supporting _int128 (eg gcc 4.2 and later)
-BITS=-DB128
-MPLRSOBJ2=lrslib2-mplrs.o lrslong2-mplrs.o
-LRSOBJ2=lrslib2.o lrslong2.o
+#BITS=-DB128
+#MPLRSOBJ2=lrslib2-mplrs.o lrslong2-mplrs.o
+#LRSOBJ2=lrslib2.o lrslong2.o
#compilers without _int128 support (equivalent to make lrs64 in v.7.2)
-#BITS=
-#MPLRSOBJ2=
-#LRSOBJ2=
+BITS=
+MPLRSOBJ2=
+LRSOBJ2=
LRSOBJ=lrs.o lrslong1.o lrslong2.o lrslib1.o lrslib2.o lrslibgmp.o lrsgmp.o lrsdriver.o
@@ -216,11 +216,11 @@
#legacy lrs and mplrs
#CFLAGS = -g -Wall -I ${ARITH}
@@ -231,11 +231,11 @@
SHLIB ?=$(SONAME)$(SOMINOR)
SHLINK ?=liblrs.so

View file

@ -4,20 +4,21 @@
# - patch to fix up makefile for 32-bit builds
pkgname=lrs
pkgver=072
pkgver=073
_pkgver=${pkgver/./}
pkgrel=1
pkgdesc='C implementation of the reverse search algorithm for vertex enumeration/convex hull problems'
arch=(x86_64)
url='http://cgm.cs.mcgill.ca/~avis/C/lrs.html'
license=(GPL)
depends=(gmp)
license=(GPL-2.0-or-later)
depends=(glibc
gmp)
source=(http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/lrslib-$_pkgver.tar.gz
lrs-system-cflags.patch
32-bit-support.patch)
sha256sums=('fc48754a1ded1d8445d40ecfbe3546e4f27d53aaee95dc2c8c0c79fb9cd532f0'
sha256sums=('c49a4ebd856183473d1d5a62785fcdfe1057d5d671d4b96f3a1250eb1afe4e83'
'617ed06ae2584ef3349a3b1f6ab1a4acd11f18211394458498e1223a65bb0e73'
'9d8ae8d964c7f2342cdeab105776963aea5d7e20db656b0e87b0290593859dc9')
'09ec4ed0d3e5894ef9542f18db76d5f9c5dd5d88013ee54765a54279911cf3f3')
prepare() {
cd lrslib-$_pkgver