mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/openssl(-cryptodev): removed our patch, no longer needed
This commit is contained in:
parent
8645cbae68
commit
304fab58e7
4 changed files with 4 additions and 38 deletions
|
@ -29,13 +29,11 @@ provides=("openssl=${pkgver}")
|
|||
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch'
|
||||
'alarm.patch')
|
||||
'ca-dir.patch')
|
||||
md5sums=('a1da58ce63baef3812004714fa302c47'
|
||||
'ca6bcd8641957df69c6c0bb4b93785aa'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'5c6b1cb3fc9bb0a3e5da0a973df76b33')
|
||||
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$_pkgname-$_ver
|
||||
|
@ -55,8 +53,6 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# get rid of ia32 crap
|
||||
patch -p1 -i $srcdir/alarm.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS -DHASH_MAX_LEN=64 \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff -urN a/crypto/evp/e_rc4_hmac_md5.c b/crypto/evp/e_rc4_hmac_md5.c
|
||||
--- a/crypto/evp/e_rc4_hmac_md5.c 2012-04-18 11:51:33.000000000 -0600
|
||||
+++ b/crypto/evp/e_rc4_hmac_md5.c 2012-04-19 12:10:44.435615332 -0600
|
||||
@@ -289,8 +289,7 @@
|
||||
|
||||
const EVP_CIPHER *EVP_rc4_hmac_md5(void)
|
||||
{
|
||||
- extern unsigned int OPENSSL_ia32cap_P[];
|
||||
/* RC4_CHAR flag ------------vvvvv */
|
||||
- return(OPENSSL_ia32cap_P[0]&(1<<20) ? NULL : &r4_hmac_md5_cipher);
|
||||
+ return(&r4_hmac_md5_cipher);
|
||||
}
|
||||
#endif
|
|
@ -23,13 +23,11 @@ backup=('etc/ssl/openssl.cnf')
|
|||
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch'
|
||||
'alarm.patch')
|
||||
'ca-dir.patch')
|
||||
md5sums=('a1da58ce63baef3812004714fa302c47'
|
||||
'ca6bcd8641957df69c6c0bb4b93785aa'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'5c6b1cb3fc9bb0a3e5da0a973df76b33')
|
||||
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$_ver
|
||||
|
@ -49,8 +47,6 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# get rid of ia32 crap
|
||||
patch -p1 -i $srcdir/alarm.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
shared zlib enable-md2 \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff -urN a/crypto/evp/e_rc4_hmac_md5.c b/crypto/evp/e_rc4_hmac_md5.c
|
||||
--- a/crypto/evp/e_rc4_hmac_md5.c 2012-04-18 11:51:33.000000000 -0600
|
||||
+++ b/crypto/evp/e_rc4_hmac_md5.c 2012-04-19 12:10:44.435615332 -0600
|
||||
@@ -289,8 +289,7 @@
|
||||
|
||||
const EVP_CIPHER *EVP_rc4_hmac_md5(void)
|
||||
{
|
||||
- extern unsigned int OPENSSL_ia32cap_P[];
|
||||
/* RC4_CHAR flag ------------vvvvv */
|
||||
- return(OPENSSL_ia32cap_P[0]&(1<<20) ? NULL : &r4_hmac_md5_cipher);
|
||||
+ return(&r4_hmac_md5_cipher);
|
||||
}
|
||||
#endif
|
Loading…
Reference in a new issue