mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-kirkwood-dt to 5.10.16-1
This commit is contained in:
parent
05ca8e72b0
commit
30780b58e5
9 changed files with 22 additions and 102 deletions
|
@ -1,25 +0,0 @@
|
|||
From 311bb4a115f653ff9f3202873303483007906c8f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 31 Aug 2014 08:45:13 -0600
|
||||
Subject: [PATCH] disable mv643xx_eth TSO
|
||||
|
||||
---
|
||||
drivers/net/ethernet/marvell/mv643xx_eth.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/net/ethernet/marvell/mv643xx_eth.c b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
index b151a94..e04af62 100644
|
||||
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
@@ -3110,7 +3110,7 @@ static int mv643xx_eth_probe(struct platform_device *pdev)
|
||||
dev->watchdog_timeo = 2 * HZ;
|
||||
dev->base_addr = 0;
|
||||
|
||||
- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
|
||||
+ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
|
||||
dev->vlan_features = dev->features;
|
||||
|
||||
dev->features |= NETIF_F_RXCSUM;
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 27316c3bd9c9aa2058edda79b2d8b9663b0bb7a0 Mon Sep 17 00:00:00 2001
|
||||
From 815a8519e8bafe22ea3ba78425370015c9dc3ca7 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:32:06 -0700
|
||||
Subject: [PATCH 1/7] leds: trigger: Introduce a SATA trigger
|
||||
Subject: [PATCH 1/6] leds: trigger: Introduce a SATA trigger
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 8cadc8ea5d5576c2b8b96b499937b7096c0b34e2 Mon Sep 17 00:00:00 2001
|
||||
From 49fc8ed68c36250c9edf04593e1c7430ffa1b14c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:34:33 -0700
|
||||
Subject: [PATCH 2/7] ata: sata_mv: Add SATA activity LED trigger support
|
||||
Subject: [PATCH 2/6] ata: sata_mv: Add SATA activity LED trigger support
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 1fa882e4c70e69eeefbc8d288275f9d6fee92d8d Mon Sep 17 00:00:00 2001
|
||||
From 588ee98661962e65f42cc634522f05d4a980eb6f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:37:08 -0700
|
||||
Subject: [PATCH 3/7] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on
|
||||
Subject: [PATCH 3/6] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From a56c64e1b36e0cbc4736489667611d538ba033a5 Mon Sep 17 00:00:00 2001
|
||||
From 3c45ed3c4b028c22998f0f79ac8cd891444e8a3b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:38:04 -0700
|
||||
Subject: [PATCH 4/7] Fix mvsdio SD card detection
|
||||
Subject: [PATCH 4/6] Fix mvsdio SD card detection
|
||||
|
||||
Helps SD card detection on PPv4.
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 9f07c9b93aa7ae53fc1ad026eff47662f2f49560 Mon Sep 17 00:00:00 2001
|
||||
From 2b68b108d918d45d4b986f7d5006d1a8b4839bf8 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:42:40 -0700
|
||||
Subject: [PATCH 5/7] ARM: dts: kirkwood: Initial support for GoFlex Home
|
||||
Subject: [PATCH 5/6] ARM: dts: kirkwood: Initial support for GoFlex Home
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 4517a0f64d12498830f16b61bf6e871c8ba636ff Mon Sep 17 00:00:00 2001
|
||||
From 993e972df1ed50a12ed3fc9f743ee89e85cb7530 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 25 Feb 2018 16:45:51 -0700
|
||||
Subject: [PATCH 6/7] Revert "vfs,mm: fix a dead loop in
|
||||
Subject: [PATCH 6/6] Revert "vfs,mm: fix a dead loop in
|
||||
truncate_inode_pages_range()"
|
||||
|
||||
This reverts commit c2a9737f45e27d8263ff9643f994bda9bac0b944.
|
||||
|
@ -13,10 +13,10 @@ device.
|
|||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/mm/filemap.c b/mm/filemap.c
|
||||
index 0b2067b3c328..f5be2ee65e90 100644
|
||||
index 125b69f59caa..8c2aedc1e3ae 100644
|
||||
--- a/mm/filemap.c
|
||||
+++ b/mm/filemap.c
|
||||
@@ -2197,10 +2197,6 @@ ssize_t generic_file_buffered_read(struct kiocb *iocb,
|
||||
@@ -2201,10 +2201,6 @@ ssize_t generic_file_buffered_read(struct kiocb *iocb,
|
||||
unsigned int prev_offset;
|
||||
int error = 0;
|
||||
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
From 6a6dfc24ba04d438864d4726646506b82eeb7ef3 Mon Sep 17 00:00:00 2001
|
||||
From: Chuck Lever <chuck.lever@oracle.com>
|
||||
Date: Sun, 31 Jan 2021 16:16:23 -0500
|
||||
Subject: [PATCH 7/7] SUNRPC: Fix NFS READs that start at non-page-aligned
|
||||
offsets
|
||||
|
||||
Anj Duvnjak reports that the Kodi.tv NFS client is not able to read
|
||||
video files from a v5.10.11 Linux NFS server.
|
||||
|
||||
The new sendpage-based TCP sendto logic was not attentive to non-
|
||||
zero page_base values. nfsd_splice_read() sets that field when a
|
||||
READ payload starts in the middle of a page.
|
||||
|
||||
The Linux NFS client rarely emits an NFS READ that is not page-
|
||||
aligned. All of my testing so far has been with Linux clients, so I
|
||||
missed this one.
|
||||
|
||||
Reported-by: A. Duvnjak <avian@extremenerds.net>
|
||||
BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=211471
|
||||
Fixes: 4a85a6a3320b ("SUNRPC: Handle TCP socket sends with kernel_sendpage() again")
|
||||
Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
|
||||
Tested-by: A. Duvnjak <avian@extremenerds.net>
|
||||
---
|
||||
net/sunrpc/svcsock.c | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
|
||||
index 4404c491eb38..fa7b7ae2c2c5 100644
|
||||
--- a/net/sunrpc/svcsock.c
|
||||
+++ b/net/sunrpc/svcsock.c
|
||||
@@ -1113,14 +1113,15 @@ static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
|
||||
unsigned int offset, len, remaining;
|
||||
struct bio_vec *bvec;
|
||||
|
||||
- bvec = xdr->bvec;
|
||||
- offset = xdr->page_base;
|
||||
+ bvec = xdr->bvec + (xdr->page_base >> PAGE_SHIFT);
|
||||
+ offset = offset_in_page(xdr->page_base);
|
||||
remaining = xdr->page_len;
|
||||
flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
|
||||
while (remaining > 0) {
|
||||
if (remaining <= PAGE_SIZE && tail->iov_len == 0)
|
||||
flags = 0;
|
||||
- len = min(remaining, bvec->bv_len);
|
||||
+
|
||||
+ len = min(remaining, bvec->bv_len - offset);
|
||||
ret = kernel_sendpage(sock, bvec->bv_page,
|
||||
bvec->bv_offset + offset,
|
||||
len, flags);
|
||||
--
|
||||
2.30.0
|
||||
|
|
@ -7,7 +7,7 @@ pkgbase=linux-kirkwood-dt
|
|||
_srcname=linux-5.10
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=5.10.14
|
||||
pkgver=5.10.16
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -22,20 +22,18 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
|||
'0004-Fix-mvsdio-SD-card-detection.patch'
|
||||
'0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch'
|
||||
'0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch'
|
||||
'0007-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
|
||||
md5sums=('753adc474bf799d569dec4f165ed92c3'
|
||||
'd928049c6149ed507afbb72c90cb2dc2'
|
||||
'a6b4d912185d05ce8da3c197a8819c67'
|
||||
'6fd639f9b8c27a517493aaf6648f6b96'
|
||||
'2127d09de35cb87b4704d62e2d2affdc'
|
||||
'43f8997ea02d1a5143c02c7a47536129'
|
||||
'4d188618504694ca6cc8db3eb0a6aee9'
|
||||
'238a66247da0f9a57d179027e94f8cfa'
|
||||
'70e6dad899f235ce620eddac81165cbf'
|
||||
'6eb3cfa9872f7c0cbc59e5c17eca854c'
|
||||
'e40bf085efefa138fd99acf2c0126046'
|
||||
'88d6dc4194c27a430b2af75fe4ce794e'
|
||||
'a0424cf77acdea9e1a97f03a7ed61b39'
|
||||
'9cd58d353f1d5e87a9f1c0fa089d12e3'
|
||||
'3dadee14c9cf70ff8b3a9b3fde9e12fa'
|
||||
'e0f9c16ccc1492cb7e0e7ab46f5e1731'
|
||||
'bcee56942897ee4f0253619843859b7f'
|
||||
'959e49540dac4c5e689ad9037150a360'
|
||||
'79fa396e3f9a09a85156d6d7c2d34b58')
|
||||
|
@ -52,7 +50,6 @@ prepare() {
|
|||
git apply ../0004-Fix-mvsdio-SD-card-detection.patch
|
||||
git apply ../0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch
|
||||
git apply ../0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch
|
||||
git apply ../0007-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
Loading…
Reference in a new issue